Filer på delte nettverksressurser åpnes sakte, åpnes som skrivebeskyttet, eller du får en feilmelding

Artikkeloversettelser Artikkeloversettelser
Artikkel-ID: 814112 - Vis produkter som denne artikkelen gjelder for.
Viktig!  Denne artikkelen inneholder informasjon som viser hvordan du kan få hjelp til å redusere sikkerhetsinnstillinger eller hvordan du deaktiverer sikkerhetsfunksjoner på en datamaskin. Du kan gjøre disse endringene for å omgå et bestemt problem. Før du gjør disse endringene, anbefaler vi at du evaluerer risikoen som er knyttet til implementering av denne løsningen i ditt bestemte miljø. Hvis du implementerer denne løsningen, må du gjøre det som er nødvendig for å beskytte systemet.
Vis alt | Skjul alt

Symptom

Ett av følgende symptomer kan oppstå:
  • Når du kopierer en fil over et nettverk i Microsoft Windows XP, kan du få en av følgende feilmeldinger hvis kildefilen finnes på en Microsoft Windows 2000-basert delt nettverksressurs:
    Filen eller nettverksbanen finnes ikke lenger.
    Ingen nettverkstjenester godtok den oppgitte nettverksbanen.
  • Når du prøver å åpne en fil fra en delt nettverksressurs, kan det ta lenger tid enn forventet å åpne filen.
  • Du kan få ulike feilmeldinger eller andre problemer kan oppstå når du bruker et program som åpner og lukker filer, eller som oppretter midlertidige filer på serveren, hvis den Windows 2000-baserte serveren har aktivert SMB-signering (Server Message Block).
  • En fil du åpnet over nettverket, åpnes som skrivebeskyttet, eller det oppstår brudd på delingstillatelse slik at du må lagre filen lokalt for å gjøre endringer.

    Dette problemet kan oppstå selv om tillatelsene er angitt som Alle tillatelser for både den delte ressursen og volumet som bruker NTFS-filsystemet, og ingen andre brukere har filen åpen. I dette tilfellet vil du kanskje se en av følgende feilmeldinger:
    Fil i bruk: Filnavn er låst for redigering av brukernavn. Velg Varsle hvis du vil åpne en skrivebeskyttet kopi av dokumentet, og motta en melding når dokumentet ikke lenger er i bruk.
    Denne kommandoen er ikke tilgjengelig fordi dokumentet er låst for redigering.
    Dokumentet filnavn er låst for redigering av en annen bruker. Hvis du vil åpne en skrivebeskyttet kopi av dokumentet, klikker du ...
    Filen er låst for redigering. Vil du åpne en skrivebeskyttet versjon av filen?
    Kan ikke åpne filnavndelt nettverksressurs. Kontroller at en disk er i stasjonen du angav.
    Ingen tilgang. Filen kan være i bruk av et annet program.
  • Når du åpner filer, kan det hende at du kan åpne to filer i programmer som Microsoft Excel eller Microsoft PowerPoint, mens feilmeldingen "Skrivebeskyttet" vises når du åpner en tredje fil.
  • Når du åpner eller lukker filer, kan det se ut som at nettverksprogrammer som avhenger av mye inn-/utdata for nettverksfiler, slutter å svare, eller det kan oppstå forsinkelser.
  • Det kan oppstå problemer når Windows XP bruker gruppepolicyer eller kjører påloggingsskript.
  • Du kan bare lagre en Microsoft Office-fil ved å bruke det samme filnavnet etter at filen har vært åpen i minst 30 minutter.
  • Du kan også få andre feilmeldinger, avhengig av programmet du bruker. Du kan for eksempel få feilmeldinger som angir at en fil allerede er i bruk, eller at en fil bare kan åpnes som skrivebeskyttet.

Årsak

Dette problemet kan oppstå hvis et av følgende forhold er til stede:
  • Det har oppstått et problem med tilpassing av SMB-signering fra en klient som kjører Microsoft Windows XP Service Pack 1 (SP1) på en Windows 2000-basert server som krever SMB-signering.
  • Filen er åpen og låst i en annen prosess. Dette problemet kan for eksempel være forårsaket av et av følgende elementer:
    • Nettverksmappen er åpen i Microsoft Windows Utforsker, og du bruker detaljvisning til å vise flere detaljer (for eksempel forfatter eller tittel) for filer i mappen. Windows Utforsker leser innholdet i filene i mappen for å hente flere detaljer. Hvis et program prøver å åpne en fil eksklusivt, og Windows Utforsker har nettverksfilen åpen for å hente denne ekstra filinformasjonen, oppstår det brudd på delingstillatelse.
    • Filen kan være låst i et annet program eller en annen prosess, for eksempel et antivirusprogram (på klientdatamaskinen eller serveren).

Løsning

Advarsel!  Denne løsningen kan gjøre datamaskinen eller nettverket mer utsatt for angrep fra brukere med onde hensikter eller skadelig programvare, for eksempel virus. Denne løsningen anbefales ikke, men denne informasjonen oppgis slik at du kan velge å implementere løsningen på eget initiativ. Bruk denne løsningen på eget ansvar.

Obs!  Antivirusprogrammer er utviklet for å beskytte datamaskinen mot virus. Du må ikke laste ned eller åpne filer fra kilder du ikke stoler på, gå til webområder du ikke er trygg på, eller åpne e-postvedlegg når antivirusprogrammet er deaktivert.

Hvis du vil ha mer informasjon om datamaskinvirus, klikker du følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
129972Datamaskinvirus: beskrivelse, forebygging og gjenoppretting
Slik løser du dette problemet:
  1. Last ned og installer sikkerhetsoppdateringen MS02-070 som er beskrevet i Microsoft Knowledge Base-artikkel 329170, på alle Windows 2000-baserte og Windows XP-baserte filservere og klientdatamaskiner.

    Hvis du vil ha mer informasjon om denne oppdateringen, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
    329170 MS02-070: Feil i SMB-signering kan tillate at gruppepolicy endres
  2. Oppgrader alle Windows XP-baserte klientdatamaskiner til Windows XP Service Pack 1 (SP1), og skaff og installer deretter hurtigreparasjonene som er beskrevet i Microsoft Knowledge Base-artiklene 328170 og 812937.

    Hvis du vil ha mer informasjon om hvordan du får tak i Windows XP SP1, kan du klikke artikkelnummeret nedenfor for å vise artikkelen i Microsoft Knowledge Base:
    322389 Slik får du tak i den seneste oppdateringspakken for Windows XP
    Hvis du vil ha mer informasjon om hvordan du anskaffer hurtigreparasjonene, kan du klikke artikkelnumrene nedenfor for å vise artiklene i Microsoft Knowledge Base:
    812937 Filen låser seg, eller feilmelding om at tilgang er avslått, når du lagrer filer på nettverket (denne artikkelen kan være på engelsk)
    328170 Programmet åpner en fil som skrivebeskyttet eller returnerer en melding om brudd på delingstillatelse eller meldingen "Ingen tilgang" ved åpning fra eller lagring til en nettverksmappe (denne artikkelen kan være på engelsk)
  3. Hvis problemet ikke er løst, deaktiverer du skanning av nettverksstasjon i antivirusprogrammet. Hvis du vil deaktivere antivirusprogrammet, kan du se i dokumentasjonen for antivirusprogrammet eller den elektroniske hjelpen for å informasjon om hvordan du gjør dette.

    Hvis problemet fremdeles ikke er løst, deaktiverer du antivirusprogrammet midlertidig. Noen ganger må du kanskje fjerne antivirusprogrammet på både klienten og serveren for å kunne feilsøke dette problemet. Hvis du ikke løser problemet ved å fjerne eller deaktivere antivirusprogrammet, kontakter du produsenten av antivirusprogrammet for å få mer informasjon om dette problemet og hvilken fremgangsmåte du må følge for å løse problemet. Du kan for eksempel gå til følgende webområder for tredjeparter for å få informasjon om hvordan du løser dette problemet med bestemte antivirussprodukter:
    http://www.trendmicro.com/en/products/desktop/tav/evaluate/overview.htm
    http://service1.symantec.com/SUPPORT/ent-security.nsf/552ba2f7636bedf088256818006f78bf/3c71b1248df4580688256ba4007383dd?OpenDocument&sone=nav_76_ce_tasks.html&stg=&prod=Norton%20AntiVirus%20Corporate%20Edition&ver=7.6&base=&next=&src=ent&pcode=nav_ce&dtype=corp&svy=&prev=
    Microsoft tilbyr kontaktopplysninger for tredjeparter, noe som hjelper deg med å finne teknisk kundestøtte. Disse kontaktopplysningene kan endres uten varsel. Microsoft garanterer ikke nøyaktigheten til disse kontaktopplysningene om tredjeparter.

Mer informasjon

Spor fra overvåkingsprogrammet Network Monitor kan vise feilmeldingen "DOS Error, (5) ACCESS_DENIED" eller "DOS Error, (32) SHARING_VIOLATION" etter 35 sekunder (mellom kommandoene "SMB: C NT create & X" for samme filnavn). Hvor lenge serveren skal vente på et Oplock Break-svar, styres av
LanmanServer
-parameteren
OplockBreakWait
. Som standard er denne parameteren angitt til 35 sekunder.

Hvis du vil ha mer informasjon om hvordan du omgår påloggingsforsinkelser, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
319440 Påloggingsforsinkelser over trege koblinger hvis operasjonslås ikke gis for policyfilen (denne artikkelen kan være på engelsk)

Referanser

Hvis du vil ha mer informasjon, kan du klikke følgende artikkelnumre for å vise artiklene i Microsoft Knowledge Base:
306981 Operasjonslåser på nivå II gis ikke etter at en fil er låst (denne artikkelen kan være på engelsk)
324002 Filer kan forbli åpne etter søk etter filer over et nettverk (denne artikkelen kan være på engelsk)
296264 Konfigurere opportunistisk låsing i Windows (denne artikkelen kan være på engelsk)
812513 Det tar uventet lang tid å åpne en fil via SMB-protokollen (denne artikkelen kan være på engelsk)
829700 Treg nettverksytelse når du åpner en fil som er plassert i en delt mappe på en datamaskin på et eksternt nettverk (denne artikkelen kan være på engelsk)
826722 Kan ikke slette snarvei på en delt nettverksressurs: "Filen brukes av en annen person eller et annet program"
822227 Programmet kan generere et brudd på delingstillatelse når en fil åpnes fra Windows Utforsker (denne artikkelen kan være på engelsk)
811005 Brukergodkjenning til tjenester som for eksempel Microsoft Exchange Server, kan bli tidsavbrutt på medlemsserveren (denne artikkelen kan være på engelsk)

Egenskaper

Artikkel-ID: 814112 - Forrige gjennomgang: 1. desember 2007 - Gjennomgang: 6.3
Informasjonen i denne artikkelen gjelder:
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 2002 Standard Edition
Nøkkelord: 
kberrmsg kbnetwork kbprb KB814112

Gi tilbakemelding

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com