Súbory v zdieľaných sieťových priečinkoch sa otvárajú pomaly, majú príznak Iba na čítanie alebo sa zobrazí chybové hlásenie

Preklady článku Preklady článku
ID článku: 814112 - Zobraziť produkty, ktorých sa tento článok týka.
Dôležité upozornenie: Tento článok obsahuje postupy, ktoré vedú k oslabeniu zabezpečenia počítača alebo k vypnutiu funkcií zabezpečenia v počítači. Vykonaním týchto zmien môžete vyriešiť špecifické problémy. Pred vykonaním zmien sa však odporúča vyhodnotiť riziká spojené s nasadením tohto riešenia v konkrétnom prostredí. Ak sa rozhodnete tento postup použiť, vykonajte všetky dodatočné opatrenia na ochranu systému.
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

Môže sa vyskytnúť niektorý z nasledovných príznakov:
  • Ak kopírujete súbor prostredníctvom siete v systéme Microsoft Windows XP a zdrojový súbor sa nachádza v zdieľanom sieťovom priečinku v systéme Microsoft Windows 2000, zobrazí sa niektoré z nasledovných chybových hlásení:
    Súbor alebo sieťová cesta už neexistuje.
    Žiaden zo sprostredkovateľov siete neakceptoval zadanú sieťovú cestu.
  • Ak sa pokúsite súbor otvoriť zo zdieľaného sieťového priečinka, otvorenie súboru trvá príliš dlho.
  • Ak používate program, ktorý otvára a zatvára súbory alebo vytvára dočasné súbory na serveri so systémom Windows 2000 so zapnutým podpisovaním blokov hlásení servera (SMB), zobrazia sa rôzne chybové hlásenia alebo sa vyskytnú ďalšie problémy.
  • Súbor v sieti sa otvorí s príznakom Iba na čítanie alebo dôjde k porušeniu zdieľania. Ak chcete vykonať zmeny, je nutné súbor uložiť v miestom počítači.

    Tieto problémy sa môžu vyskytnúť aj v prípade, že máte povolenia nastavené na hodnotu Úplný prístup pre zdieľanú položku aj zväzok používajúci systém súborov NTFS a daný súbor nie je otvorený žiadnym ďalším používateľom. V takom prípade sa môže zobraziť jedno z nasledovných chybových hlásení:
    Súbor sa práve používa: Súbor názov_súboru uzamkol pre úpravy používateľ meno_používateľa. Kliknutím na tlačidlo Oznámiť otvoríte kópiu dokumentu v režime „Iba na čítanie“ a keď bude dokument k dispozícii, zobrazí sa príslušný oznam.
    Tento príkaz nie je k dispozícii, pretože je dokument uzamknutý a nedá sa upravovať.
    Dokument názov_súboru je uzamknutý iným používateľom a nedá sa upravovať. Ak chcete otvoriť kópiu tohto dokumentu určenú iba na čítanie, kliknite na...
    Súbor je uzamknutý a nedá sa upravovať. Chcete otvoriť verziu súboru určenú iba na čítanie?
    Nemožno otvoriť názov_súboru v zdieľaný_sieťový_priečinok. Presvedčte sa, či sa v zadanej jednotke nachádza disk.
    Prístup bol odmietnutý. Súbor pravdepodobne používa iná aplikácia.
  • Niektoré programy, napríklad Microsoft Excel alebo Microsoft PowerPoint, môžu úspešne otvoriť dva súboru, no po otvorení tretieho zobrazia chybové hlásenie s informáciou o tom, že súbor možno otvoriť iba na čítanie.
  • Sieťové programy, ktoré spracovávajú veľké množstvo vstupov a výstupov v sieťových súboroch, môžu zdanlivo prestať reagovať, prípadne pri otváraní alebo zatváraní súborov dochádza k oneskoreniu.
  • Ak systém Windows XP použije politiku skupiny alebo spustí prihlasovacie skripty, môžu sa vyskytnúť problémy.
  • Súbor balíka Microsoft Office možno uložiť pod rovnakým názvom len v prípade, ak bol otvorený najmenej 30 minút.
  • V závislosti od používaného programu sa môžu zobraziť aj ďalšie chybové hlásenia. Môže sa napríklad zobraziť chybové hlásenie s informáciou o tom, že súbor sa už používa alebo ho možno otvoriť iba na čítanie.

PRICINA

Tento problém môže nastať v prípade splnenia jednej z nasledovných podmienok:
  • Vyskytol sa problém pri vyjednávaní podpisovania blokov SMB medzi klientom so systémom Microsoft Windows XP s balíkom Service Pack 1 (SP1) a serverom so systémom Windows 2000, ktorý vyžaduje podpisovanie blokov SMB.
  • Súbor bol otvorený a uzamknutý iným procesom. Tento problém môže byť spôsobený napríklad niektorou z nasledovných príčin:
    • Sieťový priečinok je otvorený v programe Prieskumník a pomocou zobrazenia Podrobnosti ste zobrazili podrobnosti súborov v priečinku (napríklad autora alebo názov). Program Prieskumník prečíta obsah súborov v priečinku, aby získal ďalšie podrobnosti. Ak sa program pokúsi otvoriť súbor výhradne a program Prieskumník tento sieťový súbor otvoril za účelom získania ďalších informácií o súbore, nastane porušenie zdieľania.
    • Súbor mohol byť uzamknutý iným programom alebo procesom, napríklad antivírusovým programom (v klientskom počítači alebo na serveri).

RIESENIE

Upozornenie: Tento postup môže oslabiť zabezpečenie počítača alebo siete voči útokom používateľov so zlým úmyslom alebo nebezpečnému softvéru, ako sú napríklad vírusy. Toto riešenie sa neodporúča, no poskytujeme tieto informácie, s pomocou ktorých môžete riešenie implementovať podľa vlastného uváženia. Toto riešenie používate na vlastné riziko.

Poznámka: Antivírusový program je určený na ochranu počítača pred vírusmi. Ak je antivírusový program v počítači vypnutý, nemali by ste preberať ani otvárať súbory zo zdrojov, ktorým nedôverujete, navštevovať nedôveryhodné lokality ani otvárať e-mailové prílohy.

Ďalšie informácie o počítačových vírusoch nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:
129972Počítačové vírusy: popis, prevencia a obnovenie (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
Pri odstraňovaní tohto problému postupujte nasledovne:
  1. Prevezmite aktualizáciu zabezpečenia MS02-070, ktorú popisuje článok 329170 databázy Microsoft Knowledge Base, a nainštalujte ju na všetky súborové servery a klientske počítače so systémom Windows 2000 a Windows XP.

    Ďalšie informácie o tejto aktualizácii nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:
    329170 MS02-070: Porucha zabezpečenia podpisovania SMB môže umožniť zmenu politiky skupiny (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
  2. Inovujte všetky klientske počítače so systémom Windows XP balíkom Service Pack 1 (SP1) pre tento systém a potom prevezmite a nainštalujte rýchle opravy, ktoré popisujú články 328170 a 812937 databázy Microsoft Knowledge Base.

    Ďalšie informácie o možnostiach získania balíka Windows XP SP1 nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:
    322389 Ako získať najnovší balík Windows XP Service Pack (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
    Ďalšie informácie o možnostiach získania týchto rýchlych opráv nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:
    812937 Pri ukladaní súboru prostredníctvom siete sa súbor uzamkne alebo sa zobrazí chybové hlásenie s informáciou o zamietnutí prístupu (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
    328170 Pri otváraní alebo ukladaní súboru v sieťovom priečinku program otvorí súbor iba na čítanie alebo vráti hlásenie s informáciou o narušení zdieľania alebo zamietnutí prístupu (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
  3. Ak sa vám problém nepodarilo odstrániť, zakážte kontrolu sieťovej jednotky v antivírusovom programe. Informácie o príslušnom postupe nájdete v dokumentácii k antivírusovému programu alebo v Pomocníkovi online.

    Ak sa vám problém nepodarilo ani po tomto kroku odstrániť, dočasne vypnite antivírusový program. V niektorých prípadoch bude na odstránenie tohto problému potrebné odstrániť antivírusový program v klientskom aj serverom počítači. Ak sa problém odstránením alebo vypnutím antivírusového programu vyriešil, obráťte sa na výrobcu antivírusového programu so žiadosťou o ďalšie informácie týkajúce sa tohto problému a možných postupov jeho odstránenia. Informácie o riešení uvedeného problému týkajúce sa konkrétnych antivírusových produktov môžete získať na nasledovných webových lokalitách iných výrobcov:
    http://kb.trendmicro.com/solutions/solutionDetail.asp?solutionID=10781
    http://service1.symantec.com/SUPPORT/ent-security.nsf/552ba2f7636bedf088256818006f78bf/3c71b1248df4580688256ba4007383dd?OpenDocument&sone=nav_76_ce_tasks.html&stg=&prod=Norton%20AntiVirus%20Corporate%20Edition&ver=7.6&base=&next=&src=ent&pcode=nav_ce&dtype=corp&svy=&prev=
    Na uľahčenie vyhľadania technickej podpory poskytuje spoločnosť Microsoft kontaktné informácie na iných výrobcov. Tieto kontaktné informácie sa môžu zmeniť bez predchádzajúceho upozornenia. Spoločnosť Microsoft neručí za správnosť týchto kontaktných informácií iných výrobcov.

DALSIE INFORMACIE

Pri trasovaní programu Sledovanie siete sa môžu zobraziť chybové hlásenia: Chyba systému DOS, (5) ACCESS_DENIED alebo Chyba systému DOS, (32) SHARING_VIOLATION po 35 sekundách (medzi príkazmi SMB: C NT create & X v rovnakom názve súboru). Doba, počas ktorej server čaká na odpoveď prerušenia Oplock, je riadená hodnotou
OplockBreakWait
parametra
LanmanServer
. V predvolenom nastavení je hodnota tohto parametra nastavená na 35 sekúnd.

Ďalšie informácie o možnostiach riešenia oneskorenia pri prihlasovaní získate po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
319440 Ak súboru politiky nie je udelené prerušenie Oplock, dochádza pri pomalom pripojení k oneskoreniu pri prihlasovaní (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)

ODKAZY

Ďalšie informácie získate po kliknutí na nasledovné čísla článkov publikovaných v databáze Microsoft Knowledge Base:
306981 Po uzamknutí súboru sa nepridelia prerušenia oplock úrovne 2 (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
324002 Pri vyhľadávaní súborov v sieti môžu súbory zostať otvorené (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
296264 Konfigurácia príležitostného uzamykania v systéme Windows (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
812513 Otvorenie súboru pomocou protokolu SMB (Server Message Block) trvá neočakávane dlho (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
829700 Pomalý výkon siete pri otváraní súboru umiestneného v zdieľanom priečinku vo vzdialenom sieťovom počítači (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
826722 Odkaz v zdieľanom sieťovom priečinku nie je možné odstrániť, pretože je používaný iným používateľom alebo programom (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
822227 Pri otvorení súboru v programe Prieskumník zobrazí program chybové hlásenie o narušení zdieľania (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
811005 Pri overovaní používateľov v službách, ako je napríklad Microsoft Exchange Server, môže na strane členského servera uplynúť časový limit (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)

Vlastnosti

ID článku: 814112 - Posledná kontrola: 1. decembra 2007 - Revízia: 4.5
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 2002 Standard Edition
Kľúčové slová: 
kberrmsg kbnetwork kbprb KB814112

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com