แฟ้มบนเครือข่ายการแบ่งปันเปิดได้ช้าลง เปิดเป็นแบบอ่านอย่างเดียว หรือคุณได้รับข้อความแสดงข้อผิดพลาด

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 814112 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
สิ่งสำคัญบทความนี้ประกอบด้วยข้อมูลที่แสดงวิธีการที่ช่วยให้การตั้งค่าการรักษาความปลอดภัยที่ต่ำหรือวิธีการปิดคุณลักษณะการรักษาความปลอดภัยบนเครื่องคอมพิวเตอร์ คุณสามารถเปลี่ยนแปลงการตั้งค่าเหล่านี้ เพื่อแก้ปัญหาเฉพาะแต่ละอย่างได้ ก่อนที่คุณจะเปลี่ยนแปลงการตั้งค่าเหล่านี้ เราขอแนะนำให้คุณประเมินความเสี่ยงที่เกี่ยวข้องกับการใช้วิธีแก้ปัญหานี้ในสภาพแวดล้อมของคุณ หากคุณดำเนินการนี้ โปรดดำเนินการตามขั้นตอนเสริม เพื่อช่วยป้องกันระบบของคุณ
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

คุณอาจพบอาการอย่างใดอย่างหนึ่งต่อไปนี้::
  • เมื่อคุณคัดลอกแฟ้มบนเครือข่ายใน Windows XP ถ้าแฟ้มต้นฉบับจะอยู่บนเครือข่ายที่ใช้ Microsoft Windows 2000 ใช้ร่วมกัน คุณอาจได้รับข้อความใดข้อความแสดงข้อผิดพลาดต่อไปนี้:
    เส้นทางของแฟ้มหรือเครือข่ายที่ไม่มีอยู่
    ผู้ให้บริการเครือข่ายไม่ยอมรับเส้นทางเครือข่ายที่กำหนด
  • เมื่อคุณพยายามเปิดแฟ้มจากเครือข่ายใช้ร่วมกัน แฟ้มอาจใช้เวลานานเกินกว่าที่คาดว่าจะเปิดขึ้น
  • คุณอาจได้รับข้อความแสดงข้อผิดพลาดต่าง ๆ หรือประสบปัญหาอื่น ๆ เมื่อคุณใช้โปรแกรมที่เปิด และปิดแฟ้ม หรือที่สร้างแฟ้มชั่วคราวบนเซิร์ฟเวอร์ถ้าเซิร์ฟเวอร์ที่ใช้ Windows 2000 ที่มีการบล็อกข้อความเซิร์ฟเวอร์ (SMB) เซ็นชื่อในการเปิดใช้งานอยู่
  • มีเปิดแฟ้มที่คุณเปิดในเครือข่ายเป็นแบบอ่านอย่างเดียว หรือเกิดการละเมิดการใช้งานร่วมกัน และคุณต้องบันทึกแฟ้มภายในเพื่อทำการเปลี่ยนแปลง

    ปัญหานี้อาจเกิดขึ้นแม้ว่าสิทธิ์ของคุณถูกตั้งค่าเป็น Full Control สำหรับทั้งใช้ร่วมกันและไดรฟ์ข้อมูลที่ใช้ระบบแฟ้ม NTFS และไม่มีผู้ใช้อื่นได้เปิดแฟ้ม ในกรณีนี้ คุณอาจได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้อย่างใดอย่างหนึ่ง:
    แฟ้มที่ใช้:FileName :ถูกล็อกเพื่อแก้ไขโดยชื่อผู้ใช้. คลิก 'แจ้งให้ทราบ' เพื่อเปิดสำเนาแบบอ่านอย่างเดียวของเอกสาร และได้รับการแจ้งเตือนเมื่อเอกสารไม่ถูกใช้
    คำสั่งนี้ไม่พร้อมใช้งานได้เนื่องจากเอกสารถูกล็อกเพื่อแก้ไข
    เอกสารFileName :ถูกล็อกเพื่อแก้ไขโดยผู้ใช้อื่น เมื่อต้องการเปิดสำเนาแบบอ่านอย่างเดียวของเขาเอกสาร คลิ...
    แฟ้มถูกล็อกเพื่อแก้ไข คุณต้องการเปิดแฟ้มรุ่นแบบอ่านอย่างเดียว
    เปิดไม่ได้FileName :บนเครือข่ายที่ใช้ร่วมกัน. ตรวจสอบให้แน่ใจว่า ดิสก์ในไดรฟ์คุณระบุ
    ปฏิเสธการเข้าใช้งาน แฟ้มอาจถูกใช้โดยโปรแกรมประยุกต์อื่น
  • เมื่อคุณเปิดแฟ้ม โปรแกรมเช่น Microsoft Excel หรือ Microsoft PowerPoint อาจเปิดแฟ้มที่สองได้สำเร็จ แต่แสดงข้อความข้อผิดพลาด "อ่านอย่างเดียว" เมื่อคุณเปิดแฟ้มของบุคคลที่สามเป็น
  • เมื่อคุณเปิด หรือ เมื่อคุณปิดแฟ้ม โปรแกรมเครือข่ายที่ใช้กับแฟ้มเครือข่ายหนาอินพุต/เอาท์พุต (I/O) อาจอาจหยุดการตอบสนอง หรือความล่าช้าที่อาจเกิดขึ้น
  • คุณอาจพบปัญหาเมื่อ Windows XP ใช้นโยบายกลุ่ม หรือเรียกใช้สคริปต์การเข้าสู่ระบบ
  • คุณสามารถบันทึกแฟ้ม Microsoft Office โดยใช้ชื่อแฟ้มเดียวกันเท่านั้นหลังจากที่คุณมีแฟ้มเปิดน้อยกว่า 30 นาที
  • คุณอาจได้รับข้อความอื่น ๆ เกิดข้อผิดพลาด ขึ้นอยู่กับโปรแกรมที่คุณกำลังใช้อยู่ For example, you may receive error messages that indicate that a file is already in use or that a file can be opened only as read-only.

สาเหตุ

This issue may occur if any one of the following conditions is true:
  • There is an issue with negotiating SMB signing from a client that is running Microsoft Windows XP Service Pack 1 (SP1) to a Windows 2000-based server that requires SMB signing.
  • Another process has the file open and locked. For example, this issue may be caused by either of the following items:
    • The network folder is open in Microsoft Windows Explorer and you are using Details view to display additional details (such as the author or title) for files in the folder. Windows Explorer reads the contents of the files in the folder to obtain the additional details. If a program tries to open a file exclusively and Windows Explorer has the network file open to extract this additional file information, a sharing violation occurs.
    • Another program or process, such as an antivirus program (either on the client computer or on the server), may have the file locked.

การแก้ไข

คำเตือนวิธีแก้ปัญหานี้อาจทำให้คอมพิวเตอร์ของคุณหรือเครือข่ายของคุณเสี่ยงการโจมตี โดยผู้ใช้ที่ประสงค์ร้าย หรือซอฟต์แวร์ที่เป็นอันตรายเช่นไวรัส เราไม่แนะนำให้คุณใช้วิธีนี้ เพียงแต่เสนอข้อมูลนี้เพื่อให้คุณสามารถใช้วิธีการนี้ตามดุลยพินิจของคุณเอง คุณต้องยอมรับความเสี่ยงในการใช้วิธีการนี้ด้วยตนเอง

หมายเหตุ:โปรแกรมป้องกันไวรัสจะได้รับการออกแบบเพื่อช่วยปกป้องคอมพิวเตอร์ของคุณจากไวรัส คุณไม่ต้องดาวน์โหลด หรือเปิดแฟ้มจากแหล่งที่มาที่คุณไม่เชื่อถือ เยี่ยมชม Web sites ที่คุณไม่เชื่อถือ หรือเปิดสิ่งที่แนบอีเมล์เมื่อมีการปิดใช้งานโปรแกรมป้องกันไวรัสของคุณ

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับไวรัสคอมพิวเตอร์ คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
129972ไวรัสคอมพิวเตอร์: คำอธิบาย ป้องกัน และกู้คืน
เมื่อต้องการแก้ปัญหานี้ ให้ทำตามขั้นตอนต่อไปนี้:
  1. Download and install the MS02-070 security update that is described in Microsoft Knowledge Base article 329170 on all Windows 2000-based and Windows XP-based file servers and client computers.

    For additional information about this update, click the following article number to view the article in the Microsoft Knowledge Base:
    329170MS02-070: Flaw in SMB signing may permit Group Policy to be modified
  2. Upgrade any Windows XP-based client computers to Windows XP Service Pack 1 (SP1), and then obtain and install the hotfixes that are described in Microsoft Knowledge Base articles 328170 and 812937.

    For additional information about how to obtain Windows XP SP1, click the following article number to view the article in the Microsoft Knowledge Base:
    322389วิธีการขอรับ Service Pack ล่าสุดของ Windows XP
    For additional information about how to obtain the hotfixes, click the following article numbers to view the articles in the Microsoft Knowledge Base:
    812937File Lock or Access Denied error message when you save files over the network
    328170Program opens a file as read-only or returns a sharing violation or "Access Denied" message when opening from or saving to a network folder
  3. If you have not resolved the issue, disable network drive scanning in your antivirus program. To turn off your antivirus program, see the antivirus program documentation or online help for steps and information about how to do this.

    If the issue is still not resolved, temporarily turn off your antivirus program. Sometimes, you may have to remove antivirus software on both the client and the server to troubleshoot this issue. If removing or disabling your antivirus program does not resolve the issue, contact the manufacturer of your antivirus program for additional information about this issue and the steps that you must take to resolve the issue. For example, visit the following third-party Web sites for information about how to resolve this issue with specific antivirus products:
    http://www.trendmicro.com/
    http://www.symantec.com/support/
    Microsoft จะให้ข้อมูลติดต่อของบริษัทอื่น เพื่อช่วยให้คุณสามารถขอรับการสนับสนุนทางเทคนิคได้ ข้อมูลติดต่อนี้อาจเปลี่ยนแปลงโดยไม่ต้องแจ้งให้ทราบล่วงหน้า Microsoft ไม่รับประกันความถูกต้องของข้อมูลการติดต่อกับบริษัทอื่นๆ เหล่านี้

ข้อมูลเพิ่มเติม

Network Monitor traces may show "DOS Error, (5) ACCESS_DENIED" or "DOS Error, (32) SHARING_VIOLATION" error messages after 35 seconds (between "SMB: C NT create & X" commands for the same file name). The time that the server waits for an Oplock Break response is controlled by the
LanmanServer
พารามิเตอร์
OplockBreakWait
. By default, this parameter is set to 35 seconds.

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการหลีกเลี่ยงความล่าช้าในการเข้าสู่ระบบ คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
319440เกิดความล่าช้าของการเข้าสู่ระบบผ่านการเชื่อมต่อที่ช้า ถ้าไม่มีการให้สิทธิ์การล็อคเฉพาะกรณีสำหรับแฟ้มนโยบายใน Windows

ข้อมูลอ้างอิง

หากต้องการทราบข้อมูลเพิ่มเติม โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base::
306981Level II oplocks are not granted after a file is locked
324002Searching files across a network may leave open files
296264Configuring opportunistic locking in Windows
812513File takes an unexpectedly long time to open through server message block protocol
829700Slow network performance when you open a file that is located in a shared folder on a remote network computer
826722Cannot delete shortcut on a network share: "It is being used by another person or program"
822227Program may raise a sharing violation when a file is opened from Windows Explorer
811005รับรองความถูกต้องของผู้ใช้บริการเช่น Microsoft Exchange Server อาจหมดเวลาบนเซิร์ฟเวอร์ของสมาชิก

คุณสมบัติ

หมายเลขบทความ (Article ID): 814112 - รีวิวครั้งสุดท้าย: 26 กันยายน 2554 - Revision: 3.0
ใช้กับ
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 2002 Standard Edition
Keywords: 
kbnetwork kberrmsg kbprb kbmt KB814112 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:814112

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com