Article ID: 814120 - Last Review: November 2, 2005 - Revision: 6.1

FIX: PrintUI.dll does not install correct OEM print processor from command line script on Windows 2000

For a Microsoft Windows XP version of this article, see 814121  (http://support.microsoft.com/kb/814121/EN-US/ ) .

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SYMPTOMS

One way to install a local printer is by using PrintUI.dll by means of INF and the steps listed in the article in the "References" section. If you use this method to install a local printer that uses a custom print processor, although the new print processor is installed, it is not selected in the printer Properties:
  • If you do a new installation, you always get the Winprint.dll print processor.
  • If you replace an existing driver, the selection for the previous print processor is retained.
Note This problem does not occur if you use the Add Printer Wizard to install the printer.

CAUSE

This problem occurs because of a bug in the Printui.dll file.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/ ) How to obtain the latest Windows 2000 service pack

Hotfix information

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   19-Mar-2003  21:45  5.0.2195.6685   66,320  Ntprint.dll
   19-Mar-2003  21:45  5.0.2195.6685  381,712  Printui.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows 2000 Service Pack 4.

MORE INFORMATION

For more information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173  (http://support.microsoft.com/kb/265173/ ) The Datacenter Program and Windows 2000 Datacenter Server product
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For more information about the Printui.dll file, click the following article number to view the article in the Microsoft Knowledge Base:
189105  (http://support.microsoft.com/kb/189105/ ) How to add printers with no user interaction in Windows

APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 1
Keywords: 
kbbug kbfix kbwin2000presp4fix kbqfe kbhotfixserver KB814120
 

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