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Drive Letters Are Reset When You Restart the Computer

Article ID:814193
Last Review:February 12, 2007
Revision:3.1
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SYMPTOMS

When you restart a computer that uses a hardware RAID array, you may find that the drive letters that you previously assigned to partitions on local hard disks are reset to their default drive letter assignments.

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CAUSE

This problem may occur if both the following conditions are true:
You install a Windows 2000 kernel hotfix where the following files have a date stamp between September 30, 2002 and February 4, 2003:
Ntkrnlmp.exe
Ntkrnlpa.exe
Ntkrpamp.exe
Ntoskrnl.exe
When the Mount Manager component (Mountmgr) queries the registry, the RtlQueryRegistryValuesRtlQuery function incorrectly processes REG_BINARY registry entries that contain a NULL value in the following registry key:
HKEY_LOCAL_MACHINE\System\MountedDevices

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RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain the Latest Windows 2000 Service Pack

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Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Windows 2000 Service Pack 3 (SP3).

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version        Size    File name
--------------------------------------------------------
04-Feb-2003  16:15  5.0.2195.6661  29,264  Mountmgr.sys

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

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MORE INFORMATION

For more information about the RtlQueryRegistryValuesRtlQuery function, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms803008.aspx (http://msdn2.microsoft.com/en-us/library/ms803008.aspx)
For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 (http://support.microsoft.com/kb/816915/EN-US/) New Naming Schema for Microsoft Windows Hotfix Packages

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APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional Edition

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Keywords: 
kbhotfixserver kbqfe kbwin2ksp4fix kbqfe kbfix kbbug KB814193

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