Přenos souboru z digitálního fotoaparátu se nezdařil

Překlady článku Překlady článku
ID článku: 814390 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při provádění některých akcí souvisejících se zařízením PTP (Picture Transfer Protocol) v počítači se systémem Windows XP můžete zaznamenat následující příznaky:

Příznak 1:

Pokusíte-li se přenést velký počet souborů nebo jeden velký soubor ze zařízení používajícího protokol PTP (Picture Transfer Protocol), jako je například Sony MemoryStick, může se zobrazit jedna z následujících chybových zpráv:

Chybová zpráva 1
Počítač nerozpoznal skener nebo fotoaparát. Zkontrolujte, zda je zařízení zapnuto a správně připojeno k počítači.
Chybová zpráva 2
Aktuální obrázek nelze zkopírovat. Chcete-li obrázek zkopírovat, klikněte na tlačítko Opakovat. Jestliže chcete kopírování ukončit, klikněte na tlačítko Storno.
Pokud kliknete na tlačítko Opakovat, chybová zpráva se zobrazí znovu.

Příznak 2:

Pokusíte-li se přenést jeden velký soubor z fotoaparátu USB PTP na místní pevný disk (HDD) v Průzkumníkovi Windows, okno operace kopírování přestane přibližně na 2 minuty reagovat. Po uplynutí této doby okno zmizí a na cílové jednotce pevného disku bude vytvořen soubor o velikosti 0 bajtů.

Příznak 3:

Pokusíte-li se přenést jeden velký soubor z fotoaparátu USB PTP na místní pevný disk (HDD) pomocí průvodce skenery a fotoaparáty, přenos souboru ihned selže a zobrazí se následující chybová zpráva:
Průvodce skenery a fotoaparáty: Aktuální obrázek nelze zkopírovat.
Chcete-li obrázek zkopírovat, klikněte na tlačítko Opakovat. Jestliže chcete kopírování ukončit, klikněte na tlačítko Storno.
Pokud kliknete na tlačítko Opakovat, chybová zpráva se zobrazí znovu.

Příčina

Příznak 1

První příznak se vyskytuje v důsledku následujícího omezení ovladače protokolu PTP dodávaného společností Microsoft:
  • Přenosy souborů jsou omezeny na maximálně 2048 souborů současně.
  • Soubory musí být menší než 210 MB.
Příznak 2

Druhý příznak se objevuje v důsledku chyby v ovladači PTP (ptpusd.dll).

Příznak 3

Třetí příznak je důsledkem chyby v průvodci skenery a fotoaparáty.

Řešení

Příznak 1

Problém vyřešíte instalací opravy hotfix popsané v tomto článku.

Příznaky 2 a 3

Fotoaparát můžete připojit pomocí rozhraní USB Mass Storage Class (MSC) namísto rozhraní PTP. Poté přeneste velké soubory pomocí Průzkumníka Windows.

Informace o aktualizaci Service Pack

Problém popsaný v části Příznak 1 je možné vyřešit pomocí nejnovější aktualizace Service Pack pro systém Microsoft Windows XP. Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322389 Jak získat nejnovější aktualizaci Service Pack pro systém Windows XP

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix dodávaná společností Microsoft. Tato oprava hotfix je však určená pouze k odstranění problému popsaného v tomto článku. Instalujte ji pouze v systémech, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud vás tedy uvedené potíže příliš neobtěžují, doporučujeme, abyste počkali na další aktualizaci softwaru, která bude tuto opravu obsahovat.

Pokud je k dispozici oprava hotfix ke stažení, na začátku tohoto článku znalostní báze Knowledge Base naleznete oddíl Hotfix download available (Oprava hotfix ke stažení). Pokud zde tento oddíl není uveden, požádejte o poskytnutí opravy hotfix středisko technické podpory a péče o zákazníky společnosti Microsoft.

Poznámka: Máte-li jakékoli další dotazy nebo je-li třeba vyřešit nějaké potíže, je možné, že pro ně bude nutné vytvořit samostatný požadavek na služby. Další dotazy a žádosti o podporu, které se netýkají této konkrétní opravy hotfix, podléhají běžným sazbám za poskytnutí podpory. Úplný seznam telefonních čísel služeb technické podpory a péče o zákazníky společnosti Microsoft a možnost vytvoření samostatného požadavku na služby naleznete na tomto webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Ve formuláři Hotfix download available (Oprava hotfix ke stažení) jsou uvedeny jazyky, v nichž je oprava hotfix k dispozici. Pokud seznam neobsahuje váš jazyk, znamená to, že daná oprava hotfix v tomto jazyku není k dispozici.
Anglická verze této opravy hotfix má následující nebo vyšší atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Při zobrazení informací o souboru jsou data a čas převedeny na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo na panelu Datum a čas v okně Ovládací panely.
Datum       Čas    Verze        Velikost   Název souboru   Aktualizace SP-------------------------------3. 12. 2003 13:06 5.1.2600.112  148 992 Ptpusd.dll  1 3. 12. 2003 12:01 5.1.2600.1179 151 040 Ptpusd.dll  2

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt. Tento problém byl poprvé opraven aktualizací Microsoft Windows XP Service Pack 2.

Další informace

Produkty jiných výrobců popisované v tomto článku vyrábějí společnosti, které jsou nezávislé na společnosti Microsoft. Společnost Microsoft neposkytuje žádnou záruku (implicitně předpokládanou ani jinou) týkající se výkonu a spolehlivosti těchto produktů.

Vlastnosti

ID článku: 814390 - Poslední aktualizace: 1. prosince 2008 - Revize: 5.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Klíčová slova: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB814390

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com