Bij het herstel van een beschadigd register wordt per ongeluk een subset registersleutels verwijderd

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 814545 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Nadat Windows is opgestart, kan het gebeuren dat in het register een subset sleutels onder een subsleutel ontbreekt, zoals
HKLM\Software\Classes
of
HKLM\Software\Classes\CLSID
. Omdat veel van deze sleutels vereist zijn voor een goede uitvoering van Windows, is het mogelijk dat Explorer.exe niet wordt gestart wanneer u zich aanmeldt, Windows Management Instrumentation (WMI) niet goed werkt of een bepaald programma niet wordt uitgevoerd. Als u het register controleert (u vergelijkt het register met dat van een werkende computer of u voert een probleemoplosser uit), zult u zien dat veel sleutels ontbreken.

Oorzaak

Met de registertolerantiecode in Windows XP Service Pack 1 (SP1) worden beschadigde registersleutels verwijderd op het moment dat Windows wordt gestart, maar het kan ook gebeuren dat een subset sleutels per ongeluk wordt verwijderd.

Oplossing

Informatie over servicepacks

U kunt dit probleem oplossen met het recentste servicepack voor Microsoft Windows XP. Klik voor meer informatie op het volgende artikelnummer, zodat het desbetreffende Microsoft Knowledge Base-artikel wordt weergegeven:
322389 Het meest recente service pack voor Windows XP ophalen

Informatie over hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet mogelijk extra worden getest. Als u geen ernstige problemen ondervindt, raadt Microsoft u daarom aan te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan worden gedownload, is aan het begin van dit Knowledge Base-artikel een sectie 'Hotfix kan worden gedownload' opgenomen. Als een dergelijke sectie niet aanwezig is, kunt u de hotfix aanvragen bij de klantondersteuning van Microsoft.

Opmerking Als er nog andere problemen optreden of als er oplossingen zijn vereist zijn, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen en problemen die niet in aanmerking komen voor deze specifieke hotfix. Bezoek de volgende website van Microsoft voor een volledige lijst met telefoonnummers van de klantondersteuning van Microsoft of om een afzonderlijk serviceverzoek te maken:
http://support.microsoft.com/contactus/?ws=support
Opmerking Op het formulier 'Hotfix kan worden gedownload' zijn de talen vermeld waarvoor de hotfix beschikbaar is. Als uw taal daar niet bij staat, is de hotfix niet beschikbaar voor die taal. De Engelse versie van deze correctie heeft de bestandskenmerken die in de volgende tabel worden weergegeven (of recentere kenmerken). De datums en tijden voor deze bestanden worden weergegeven in UTC-notatie (Coordinated Universal Time). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Als u het verschil tussen UTC en lokale tijd wilt bepalen, gebruikt u het tabblad Tijdzone van de optie Datum en tijd in het Configuratiescherm.
   Datum       Tijd    Versie         Grootte    Bestandsnaam
   ----------------------------------------------------------
   18-feb-2003  14:01  5.1.2600.1170  1.892.352  Ntkrnlmp.exe
   18-feb-2003  14:02  5.1.2600.1170  1.948.288  Ntkrnlpa.exe
   18-feb-2003  14:02  5.1.2600.1170  1.921.024  Ntkrpamp.exe
   18-feb-2003  14:01  5.1.2600.1170  1.924.480  Ntoskrnl.exe

U kunt dit probleem voorkomen door de hotfix te installeren die in dit artikel wordt beschreven. Als het probleem zich al heeft voorgedaan, herstelt u de ontbrekende registersleutels met een back-up.

Status

Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die aan het begin van dit artikel worden vermeld. In Microsoft Windows XP Service Pack 2 is voor het eerst een correctie aangebracht voor dit probleem.

Eigenschappen

Artikel ID: 814545 - Laatste beoordeling: woensdag 31 december 2008 - Wijziging: 3.3
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP1a
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP1a
Trefwoorden: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB814545

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com