Восстановление реестра может привести к непреднамеренному удалению части разделов

Переводы статьи Переводы статьи
Код статьи: 814545 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

После запуска Windows в реестре может не хватать некоторых разделов, например
HKLM\Software\Classes
или
HKLM\Software\Classes\CLSID
. Поскольку многие из этих разделов отвечают за правильную работу Windows, после входа в систему файл Explorer.exe может не запускаться, инструментарий управления Windows (WMI) может работать некорректно или вообще не работать. Если сравнить реестр с реестром работающего компьютера или выполнить операции по устранению неполадок, можно обнаружить, что часть разделов отсутствует.

Причина

Код исправления реестра, входящий в пакет обновления 1 (SP1) для Windows XP, удаляет поврежденные разделы реестра при запуске Windows, но при этом случайно могут быть удалены целые наборы разделов.

Решение

Сведения о пакете обновления

Чтобы решить эту проблему, установите последний пакет обновления для Windows XP. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
322389 Как получить последний пакет обновления для Windows XP

Сведения об исправлении

Корпорация Майкрософт выпустила исправление, однако оно предназначено исключительно для устранения проблемы, описанной в этой статье. Это исправление необходимо применять только в тех системах, в которых наблюдается данная проблема. Исправление может проходить дополнительное тестирование. По этой причине корпорация Майкрософт рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, в верхней части статьи базы знаний отображается раздел «Исправление доступно для загрузки». Если этот раздел не отображается, обратитесь в службу поддержки пользователей Майкрософт, чтобы получить данное исправление.

Примечание. Если возникли другие проблемы или необходимо устранить неполадки, возможно, потребуется создать отдельный запрос. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются на стандартных условиях. Чтобы получить полный список телефонных номеров службы поддержки пользователей корпорации Майкрософт или создать отдельный запрос, посетите веб-узел корпорации Майкрософт по следующему адресу:
http://support.microsoft.com/contactus/?ws=support
Примечание. В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если нужный язык не отображается, это означает, что исправление для данного языка отсутствует. Английская версия исправления содержит версии файлов, приведенные в следующей таблице, или более поздние. Дата и время указаны в формате UTC. При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы узнать разницу между временем в формате UTC и местным временем, откройте вкладку Часовой пояс элемента «Дата и время» на панели управления.
   Дата         Время Версия      Размер  Имя файла
   ----------------------------------------------------------
   18-Feb-2003  14:01  5.1.2600.1170  1,892,352  Ntkrnlmp.exe
   18-Feb-2003  14:02  5.1.2600.1170  1,948,288  Ntkrnlpa.exe
   18-Feb-2003  14:02  5.1.2600.1170  1,921,024  Ntkrpamp.exe
   18-Feb-2003  14:01  5.1.2600.1170  1,924,480  Ntoskrnl.exe

Чтобы не допустить возникновения проблемы, установите описанное в этой статье исправление. Если вы все-таки столкнулись с проблемой, восстановите недостающие разделы реестра из архива.

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в начале данной статьи. Первое исправление этой проблемы появилось в пакете обновления 2 (SP2) для Windows XP.

Свойства

Код статьи: 814545 - Последний отзыв: 11 сентября 2008 г. - Revision: 3.3
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP1a
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP1a
Ключевые слова: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB814545

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com