Samengestelde USB-apparaten met interfaces die niet opeenvolgend zijn genummerd, werken niet in Windows XP

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 814560 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Symptomen

Een apparaat dat meer dan één interfacedescriptor bevat, wordt een gecombineerd USB-apparaat genoemd. Elke interface in een gecombineerd USB-apparaat heeft een nummer. Wanneer u een gecombineerd USB-apparaat aansluit op een computer met Microsoft Windows XP waarvan de interfaces niet opeenvolgend zijn genummerd, start het gecombineerde USB-apparaat niet.

Oorzaak

Dit probleem doet zich voor omdat een nieuw stuurprogramma voor samengestelde USB-apparaten dat bij Windows XP wordt geleverd, ervan uitgaat dat alle samengestelde USB-apparaten opeenvolgend genummerde interfaces hebben.

Als de interfaces niet opeenvolgend genummer zijn, vindt het stuurprogramma (Usbccgp.sys) niet alle interfaces wanneer het stuurprograma een aanvankelijke configuratie voor het apparaat selecteert. De aanvankelijke configuratie werkt niet wanneer deze naar de stack met USB-stuurprogramma's wordt verzonden, omdat een aantal interfaces in het configuratieverzoek ontbreken. Door dit verschil in de lijst met interfaces kan het stuurprogramma Usbccgp.sys het apparaat niet starten.

Oplossing

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet mogelijk extra worden getest. Als u geen ernstige problemen ondervindt, raadt Microsoft u daarom aan te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan worden gedownload, is aan het begin van dit Knowledge Base-artikel een sectie 'Hotfix kan worden gedownload' opgenomen. Als een dergelijke sectie niet aanwezig is, kunt u de hotfix aanvragen bij de klantondersteuning van Microsoft.

Opmerking Als er nog andere problemen optreden of als er oplossingen zijn vereist zijn, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen en problemen die niet in aanmerking komen voor deze specifieke hotfix. Bezoek de volgende website van Microsoft voor een volledige lijst met telefoonnummers van de klantondersteuning van Microsoft of om een afzonderlijk serviceverzoek te maken:
http://support.microsoft.com/contactus/?ws=support
Opmerking Op het formulier 'Hotfix kan worden gedownload' zijn de talen vermeld waarvoor de hotfix beschikbaar is. Als uw taal daar niet bij staat, is de hotfix niet beschikbaar voor die taal.

De Engelse versie van deze hotfix heeft de bestandskenmerken die in de volgende tabel worden weergegeven (of recentere bestandskenmerken). De datums en tijden voor deze bestanden worden weergegeven in de UTC-notatie (Coordinated Universal Time). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Als u het verschil tussen UTC en lokale tijd wilt bepalen, gebruikt u het tabblad Tijdzone van de optie Datum en tijd in het Configuratiescherm.
Datum         Tijd    Versie       Grootte     Bestandsnaam     Platform
---------------------------------------------------------------------------
24-feb-2003   14:03    5.1.2600.111   24.960   usbccgp.sys   Windows XP
21-feb-2003   18:57    5.1.2600.1172  28.160   usbccgp.sys   Windows XP SP1

Status

Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Eigenschappen

Artikel ID: 814560 - Laatste beoordeling: woensdag 31 december 2008 - Wijziging: 4.2
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP1a
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP1a
Trefwoorden: 
kbautohotfix kbhotfixserver kbqfe kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbprb kbusb KB814560

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com