Dispositivos USB Composite cujos interfaces não são numeradas seqüencialmente não funcionam no Windows XP

Traduções deste artigo Traduções deste artigo
ID do artigo: 814560 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Um dispositivo que contém mais de um descritor de interface é conhecido como um dispositivo USB composto . Cada interface em um dispositivo USB composto é numerada. Não é iniciado quando você conectar um dispositivo USB composto cujos interfaces não são numeradas seqüencialmente em um computador que está executando o Microsoft Windows XP, o dispositivo USB composto.

Causa

Esse problema ocorre porque um novo driver para composição USB dispositivos que está incluído no Windows XP assume que todos os dispositivos USB compostos tem interfaces numeradas seqüencialmente.

Se as interfaces não são numeradas seqüencialmente, o driver (Usbccgp.sys) não encontrará todas as interfaces quando o driver estiver selecionando uma configuração inicial para o dispositivo. A configuração inicial não funciona quando ele for enviado para o USB driver pilha porque algumas interfaces de estão faltando na solicitação de configuração. Essa diferença na lista de interfaces faz com que o Usbccgp.sys driver não para iniciar o dispositivo.

Resolução

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
Date          Time     Version        Size     File Name     Platform
---------------------------------------------------------------------------
24-Feb-2003   14:03    5.1.2600.111   24,960   usbccgp.sys   Windows XP
21-Feb-2003   18:57    5.1.2600.1172  28,160   usbccgp.sys   Windows XP SP1

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Propriedades

ID do artigo: 814560 - Última revisão: quarta-feira, 29 de agosto de 2007 - Revisão: 4.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP1a
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP1a
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbprb kbusb KB814560 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 814560

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com