El componente de tiempo de ejecución de datagramas de Llamada a procedimiento remoto pierde puertos de servidor de seguridad en el cliente

Seleccione idioma Seleccione idioma
Id. de artículo: 814622 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando utiliza un programa que realiza muchas de la interfaz de programación de aplicaciones de clúster (API) OpenCluster y CloseCluster función llama a en rápida sucesión, el programa puede quedarse sin recursos y dejar de responder (bloquearse).

Causa

Este problema puede producirse después de limitar el uso de puerto en el servidor de seguridad que el programa utiliza para comunicarse. Cuando se utiliza la API de clústeres, la función CloseCluster libera los recursos que utilizan OpenCluster , incluidos puertos de llamada a procedimiento remoto (RPC). Sin embargo, en algunas comunicaciones RPC incorrectas o asignaciones de memoria incorrecta, la RPC datagrama runtime componente libera el puerto de servidor de seguridad, provocando que sea irrecuperable durante la vida del proceso en ejecución. Estos puertos "perdidos" pueden provocar que el programa de agotar los recursos.

Solución

Información de Service Pack

Para resolver este problema, consiga el Service Pack más reciente para Microsoft Windows 2000. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.La versión global de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version           Size     File name
   ---------------------------------------------------------
   18-Mar-2003  21:33  5.0.2195.6662     944,400  Ole32.dll
   18-Mar-2003  21:26  5.0.2195.6662     432,400  Rpcrt4.dll
   18-Mar-2003  21:33  5.0.2195.6662     187,664  Rpcss.dll

Solución

Quizás pueda evitar este problema al aumentar la cantidad de número de puertos disponibles para RPC. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
814622El componente de tiempo de ejecución de datagramas de Llamada a procedimiento remoto pierde puertos de servidor de seguridad en el cliente

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo. Este problema se corrigió por primera vez en el Service Pack 4 de Microsoft Windows 2000.

Más información

Para obtener información adicional acerca de cómo obtener un hotfix para Windows 2000 Datacenter Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265173El programa Datacenter y el producto servidor de Windows 2000 Datacenter


Los puertos RPC que utilizan OpenCluster se reciclan después de un período de tiempo de espera después de llamar a la función CloseCluster . De forma predeterminada, dicho período es 240 segundos. Sin embargo, el puerto permanece asignado de la lista de puertos de firewall disponibles que se mantienen remoto procedimiento llamada servicio de Microsoft (RPCSS.exe). RPCSS mantiene la lista de todos los puertos de firewall disponibles. Cuando el programa cliente tiene que establecer una conexión nueva con el servidor, crea un nuevo socket y, a continuación, pide RPCSS para el puerto para utilizar. Esto es necesario porque cada cliente RPC de datagrama es también un servidor RPC, porque tiene al servicio Conv_Callbacks desde el servidor. El puerto de servidor de seguridad permanece asignado al proceso dure el proceso. A causa de esto, si más adelante en el cliente cierra la conexión original y solicita una nueva conexión a abrirse, asigna un nuevo puerto de servidor de seguridad de RPCSS, incluso si ya asignado puertos en el pasado ya no utiliza. Esto es una limitación conocida de diseño de puertos de firewall. Permanecen asignados al proceso para la duración de dicho proceso.

Propiedades

Id. de artículo: 814622 - Última revisión: sábado, 8 de febrero de 2014 - Versión: 6.6
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Palabras clave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbnetwork kbwin2ksp4fix kbprb kbwin2000presp4fix kbfix kbbug KB814622 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 814622

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com