You receive no warning that the Registry.pol file is corrupted

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Article ID: 814751 - View products that this article applies to.
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SYMPTOMS

If you are the administrator for a group, and you try to update or try to modify a corrupted Registry.pol file for either users or computers, you receive no warning that the Registry.pol file is corrupted while you edit, save, or apply the policy file.

CAUSE

This issue occurs when an administrator modifies the Group Policy settings under the Administrative templates node and then updates the settings for either users or computers. These changes are then written to the appropriate Registry.pol file.

If this Registry.pol file becomes corrupted before the new settings are applied to the users or to the computers that are affected by that policy, the new changes to that policy are not applied.

There is no workaround for this issue. You must re-create the Registry.pol file. You can detect that the Group Policy editor did not successfully open the Registry.pol file by enabling user environment logging on the client computer. For additional information about how to use the Userenv.log file to debug policy problems, click the following article number to view the article in the Microsoft Knowledge Base:
221833 How to Enable User Environment Debug Logging in Retail Builds of Windows
When you view the user environment event log, you may see a series of entries that are similar to the following:
USERENV(e0.524) 14:32:06:429 ParseRegistryFile: Entering with <corrupted_Registry.pol>.
USERENV(e0.524) 14:32:06:429 ParseRegistryFile: Invalid file version.
USERENV(e0.524) 14:32:06:429 ParseRegistryFile: Leaving.
USERENV(e0.524) 14:32:06:429 ProcessGPORegistryPolicy: ParseRegistryFile failed.
USERENV(e0.524) 14:32:06:439 ProcessGPOList: ProcessGPORegistryPolicy failed.
USERENV(e0.524) 14:32:06:439 ProcessGPOs: Extension Registry ProcessGroupPolicy failed, status 0x80004005.

RESOLUTION

This fix provides a warning event in the application event log if the policy processing engine cannot read a Registry.pol file. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   -----------------------------------------------------------
   14-Feb-2003  12:49  5.0.2195.6621      42,256  Basesrv.dll      
   14-Feb-2003  12:49  5.0.2195.6660     222,992  Gdi32.dll        
   14-Feb-2003  12:49  5.0.2195.6656     710,928  Kernel32.dll     
   25-Feb-2003  11:39  5.0.2195.6669     333,072  Msgina.dll       
   31-Jan-2003  12:51  5.0.2195.6661      90,232  Rdpwd.sys
   10-Feb-2003  15:22  5.0.2195.6663     166,912  Sp3res.dll       
   25-Feb-2003  11:39  5.0.2195.6666     379,664  User32.dll       
   25-Feb-2003  11:39  5.0.2195.6671     385,296  Userenv.dll      
   24-Feb-2003  13:02  5.0.2195.6669   1,620,176  Win32k.sys
   06-Feb-2003  09:04  5.0.2195.6663     181,008  Winlogon.exe     
   14-Feb-2003  12:49  5.0.2195.6655     243,472  Winsrv.dll       
   25-Feb-2003  11:41  5.0.2195.6661      90,200  Rdpwd.sys
   25-Feb-2003  11:39  5.0.2195.6656     710,928  Kernel32.dll      
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 814751 - Last Review: October 26, 2006 - Revision: 1.5
APPLIES TO
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Datacenter Server SP2
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbqfe kbwin2000presp4fix kbfix kbbug KB814751

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