Impossibile pianificare l'arresto e il riavvio di un computer basato su Windows XP mediante il comando AT con il programma Shutdown.exe

Traduzione articoli Traduzione articoli
Identificativo articolo: 814761 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Quando si utilizza il comando at con il programma Shutdown.exe per pianificare l'arresto o il riavvio di un computer basato su Windows XP, l'operazione pianificata non viene eseguita correttamente. All'avvio dell'operazione di arresto pianificata, è possibile che venga visualizzato un messaggio analogo al seguente in una finestra del prompt dei comandi:
Operazione terminata con successo.
Il privilegio richiesto non appartiene al client.

Cause

Questo problema si verifica perché, per impostazione predefinita, le operazioni pianificate mediante il comando at vengono eseguite con l'account di sistema locale. Prima che venga eseguita l'operazione di arresto sulla base del programma Shutdown.exe, viene eseguito il tentativo di abilitare alcuni diritti. Poiché l'account di sistema locale è privo di uno dei diritti che si tenta di abilitare, l'operazione non viene eseguita correttamente.

Risoluzione

È disponibile una correzione supportata da Microsoft, che è tuttavia destinata esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarla solo nei computer in cui si verifica questo problema specifico. È possibile che su questa correzione vengano eseguiti ulteriori test. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows XP contenente tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere la correzione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft all'indirizzo:
http://support.microsoft.com
NOTA: in casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Supporto Tecnico Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi dell'assistenza verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione globale di questa correzione ha gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
 Data         Ora    Versione        Dimensione     Nome file
 ---------------------------------------------------------------
 18/02/2003   17.04  5.1.2600.1170   17.920         Shutdown.exe


Workaround

Per aggirare questo problema, utilizzare l'Utilità di pianificazione per pianificare l'arresto e il riavvio del computer a un'ora specifica. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start e scegliere Pannello di controllo.
  2. Fare clic su Prestazioni e manutenzione, quindi scegliere Operazioni pianificate.
  3. Fare doppio clic su Aggiungi operazione pianificata. Verrà avviata la Pianificazione guidata operazioni.
  4. Scegliere Avanti.
  5. In Selezionare l'applicazione da eseguire scegliere Sfoglia.
  6. Nella finestra di dialogo Selezionare l'applicazione da pianificare individuare la cartella %SystemRoot%\System32, individuare il file Shutdown.exe e fare clic su di esso, quindi scegliere Apri.
  7. In Esegui questa operazione specificare un nome e la frequenza di esecuzione dell'operazione, quindi scegliere Avanti.
  8. In Selezionare l'ora e il giorno per l'avvio dell'operazione specificare un'ora e una data di avvio dell'operazione e scegliere Avanti.
  9. Digitare il nome utente e la password per l'esecuzione dell'operazione, quindi scegliere Avanti.
  10. Selezionare la casella di controllo Apri le proprietà avanzate per questa operazione quando si sceglie Fine e scegliere Fine.
  11. Scegliere la scheda Operazione.
  12. Nella casella Esegui specificare eventuali parametri aggiuntivi da utilizzare con il programma Shutdown.exe.
  13. Scegliere OK.
In alternativa, è possibile cambiare l'account utilizzato per il comando at come segue:
  1. Aprire la cartella Operazioni pianificate come descritto nella sezione "Risoluzione".
  2. Scegliere Account servizio AT dal menu Avanzate.
  3. Digitare il nome account e la password richiesti e scegliere OK.
Note
  • Questa modifica avrà effetto su tutte le operazioni pianificate con il comando at e non solo su Shutdown.exe.
  • L'account utilizzato deve disporre del diritto SeRemoteShutdownPrivilege nel sistema locale.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo.

Informazioni

Per ulteriori informazioni sul comando shutdown, digitare shutdown /? al prompt dei comandi, quindi premere INVIO.

Per ulteriori informazioni sul comando at, digitare at /? al prompt dei comandi, quindi premere INVIO.

Proprietà

Identificativo articolo: 814761 - Ultima modifica: venerdì 31 marzo 2006 - Revisione: 5.2
Le informazioni in questo articolo si applicano a
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Chiavi: 
kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB814761
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com