Não é possível agendar um computador com base no Windows XP para desligar e reiniciar usando o comando AT com o Shutdown.exe

Traduções deste artigo Traduções deste artigo
ID do artigo: 814761 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Ao usar o comando at com o Shutdown.exe para agendar um computador com base no Windows XP para desligar e reiniciar, o computador não desliga ou reinicia conforme esperado. Quando a tarefa agendada de desligamento inicia, pode ser exibida a seguinte mensagem em uma janela do prompt de comando:
A operação foi concluída com êxito.
Um privilégio requerido não está em poder do cliente.

Causa

Este problema ocorre porque, por padrão, as tarefas agendadas usando o comando at são executadas sob uma conta do Sistema local. O Shutdown.exe tenta ativar alguns direitos antes de executar a ação de desligamento. A conta do sistema local não possui um dos direitos necessários que o Shutdown.exe tenta ativar e, portanto, a ação não é executada com êxito.

Resolução

Informações sobre o service pack

Para resolver este problema, obtenha o service pack mais recente para o Microsoft Windows XP. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
322389 Como obter o service pack mais recente do Windows XP

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se este problema não o prejudicar, é aconselhável aguardar a próxima atualização de software que contenha este hotfix.

Se o hotfix estiver disponível para download, existirá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não é exibida, contate o Serviço de Atendimento ao Cliente da Microsoft para obter o hotfix.

Observação Caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento ao Cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso seu idioma não seja exibido, um hotfix não está disponível para esse idioma. A versão global desta correção apresenta os atributos de arquivo (ou mais recentes) listados na tabela a seguir. As datas e horários desses arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
Data         Hora   Versão            Tamanho    Nome do Arquivo ------------------------------------------------------------ 18-Fev-2003  17:04 5.1.2600.1170     17.920      Shutdown.exe

				

Como Contornar

Como solução alternativa para esse problema, use o Agendador de Tarefas para agendar o computador para desligar e reiniciar em um horário específico. Para fazer isto, execute as seguintes etapas:
  1. Clique em Iniciar e em Painel de controle.
  2. Clique em Desempenho e manutenção e em Tarefas agendadas.
  3. Clique duas vezes em Adicionar uma tarefa agendada. O Assistente de tarefa agendada é iniciado.
  4. Clique em Avançar.
  5. Em Clique no programa a ser executado pelo Windows, clique em Procurar.
  6. Na caixa de diálogo Selecione o programa a ser agendado, localize a pasta %SystemRoot%\System32, encontre e clique no arquivo Shutdown.exe e clique em Abrir.
  7. Em Executar esta tarefa especifique um nome para a tarefa e a freqüência com que deseja que essa tarefa seja executada, e clique em Avançar.
  8. Em Selecione a hora e o dia para o início da tarefa, especifique uma hora e data de início para a tarefa e, em seguida, clique em Avançar.
  9. Digite o nome de usuário e senha sob os quais executar a tarefa e clique em Avançar.
  10. Marque a caixa de seleção Abrir as propriedades avançadas desta tarefa ao clicar em Concluir e clique em Concluir.
  11. Clique na guia Tarefas.
  12. Na caixa Executar, especifique quaisquer parâmetros adicionais que deseja usar com Shutdown.exe.
  13. Clique em OK.
Como alternativa, é possível alterar a conta usada pelo comando at da seguinte forma:
  1. Abra a pasta Tarefas Agendadas conforme descrito anteriormente na seção "Solução alternativa".
  2. No menu Avançado, clique em Na conta de serviço.
  3. Digite o nome de usuário e senha da conta necessária e clique em OK.
Observações
  • Essa alteração irá afetar todas as tarefas agendadas com o comando at, não somente o Shutdown.exe.
  • A conta usada deve ter o direito RemoteShutdownPrivilege no sistema local.

Situação

A Microsoft confirmou que este é um problema que ocorre nos produtos Microsoft que estão listados no início deste artigo. Este problema foi corrigido pela primeira vez no Microsoft Windows XP Service Pack 2 (SP2).

Mais Informações

Para obter informações adicionais sobre o comando shutdown, digite shutdown /? no prompt de comando e pressione ENTER.

Para obter informações adicionais sobre o comando at, digite at /? no prompt de comando e pressione ENTER.

Propriedades

ID do artigo: 814761 - Última revisão: quinta-feira, 19 de junho de 2008 - Revisão: 6.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
Palavras-chave: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB814761

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com