Unexpected Delay When You Log Off

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Article ID: 814770 - View products that this article applies to.
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SYMPTOMS

When you log off, it may take longer than you expect (a minute or more) for the operation to complete. When this symptom occurs, Saving your Settings may be displayed for up to a minute. Also, your profile may not unload properly, and the following event may be logged in the event log:

Type: Error
Event Id: 1000
Source: Userenv
Description: Windows cannot unload your registry file. If you have a roaming profile, your settings are not replicated. Contact your administrator.

CAUSE

This problem may occur if both of the following conditions are true:
  • You have Windows 2000 Professional installed on your computer.

    -and-
  • You install the update that is documented in the following Microsoft Knowledge Base article:
    329170 MS02-070: Flaw in SMB Signing May Permit Group Policy to Be Modified
This issue may be caused by a problem with the spooler service.

WORKAROUND

To work around this issue, stop the spooler service before you log off. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type NET STOP SPOOLER, and then press ENTER.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   ------------------------------------------------------
   28-Jan-2003  13:34  5.0.2195.6659  45,840  Spoolsv.exe      	

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 814770 - Last Review: February 1, 2007 - Revision: 4.8
APPLIES TO
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kbprint kbwin2000presp4fix kbfix kbbug KB814770

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