Un ordinateur exécutant les services Terminal Server cesse de répondre, ce qui entraîne l'affichage d'un message d'erreur dans Windows 2000 ou dans Windows XP : « Erreur Stop 0x7F »

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Sommaire

Symptômes

Il est possible qu'un ordinateur exécutant les services Terminal Server cesse de répondre. Lorsque ce problème se produit, le message d'erreur Stop suivant s'affiche :
0x0000007f (0x00000008) error STOP 0x7f
L'erreur Stop se produit dans le fichier Win32k.sys.

Lorsque vous arrêtez puis redémarrez l'ordinateur, celui-ci démarre normalement. Toutefois, l'erreur d'arrêt se reproduit régulièrement.

Ce problème peut se produire si l'ordinateur exécute Microsoft Windows XP ou Microsoft Windows 2000.

Cause

En effet, un programme peut créer jusqu'à 100 fenêtres imbriquées. Pendant le nettoyage, la taille de l'espace pile peut être insuffisant pour que le thread actif puisse gérer toutes les fonctions nécessaires au nettoyage de tous les objets fenêtre.

Résolution

Une fois ce correctif appliqué, un programme peut créer jusqu'à 50 fenêtres imbriquées. Si un programme tente de créer plus de 50 fenêtres imbriquées, il échoue.

Windows XP

Informations de Service Pack

Pour résoudre ce problème, procurez-vous le dernier Service Pack Windows XP. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322389 Comment faire pour obtenir le dernier Service Pack Windows XP

Informations sur les correctifs logiciels

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. Ne l'appliquez qu'aux systèmes sur lesquels vous constatez ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, il est recommandé d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif logiciel peut être téléchargé, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le correctif auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non directement liés au correctif logiciel en question. Pour obtenir la liste complète des numéros de téléphone des services de Support technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif logiciel est disponible. Si votre langue n'est pas répertoriée, cela signifie qu'aucun correctif logiciel n'est disponible pour cette langue.
Configuration requise
Pour que vous puissiez appliquer ce correctif, Windows XP SP1 doit être installé sur l'ordinateur.
Nécessité d'un redémarrage
Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.
Informations sur le remplacement de correctif
Ce correctif ne remplace aucun autre correctif.
Informations sur le fichier
La version anglaise de ce correctif possède les attributs de fichier répertoriés dans le tableau suivant ou ceux d'une version ultérieure. Les date et heure de création de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations des fichiers, les données sont converties en heure locale. Pour connaître le décalage entre l'heure GMT et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
   Date         Heure  Version        Taille     Nom fichier Plateforme ---------------------------------------------------------------- 15/01/2004   01:49  5.1.2600.1332  1 678 208  Win32k.sys  i386 15/01/2004   01:50  5.1.2600.1332  5 623 808  Win32k.sys  IA-64

Windows 2000

Informations sur le Service Pack

Pour résoudre ce problème, procurez-vous le dernier Service Pack pour Windows 2000. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
260910 Comment faire pour obtenir le dernier Service Pack Windows 2000

Informations sur les correctifs logiciels

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. Ne l'appliquez qu'aux systèmes sur lesquels vous constatez ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, il est recommandé d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif logiciel peut être téléchargé, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le correctif auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non directement liés au correctif logiciel en question. Pour obtenir la liste complète des numéros de téléphone des services de Support technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif logiciel est disponible. Si votre langue n'est pas répertoriée, cela signifie qu'aucun correctif logiciel n'est disponible pour cette langue.
Configuration requise
Pour que vous puissiez appliquer ce correctif, Windows 2000 Service Pack 3 doit être installé sur l'ordinateur.
Nécessité d'un redémarrage
Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.
Informations sur le remplacement de correctif
Ce correctif ne remplace aucun autre correctif.
Informations sur le fichier
La version anglaise de ce correctif possède les attributs de fichier répertoriés dans le tableau suivant ou ceux d'une version ultérieure. Les date et heure de création de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations des fichiers, les données sont converties en heure locale. Pour connaître le décalage entre l'heure GMT et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
  Date         Heure   Version          Taille   Nom de fichier
  ---------------------------------------------------------------
  04/03/2003     19:26   5.0.2195.6678     42 768   Basesrv.dll
  14/02/2003     18:49   5.0.2195.6660    222 992   Gdi32.dll
  14/02/2003     18:49   5.0.2195.6656    710 928   Kernel32.dll
  04/03/2003     19:26   5.0.2195.6669    333 072   Msgina.dll
  31/01/2003     18:51   5.0.2195.6661     90 232   Rdpwd.sys
  04/03/2003     19:26   5.0.2195.6666    379 664   User32.dll
  04/03/2003     19:26   5.0.2195.6671    385 296   Userenv.dll
  04/03/2003     19:24   5.0.2195.6679  1 620 176   Win32k.sys
  03/03/2003     15:14   5.0.2195.6675    181 008   Winlogon.exe
  14/02/2003     18:49   5.0.2195.6655    243 472   Winsrv.dll
  04/03/2003     19:33   5.0.2195.6661     90 200   56bits\Rdpwd.sys
  04/03/2003     19:26   5.0.2195.6656    710 928   uniproc\Kernel32.dll
  04/03/2003     19:26   5.0.2195.6679  1 620 176   uniproc\Win32k.sys
  14/02/2003     18:49   5.0.2195.6655    243 472   uniproc\Winsrv.dll
				

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article. Ce problème a été corrigé pour la première fois dans le Service Pack 4 Microsoft Windows 2000.

Plus d'informations

Pour plus d'informations sur la façon d'obtenir un correctif pour Windows 2000 Datacenter Server, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
265173 Le programme Datacenter et Windows 2000 Datacenter Server

Informations sur le Registre Windows XP

Avertissement Des problèmes sérieux peuvent se produire si vous modifiez le Registre de façon incorrecte à l'aide de l'Éditeur du Registre ou toute autre méthode. Ces problèmes peuvent vous obliger à réinstaller le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l'ensemble des risques liés à la modification du Registre.

Après avoir appliqué ce correctif logiciel, vous pouvez utiliser l'entrée NestedWindowLimit du Registre afin de définir le nombre maximal de fenêtres imbriquées. Le maximum peut être compris entre 50 et 100.

Avertissement Si vous définissez une valeur différente de 50, il se peut que Windows cesse de répondre et génère un message d'erreur « Stop Error 0x7F ». Si ce problème se produit, rétablissez la valeur sur 50 ou supprimez l'entrée du Registre.

Pour définir le nombre maximal de fenêtres imbriquées, procédez comme suit :
  1. Cliquez sur Démarrer, tapez regedit dans la zone Démarrer la recherche, puis appuyez sur ENTRÉE.
  2. Recherchez la sous-clé de Registre suivante, puis cliquez dessus :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows
  3. Dans le menu Édition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
  4. Tapez USERNestedWindowLimit et appuyez sur ENTRÉE.
  5. Cliquez avec le bouton droit sur USERNestedWindowLimit, puis cliquez sur Modifier.
  6. Sous Base, cliquez sur Décimale.
  7. Dans la zone Données de la valeur, tapez une nouvelle valeur.
  8. Cliquez sur OK, puis quittez l'Éditeur du Registre.

Propriétés

Numéro d'article: 814789 - Dernière mise à jour: mercredi 13 août 2008 - Version: 4.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
Mots-clés : 
kbautohotfix kbhotfixserver kbqfe kbshell kbwin2ksp4fix kberrmsg kbwin2000presp4fix kbfix kbbug KB814789
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