Un computer che esegue Servizi terminal smette di rispondere e viene inviato il messaggio di errore in Windows 2000 o in Windows XP: "Stop Error 0x7F"

Traduzione articoli Traduzione articoli
Identificativo articolo: 814789 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Un computer che esegue Servizi terminal potrebbe bloccarsi. Quando ci˛ accade, Ŕ possibile che venga visualizzato il seguente messaggio di errore irreversibile:
0x0000007f (0x00000008) error STOP 0x7f
L'errore irreversibile si verifica nel file Win32k.sys.

Il computer, dopo essere stato arrestato e riavviato, viene avviato normalmente. Tuttavia, l'errore irreversibile si verifica regolarmente.

Il problema si verifica se il computer esegue Windows XP o Microsoft Windows 2000.

Cause

La causa del problema Ŕ la creazione da parte di un programma di fino a 100 finestre nidificate. Durante la pulitura, il thread corrente potrebbe non disporre di spazio di stack sufficiente per gestire tutte le funzioni necessarie per pulire tutti gli oggetti finestra.

Risoluzione

Dopo aver applicato questo hotfix, un programma Ŕ in grado di creare fino a un massimo di 50 finestre nidificate. Se il programma tenta di creare pi¨ di 50 finestre nidificate, l'operazione non viene eseguita. Informazioni su

Windows XP

Service Pack

Per risolvere il problema, procurarsi l'ultimo Service Pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322389 Come ottenere il Service Pack pi¨ recente per Windows XP

Informazioni sull'hotfix

╚ disponibile un hotfix supportato da Microsoft. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo pertanto solo nei sistemi in cui si verifica questo specifico problema. ╚ possibile che su questo hotfix vengano eseguiti ulteriori test. Se il problema in questione non costituisce una seria minaccia per il sistema, si consiglia pertanto di attendere il rilascio del prossimo aggiornamento software contenente questo hotfix.

Se l'hotfix Ŕ disponibile per il download, Ŕ presente la sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non compare, rivolgersi al Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se occorrono attivitÓ di risoluzione, pu˛ essere necessario creare una richiesta di assistenza separata. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" visualizza le lingue per le quali l'hotfix Ŕ disponibile. Se la propria lingua non Ŕ presente, significa che l'hotfix non Ŕ disponibile in tale lingua.
Prerequisiti
Per applicare questo hotfix, Ŕ necessario che nel computer sia installato Windows XP Service Pack 1.
Richiesta di riavvio
╚ necessario riavviare il computer una volta applicato l'hotfix.
Informazioni sulla sostituzione dell'hotfix
Questo hotfix non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC (Universal Time Coordinate). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data         Ora   Versione        Dimensione       Nome file    Piattaforma ------------------------------------------------------------------- 15/01/2004  01:49  5.1.2600.1332  1,678,208  Win32k.sys  i386 15/01/2004  01:50  5.1.2600.1332  5,623,808  Win32k.sys  IA-64

Windows 2000

Informazioni sul Service Pack

Per risolvere il problema Ŕ necessario ottenere la versione pi¨ recente del Service Pack per Windows 2000. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
260910 Acquisizione della versione pi¨ recente del service pack di Windows 2000

Informazioni sull'hotfix

╚ disponibile un hotfix supportato da Microsoft. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo pertanto solo nei sistemi in cui si verifica questo specifico problema. ╚ possibile che su questo hotfix vengano eseguiti ulteriori test. Se il problema in questione non costituisce una seria minaccia per il sistema, si consiglia pertanto di attendere il rilascio del prossimo aggiornamento software contenente questo hotfix.

Se l'hotfix Ŕ disponibile per il download, Ŕ presente la sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non compare, rivolgersi al Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se occorrono attivitÓ di risoluzione, pu˛ essere necessario creare una richiesta di assistenza separata. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" visualizza le lingue per le quali l'hotfix Ŕ disponibile. Se la propria lingua non Ŕ presente, significa che l'hotfix non Ŕ disponibile in tale lingua.
Prerequisiti
Per applicare questo hotfix, Ŕ necessario che nel computer sia installato Windows 2000 Service Pack 3.
Richiesta di riavvio
╚ necessario riavviare il computer una volta applicato l'hotfix.
Informazioni sulla sostituzione dell'hotfix
Questo hotfix non sostituisce eventuali altri hotfix.
Informazioni sui file
La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC (Universal Time Coordinate). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
  Data         Ora    Versione       Dimensione       Nome file
  ---------------------------------------------------------------
  04/03/2003  19:26   5.0.2195.6678     42,768   Basesrv.dll
  14/02/2003  18:49   5.0.2195.6660    222,992   Gdi32.dll
  14/02/2003  18:49   5.0.2195.6656    710,928   Kernel32.dll
  04/03/2003  19:26   5.0.2195.6669    333,072   Msgina.dll
  31/01/2003  18:51   5.0.2195.6661     90,232   Rdpwd.sys
  04/03/2003  19:26   5.0.2195.6666    379,664   User32.dll
  04/03/2003  19:26   5.0.2195.6671    385,296   Userenv.dll
  04/03/2003  19:24   5.0.2195.6679  1,620,176   Win32k.sys
  03/03/2003  15:14   5.0.2195.6675    181,008   Winlogon.exe
  14/02/2003  18:49   5.0.2195.6655    243,472   Winsrv.dll
  04/03/2003  19:33   5.0.2195.6661     90,200   56bit\Rdpwd.sys
  04/03/2003  19:26   5.0.2195.6656    710,928   uniproc\Kernel32.dll
  04/03/2003  19:26   5.0.2195.6679  1,620,176   uniproc\Win32k.sys
  14/02/2003  18:49   5.0.2195.6655    243,472   uniproc\Winsrv.dll
				

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine del presente articolo. Questo problema Ŕ stato corretto per la prima volta nel Service Pack 4 per Microsoft Windows 2000.

Informazioni

Per ulteriori informazioni su come ottenere un hotfix per Windows 2000 Datacenter Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
265173 Il programma Datacenter e il prodotto Windows 2000 Datacenter Server (in inglese)

Informazioni sul Registro di sistema per Windows XP

Avviso L'errata modifica del Registro di sistema tramite l'editor o un altro metodo pu˛ causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non Ŕ in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema Ŕ a rischio e pericolo dell'utente.

Dopo aver applicato l'hotfix, Ŕ possibile usare la voce del Registro di sistema per impostare un numero massimo di finestre nidificate. ╚ possibile impostare il massimo su un valore compreso tra 50 e 100.

Avviso Impostando un valore diverso da 50, Windows potrebbe bloccarsi e potrebbe essere visualizzato il messaggio di errore "Stop Error 0x7F". In questo caso, ripristinare il valore a 50 oppure rimuovere la voce del Registro di sistema.

Per impostare il numero massimo di finestre nidificate, attenersi alla procedura seguente:
  1. Fare clic sul pulsante Start, digitare regedit nella casella Inizia ricerca, quindi premere INVIO.
  2. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows
  3. Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.
  4. Digitare USERNestedWindowLimit, quindi premere INVIO.
  5. Fare clic con il pulsante destro del mouse su USERNestedWindowLimit, quindi scegliere Modifica.
  6. In Base scegliere Decimale.
  7. Nella casella Dati valore digitare un nuovo valore.
  8. Scegliere OK, e chiudere l'editor del Registro di sistema.

ProprietÓ

Identificativo articolo: 814789 - Ultima modifica: giovedý 14 agosto 2008 - Revisione: 4.4
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Chiavi:á
kbautohotfix kbhotfixserver kbqfe kbshell kbwin2ksp4fix kberrmsg kbwin2000presp4fix kbfix kbbug KB814789
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com