터미널 서비스를 실행하는 컴퓨터가 응답하지 않고 Windows 2000 또는 Windows XP에서 "Stop Error 0x7F" 오류 메시지가 나타난다

기술 자료 번역 기술 자료 번역
기술 자료: 814789 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

터미널 서비스를 실행 중인 컴퓨터가 응답하지 않을 수 있습니다. 이 문제가 발생하면 다음과 같은 중지 오류 메시지가 나타납니다.
0x0000007f (0x00000008) error STOP 0x7f
Win32k.sys 파일에서 이러한 중지 오류가 발생합니다.

컴퓨터를 종료하고 다시 시작하면 컴퓨터가 평소대로 시작됩니다. 그러나 정기적으로 중지 오류가 다시 발생합니다.

이 문제는 컴퓨터에서 Windows XP나 Microsoft Windows 2000을 실행하는 경우 발생할 수 있습니다.

원인

이 문제는 프로그램에서 중첩된 창을 100개까지 만들 수 있기 때문에 발생합니다. 정리 작업을 하는 동안 현재 스레드가 모든 창 개체를 정리하는 데 필요한 기능을 모두 처리하기에는 스택 공간이 부족할 수 있습니다.

해결 방법

이 핫픽스를 적용한 후에는 프로그램에서 중첩된 창을 50개까지 만들 수 있습니다. 프로그램에서 중첩된 창을 50개 이상 만들려고 하면 오류가 발생합니다.

Windows XP

서비스 팩 정보

이 문제를 해결하려면 Windows XP용 최신 서비스 팩을 구하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
322389 최신 Windows XP 서비스 팩을 구하는 방법

핫픽스 정보

전제 조건


이 핫픽스를 적용하려면 컴퓨터에 Windows XP 서비스 팩 1이 설치되어 있어야 합니다.

다시 시작 요구 사항


이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작해야 합니다.

핫픽스 대체 정보


이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보


이 핫픽스의 영어 버전은 아래와 같거나 그 이상의 파일 특성을 갖습니다. 이 파일의 날짜와 시간은 UTC(Coordinated Universal Time)로 나열되며 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 보려면 제어판날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.
표 축소표 확대
날짜시간버전크기파일 이름플랫폼
2004-01-1501:495.1.2600.13321,678,208Win32k.sysi386
2004-01-1501:505.1.2600.13325,623,808Win32k.sysIA-64

Windows 2000

서비스 팩 정보

이 문제를 해결하려면 Windows 2000용 최신 서비스 팩을 구하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
260910 최신 Windows 2000 서비스 팩을 구하는 방법

핫픽스 정보

현재 지원되는 핫픽스를 Microsoft에서 구할 수 있지만 이 문서에서 설명하는 문제를 해결하기 위한 것일 뿐이므로 이러한 특정 문제가 발생하는 시스템에만 이 핫픽스를 적용해야 합니다. 이 핫픽스는 나중에 추가 테스트가 필요할 수도 있습니다. 따라서 이 문제의 영향이 심각하지 않으면 이 핫픽스가 포함된 다음 Windows 2000 서비스 팩이 나올 때까지 기다리는 것이 좋습니다.

이 문제를 즉시 해결하려면 Microsoft 고객기술지원부에 문의하여 이 핫픽스를 구하십시오. Microsoft 고객기술지원부의 전체 전화 번호 목록과 지원 비용에 대한 정보를 보려면 다음 Microsoft 웹 사이트를 방문하십시오.
기술지원 서비스 안내
참고?특정 업데이트로 문제를 해결할 수 있다고 Microsoft 기술지원 전문가가 판단할 경우 지원 요청에 따른 일반적 비용이 취소될 수도 있습니다. 해당 업데이트로 해결할 수 없는 추가 질문과 문제에 대해서는 지원 비용이 청구됩니다.

전제 조건


이 핫픽스를 적용하려면 컴퓨터에 Windows 2000 서비스 팩 3이 설치되어 있어야 합니다.

다시 시작 요구 사항


이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작해야 합니다.

핫픽스 대체 정보


이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보


이 핫픽스의 영어 버전은 아래와 같거나 그 이상의 파일 특성을 갖습니다. 이 파일의 날짜와 시간은 UTC(Coordinated Universal Time)로 나열되며 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 보려면 제어판날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.
표 축소표 확대
날짜시간버전크기파일 이름
2003-03-0419:265.0.2195.667842,768Basesrv.dll
2003-02-1418:495.0.2195.6660222,992Gdi32.dll
2003-02-1418:495.0.2195.6656710,928Kernel32.dll
2003-03-0419:265.0.2195.6669333,072Msgina.dll
2003-01-3118:515.0.2195.666190,232Rdpwd.sys
2003-03-0419:265.0.2195.6666379,664User32.dll
2003-03-0419:265.0.2195.6671385,296Userenv.dll
2003-03-0419:245.0.2195.66791,620,176Win32k.sys
2003-03-0315:145.0.2195.6675181,008Winlogon.exe
2003-02-1418:495.0.2195.6655243,472Winsrv.dll
2003-03-0419:335.0.2195.666190,20056bit\Rdpwd.sys
2003-03-0419:265.0.2195.6656710,928uniproc\Kernel32.dll
2003-03-0419:265.0.2195.66791,620,176uniproc\Win32k.sys
2003-02-1418:495.0.2195.6655243,472uniproc\Winsrv.dll

현재 상태

Microsoft는 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열한 제품에서 이 문제를 확인했습니다. 이 문제는 Microsoft Windows 2000 서비스 팩 4에서 처음 해결되었습니다.

추가 정보

Windows 2000 Datacenter Server용 핫픽스를 구하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
265173 Datacenter 프로그램 및 Windows 2000 Datacenter Server 제품

Windows XP 레지스트리 정보

경고 레지스트리 편집기나 다른 방법을 사용하여 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 이러한 문제의 해결을 보증하지 않습니다. 레지스트리 수정에 따른 모든 책임은 사용자에게 있습니다.

이 핫픽스를 적용한 후에는 NestedWindowLimit 레지스트리 항목을 사용하여 중첩된 창의 최대 수를 설정할 수 있습니다. 최대 수를 50에서 100 사이의 값으로 설정할 수 있습니다.

경고 50이 아닌 값을 설정하면 Windows가 응답하지 않을 수 있으며 "Stop Error 0x7F" 오류 메시지가 나타날 수 있습니다. 이 문제가 발생하면 값을 50으로 복원하거나 레지스트리 항목을 제거하십시오.

중첩된 창의 최대 수를 설정하려면 다음과 같이 하십시오.
  1. 시작을 누르고 검색 시작 상자에 regedit를 입력한 다음 Enter 키를 누릅니다.
  2. 다음 레지스트리 하위 키를 찾아서 누릅니다.
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows
  3. 편집 메뉴에서 새로 만들기를 가리킨 다음 DWORD 값을 누릅니다.
  4. USERNestedWindowLimit를 입력한 다음 Enter 키를 누릅니다.
  5. USERNestedWindowLimit를 마우스 오른쪽 단추로 누른 다음 수정을 누릅니다.
  6. 단위에서 10진수를 누릅니다.
  7. 값 데이터 상자에 새 값을 입력합니다.
  8. 확인을 누른 다음 레지스트리 편집기를 종료합니다.




Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 814789 - 마지막 검토: 2007년 11월 14일 수요일 - 수정: 4.3
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 서비스 팩 3
  • Microsoft Windows 2000 서비스 팩 2
  • Microsoft Windows 2000 서비스 팩 1
  • Microsoft Windows 2000 서비스 팩 3
  • Microsoft Windows 2000 서비스 팩 2
  • Microsoft Windows 2000 서비스 팩 1
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
키워드:?
kberrmsg kbbug kbfix kbshell kbwin2000presp4fix kbqfe kbwin2ksp4fix kbhotfixserver KB814789

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com