BUG: La ╚ visualizzato un messaggio di "Errore di disco o rete", quando si aprono i file di database di Access 2.0 in Access 2000 o Access 2002

Traduzione articoli Traduzione articoli
Identificativo articolo: 814811 - Visualizza i prodotti a cui si riferisce l?articolo.
Richiedente: Richiede la conoscenza dell'interfaccia utente a utente singolo computer.
Il contenuto di questo articolo Ŕ applicabile solo ai database Microsoft Access (mdb).

Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di aprire un file di database di Access 2.0 (MDB) in Microsoft Access 2000 o Access 2002, viene potrebbe essere visualizzato un messaggio di errore analogo al seguente:
Disco o errore di rete.

Cause

Questo problema pu˛ verificarsi se il nome del file di Access 2.0 o un nome di cartella nel percorso del file contiene caratteri a doppio byte character set (DBCS).

Risoluzione

Informazioni sul Service pack

Per risolvere il problema, ottenere il service pack pi¨ recente per Microsoft Jet 4.0. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
239114Come ottenere il service pack pi¨ recente per il motore di database Microsoft Jet 4.0

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.
La versione globale di questo presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.

   Hotfix for Windows 2000 Service Pack 3 (SP3), where LOCALIZATION TAG represents a country specific tag:

   Date         Time      Version     Size       File name
   -------------------------------------------------------------------------
   06-Feb-2003  02:13:52  5.3.10.0    1,924,720  Q813696_W2K_SP4_X86_LOCALIZATION TAG.exe

   Hotfix for Windows XP Service Pack 1(SP1):

   Date         Time      Version     Size       File name
   -------------------------------------------------------------------------
   11-Feb-2003  02:39:58  5.3.10.0    1,917,288  Q813696_WXP_SP2_x86_LOCALIZATION TAG.exe
				
Dopo avere installato l'aggiornamento rapido, la versione globale di questa correzione Ŕ in deve essere di avere i seguenti attributi di file o versioni successive:
   Date         Time      Version     Size       File name
   --------------------------------------------------------------
   05-Feb-2003  22:01:40  4.0.5919.0    512,031  Msexch40.dll
   17-Dec-2002  00:42:24  4.0.6701.0    319,519  Msexcl40.dll
   05-Feb-2003  22:01:40  4.0.7308.0  1,503,262  Msjet40.dll
   17-Dec-2002  00:42:28  4.0.6524.0    348,195  Msjetoledb40.dll
   05-Feb-2003  22:01:40  4.0.6813.0    241,695  Msjtes40.dll
   17-Dec-2002  00:42:30  4.0.6610.0    348,191  Mspbde40.dll
   05-Feb-2003  22:01:40  4.0.7308.0    421,919  Msrd2x40.dll
   17-Dec-2002  00:42:32  4.0.6610.0    552,991  Msrepl40.dll
   17-Dec-2002  00:42:34  4.0.6610.0    344,095  Msxbde40.dll
				

Workaround

Per risolvere questo problema, rimuovere i caratteri a doppio byte dal nome del file dei comandi. Se il percorso contiene caratteri a byte doppio, rinominare cartelle rilevanti per rimuovere i caratteri DBCS o spostare il file di Access 2.0 in una cartella che contiene solo caratteri a byte singolo. Ad esempio, Ŕ possibile spostare il file nella directory principale di unitÓ C (C:\).

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Questo problema Ŕ stato corretto in Jet 4.0 Service Pack 7.

ProprietÓ

Identificativo articolo: 814811 - Ultima modifica: venerdý 7 ottobre 2005 - Revisione: 3.4
Le informazioni in questo articolo si applicano a:
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
Chiavi:á
kbmt kbautohotfix kbhotfixserver kbtshoot kbdbcs kbopenfile kberrmsg kbqfe kbfix kbbug KB814811 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 814811
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com