PRB: Obnovení systému Windows not monitor soubory opravy (MSP) Instalační služba Windows Installer

Překlady článku Překlady článku
ID článku: 814833 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při pokusu o obnovení počítače se systémem BEZE bodu obnovení před použita oprava nebo aktualizace service pack aplikace použita opravy může dosáhnout nepoužitelný stavu. Při pokusu o opravu, instalaci, přeinstalovat nebo odebrat aplikaci obdržet následující chybovou zprávu:
„ Tento opravný balíček nelze otevřít. Ověřte, zda opravný balíček existuje a že můžete k němu přístup nebo obraťte na dodavatele aplikace a ověřte, zda se jedná o platný opravný balíček Instalační služba Windows Installer."

Příčina

K tomuto problému dochází, protože systému XP obnovení sledování soubory opravy Instalační služba Windows Installer (MSP). Při instalaci souborů opravy mezipaměti oprava není obnovena ve složce \Installer Windows Folder. Service Pack 2 (SP2) je také kumulativní. Obsahuje předchozí soubory QFE (Quick Fix Engineering). Po instalaci SP2, jednotlivé QFE, které jste nainstalovali zastarají. Instalační služba Windows Installer odebere konfigurační data pro opravy QFE včetně klíčů registru.

Protože při použití nástroje Obnovení systému v mezipaměti opravy chybí, pokusí se Instalační služba Windows Installer mezipaměti opravu znovu z této opravy registrované zdrojového umístění. Umístění zdroje registrované pro mnoho aplikací opravy je však složky Temp. Tato složka je přechodné zdrojového umístění. Soubory ve složce Temp jsou obvykle odstraněny po jejich použití. Proto soubory Instalační služba Windows Installer pokusí vyhledejte umístění přechodné zdroje pravděpodobně nebyl nalezen. K chybě dojde, protože Instalační služba Windows Installer nelze najít opravy Instalační služba Windows Installer (MSP) soubory.

Řešení

Tento problém vyřešit, znovu použít opravy chybí. Sdílení sítě nebo média, která je k dispozici je oprava umístění, může být schopni vyhledat a opravu odtud. Můžete také nainstalovat nejnovější opravu Service Pack pro aplikaci, protože obsahuje nejnovější aktualizace service pack předchozí QFE. Kumulativní oprava vztahuje chybějící opravy aplikace a provede zastaralé jednotlivé opravy chybí.

Prohlášení

Toto chování je záměrné.

Další informace

Kroky pro reprodukci chování
  1. Nainstalujte aplikaci (například Office XP) v počítači. Ve výchozím nastavení je vytvořen bod obnovení. Tento bod obnovení ukládá stavu systému před instalací nové aplikace.

    Poznámka: Operační systém nainstalovat nové aplikace automaticky vytvoří bod obnovení.
  2. Nainstalujte aktualizaci service pack pro aplikaci nainstalována v kroku 1. Například instalaci aktualizace Service Pack 1 pro sadu Office XP.
  3. Instalovat některé opravy QFE (Quick Fix Engineering) pro aplikaci. Například nainstalovat dva QFE pro sadu Office XP.
  4. Vytvořit bod obnovení.

    Kroky vytvoření bodu obnovení v systému Windows XP
    1. Klepněte na tlačítko Start, přejděte na příkaz programy, přejděte na položku Příslušenství, přejděte na položku Systémové nástroje a potom klepněte na položku Obnovení systému.
    2. Klepnutím vyberte vytvořit bod obnovení a potom klepněte na tlačítko Další.
    3. Zadejte Před SP2 obnovení boduobnovení přejděte popis textové pole.
    4. Klepněte na tlačítko vytvořit.
  5. Instalace aktualizace Service Pack 2 pro aplikaci. Například nainstalovat aktualizaci SP2 pro sadu Office XP.
    Poznámka: SP2 obsahuje předchozí QFE. Tento krok umožňuje jednotlivé QFE nainstalované v kroku 3 zastaralé. Instalační služba Windows Installer odebere konfigurační data pro opravy QFE včetně klíčů registru a soubory v mezipaměti.
  6. Ověřit zdrojové soubory aktualizace service Pack a QFE nejsou přístupné prostřednictvím počítače. Odeberte například síťové sdílené položce QFE.
  7. Obnovit systém do stavu před instalací aktualizace Service Pack 2.

    Kroky k obnovení systému Windows XP
    1. Klepněte na tlačítko Start, přejděte na příkaz programy, přejděte na položku Příslušenství, přejděte na položku Systémové nástroje a potom klepněte na položku Obnovení systému.
    2. Klepnutím vyberte obnovit dřívější mého počítače a potom klepněte na tlačítko Další.
    3. Vyberte datum provedení kroku 4 a potom vyberte Bod obnovení SP2 před ze seznamu bodů obnovení.
    4. Klepněte na tlačítko Další.
  8. Pokuste se opravit nebo odebrat aplikace nebo zkuste aplikaci znovu nainstalovat. Obdržet chybovou zprávu jako uvedené "Příznaky" oddílu.

Odkazy

Další informace naleznete v následujících článcích znalostní báze Microsoft Knowledge Base:
302796Informace o řešení potíží s nástrojem Obnovení systému v systému Windows XP
303354Chybová zpráva: Obnovení systému nelze vytvořit bod obnovení
310405Postup při zapnutí a vypnutí obnovení systému v systému Windows XP
306084Postupy: Obnovení předchozího stavu v systému Windows XP operačního systému

Vlastnosti

ID článku: 814833 - Poslední aktualizace: 5. listopadu 2003 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Klíčová slova: 
kbmt kbupgrade kbsetup kbappsetup kbpreinstall kbprb KB814833 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:814833

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com