PRB: Windows-Systemwiederherstellung wird nicht Windows Installer-Patch (.msp) Dateien überwachen.

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 814833 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Problembeschreibung

Wenn Sie versuchen, Ihr Computer wiederherzustellen Ausgangspunkt Wiederherstellung, bevor Sie Windows XP angewendet einen Patch oder Servicepack, die Anwendung, die Sie den Patch angewendet kann einen nicht verwendbaren Zustand erreichen. Wenn Sie versuchen, zu reparieren, installieren, installieren oder Entfernen der Anwendung erhalten Sie folgende Fehlermeldung:
"Das Patchpaket konnte nicht geöffnet werden. Stellen Sie sicher, dass das Patchpaket vorhanden ist und, dass Sie es zugreifen können, oder wenden Sie sich an den Anwendungshersteller überprüfen, ob dies ein gültiges Windows Installer-Patchpaket ist sich."

Ursache

Dieses Problem tritt auf, weil Windows XP-Wiederherstellen die Windows Installer-Patch (.msp)-Dateien nicht überwacht. Wenn Sie die Patchdateien installieren, wird der zwischengespeicherte Patch nicht im Ordner \Installer Windows Folder wiederhergestellt. Außerdem ist Service Pack 2 (SP2) kumulativ. Es enthält die vorherige Quick Fix Engineering (QFE)-Dateien. Nach der Installation veraltet SP2, einzelne QFEs, die Sie installiert. Windows Installer werden die Konfigurationsdaten für die QFE-Patches, einschließlich der Registrierungsschlüssel entfernt.

Da der zwischengespeicherte Patch, fehlt Wenn Sie die Systemwiederherstellung verwenden, versucht Windows Installer zum Zwischenspeichern des Patches erneut aus dem der Patch registrierte Quelle. Die registrierte Quellposition für viele Anwendungspatches ist jedoch der Ordner "Temp". Dieser Ordner ist eine vorübergehende Quelle. In der Regel werden die Dateien im Ordner TEMP gelöscht, nachdem Sie diese. Daher können die Dateien, die Windows Installer versucht, suchen Sie in den vorübergehende Quellpfad nicht gefunden. Der Fehler auftritt, weil Windows Installer den Windows Installer-Patch (.msp) nicht finden kann Dateien.

Lösung

Um dieses Problem zu umgehen, übernehmen Sie die Patches, die fehlen. Wenn der Patch-Speicherort ein Netzwerk oder Medien Netzwerkfreigabe befindet, verfügbar ist, möglicherweise Sie suchen und von dort aus den Patch anwenden können. Sie können auch das neueste Service Pack-Patch für die Anwendung installieren, da das neueste Servicepack der vorherigen QFEs enthält. Der kumulative Patch gilt die fehlenden Patches für die Anwendung und macht die einzelnen fehlenden Patches veraltet.

Status

Es handelt sich hierbei um ein beabsichtigtes Verhalten.

Weitere Informationen

Schritte zum Reproduzieren des Verhaltens
  1. Installieren einer Anwendung (z. B. Office XP) auf Ihrem Computer. Standardmäßig ist ein Punkt Wiederherstellung erstellt. Dieser Punkt Wiederherstellung speichert den Zustand des Systems vor der Installation der neuen Anwendung.

    Hinweis: Wenn Sie eine neue Anwendung installieren, erstellt das Betriebssystem automatisch einen Punkt wiederherstellen.
  2. Installieren Sie ein Servicepack für die Anwendung, die Sie in Schritt 1 installiert. Installieren Sie z. B. Service Pack 1 für Office XP.
  3. Installieren Sie einige Quick Fix Engineering (QFE)-Patches für die Anwendung. Installieren Sie beispielsweise, zwei QFE für Office XP.
  4. Einen Wiederherstellungspunkt erstellen.

    Schritte zum Erstellen eines Wiederherstellungspunktes auf Windows XP
    1. Klicken Sie auf Start , zeigen Sie auf Programme , zeigen Sie auf Zubehör , zeigen Sie auf Systemprogramme und klicken Sie dann auf Systemwiederherstellung .
    2. Klicken Sie auf einen Wiederherstellungspunkt erstellen auswählen, und klicken Sie dann auf Weiter .
    3. Geben Sie Vor SP2 Wiederherstellung zeigen Sie im Textfeld Wiederherstellen zeigen Beschreibung .
    4. Klicken Sie auf Erstellen .
  5. Installieren Sie Service Pack 2 für die Anwendung. Installieren Sie für Office XP SP2 beispielsweise.
    Hinweis: SP2 enthält die vorherige QFEs. Diese Schritt stellt einzelne QFEs, die Sie in Schritt 3 veraltet installiert. Windows Installer werden die Konfigurationsdaten für die QFE-Patches, einschließlich der im Registrierungsschlüssel und die zwischengespeicherten Dateien entfernt.
  6. Stellen Sie sicher, dass die Quelldateien für Servicepacks und die QFEs nicht über Ihren Computer zugänglich sind. Z. B. Entfernen der Netzwerkfreigabe für das QFE.
  7. Wiederherzustellen Sie um den Zustand vor der Installation von Service Pack 2 des Systems.

    Schritte zum Wiederherstellen des Systems auf Windows XP
    1. Klicken Sie auf Start , zeigen Sie auf Programme , zeigen Sie auf Zubehör , zeigen Sie auf Systemprogramme und klicken Sie dann auf Systemwiederherstellung .
    2. Klicken Sie auf auf meinem Computer zu einem früheren Zeitpunkt wiederherstellen , und klicken Sie dann auf Weiter .
    3. Wählen Sie das Datum, dass Schritt 4 durchgeführt, und wählen Sie dann aus der Liste der Wiederherstellung Punkte Vor SP2 Wiederherstellung Point .
    4. Klicken Sie auf Weiter .
  8. Versuchen Sie, reparieren oder Entfernen der Anwendung, oder versuchen Sie, die Anwendung erneut zu installieren. Möglicherweise sinngemäß die Fehlermeldung wie in "Problembeschreibung" erwähnte Abschnitt.

Informationsquellen

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
302796Problembehandlung bei der Systemwiederherstellung in Windows XP
303354Fehlermeldung: Systemwiederherstellung konnte keinen Wiederherstellungspunkt erstellen
310405Aktivieren und Deaktivieren der Systemwiederherstellung in Windows XP
306084Gewusst wie: Wiederherstellen des Betriebssystems in einem früheren Zustand in Windows XP

Eigenschaften

Artikel-ID: 814833 - Geändert am: Mittwoch, 5. November 2003 - Version: 3.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbmt kbupgrade kbsetup kbappsetup kbpreinstall kbprb KB814833 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 814833
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com