Access may stop responding when you try to create an MDE or ACCDE file, or an ADE file

Article translations Article translations
Article ID: 814858 - View products that this article applies to.
Moderate: Requires basic macro, coding, and interoperability skills.
This article applies to a Microsoft Access database (.mdb or .accdb) and a Microsoft Access project (.adp).
Expand all | Collapse all

SYMPTOMS

When you try to save an Access database file (.mdb or .accdb) as an MDE file (.mde) or ACCDE file (.accde), or when you try to save an Access project file (.adp) as an ADE (.ade) file, Access may stop responding. You may receive the following error message:
Microsoft Access has encountered a problem and needs to close. We are sorry for the inconvenience.
Please tell Microsoft about this problem.
We have created an error report that you can send to help us improve Microsoft Access. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.

If you click the link for To see what data this error report contains, click here, you may receive the following error signature:
AppName: msaccess.exe AppVer: 10.0.3409.0 ModName: mso.dll ModVer: 10.0.3501.0 Offset: 0001c4c5

Additionally, other offsets, other versions of Access, and other versions of the mso.dll are possible.

CAUSE

This problem may occur when the compiled Visual Basic for Applications (VBA) project of the .mdb file or the .adp file is corrupted.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

WORKAROUND

To work around this problem, you can reload the VBA project of the Access database from text and then create the MDE file or the ACCDE file, or the ADE file. To do this, follow these steps:

Note Make a backup copy of the database before you start these steps.
  1. On the taskbar, click start and then click Run.
  2. Type <Microsoft_Access_Path>\msaccess.exe /decompile and then click OK.

    Note <Microsoft_Access_Path> is the path of the folder where Access is installed.
  3. Open the original .mdb file, the original.accdb file, or the original .adp file that you want to save as the new MDE file, ACCDE file, or ADE file. To do this, follow these steps:
    1. Press ALT+F11 to open the Visual Basic Editor.
    2. On the Debug menu, click Compile <DatabaseName>.
    3. On the File menu click Save <DatabaseName>, and then close the Visual Basic Editor.
  4. In Microsoft Office Access 2003 or in earlier versions of Access, click Database Utilities on the Tools menu, and then click Make MDE File or click Make ADE File.

    In Access 2010 and Access 2007, click the Database Tools tab, and then click Make ACCDE File or click Make ADE in the Database Tools group.
  5. In the Save MDE As dialog box, in the Save As dialog box, or in the Save ADE As dialog box, locate the folder where you want to save the MDE, the ACCDE file, or the ADE file, type the file name in the File name box, and then click Save.

REFERENCES

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
278376 ACC2002: "Make MDE File" or "Make ADE File" Command Is Not Available
289686 ACC2002: Error Message: "Microsoft Access Was Unable to Create an MDE Database"

Properties

Article ID: 814858 - Last Review: September 30, 2011 - Revision: 6.0
APPLIES TO
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 2010
Keywords: 
kbstoprespond kberrmsg kbbug kbnofix KB814858

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com