MODÈLE : accord partenaire entre les organisations qui ont le même numéro DUNS provoque un comportement inattendu est

Traductions disponibles Traductions disponibles
Numéro d'article: 815139 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous utilisez l'Assistant accord partenaire qui est fourni avec Microsoft BizTalk Accelerator for RosettaNet, vous pouvez sélectionner l'option pour enregistrer un accord sous la forme d'un fichier .vbs. Si vous exécutez ce fichier ultérieurement pour créer un accord, vous pouvez remarquer que pas tous les ports et les chaînes qui sont requises pour l'accord sont créés.

Lorsque cela se produit, vous pouvez également remarquer suivantes :
  • Pas toutes les écritures qui sont généralement créées pour un accord partenaire apparaissent dans l'accélérateur pour interface RosettaNet MMC (Microsoft Management Console).
  • Si vous affichez les chaînes qui sont associés à l'accord, les entrées qui apparaissent indiquent que les canaux associés ont le statut manquant .

Cause

Ce problème peut se produire dans les conditions suivantes :
  • Vous avez plusieurs organisations qui ont le même numéro DUNS.

    -et-
  • Vous créez plusieurs contrats à l'aide de ces organisations.
Si vous utilisez l'Assistant accord partenaire pour créer l'accord (au lieu de l'enregistrement d'un fichier .vbs), vous recevez un message d'erreur un doublon DUNS numéro existe. Toutefois, les scripts .vbs qui génère l'Assistant accord partenaire n'arrêtent pas traitement lorsqu'une erreur DUNS en double se produit.

Les scripts échouent sans générer de messages d'erreur, mais ils toujours créent certains objets Gestion de messagerie qui ne sont pas valides pour les besoins d'un accord partenaire. Ce comportement provoque relations partenaire à créer dans Accelerator for RosettaNet MMC interface qui n'ont pas canaux correspondants.

Résolution

N'utilisez pas le même numéro DUNS pour plusieurs organisations si vous souhaitez utiliser ces organisations dans les accords de partenaires commerciaux de BizTalk Accelerator pour RosettaNet.

Statut

Ce comportement est voulu par la conception même du produit.

Plus d'informations

Procédure pour reproduire le comportement

  1. Utilisez l'Assistant d'accord partenaire pour créer un accord commercial entre deux organisations, organisation A et B:organisation
    1. Utiliser 111111111 comme numéro DUNS pour l'organisation a.
    2. Utilisez 222222222 comme les DUNS numéro hiérarchique b.
    3. Lorsque vous y êtes invité, sélectionnez l'option à utiliser un PIP existant et sélectionnez PIP 0A1 .
    4. Poursuivez l'Assistant accord partenaire. Sur la dernière page, cliquez ici pour créer le contrat, puis cliquez sur Terminer .
  2. L'Assistant accord partenaire permet de créer un autre accord commercial. Créer un accord entre organisation C et D:organisation
    1. Utiliser 111111111 comme numéro DUNS pour l'organisation c.
    2. Utilisez 333333333 comme les DUNS numéro hiérarchique d.
    3. Essayez de créer ce contrat de l'Assistant. Vous recevez un message d'erreur ce numéro DUNS est déjà utilisé.
    4. Sélectionner l'option pour créer un fichier VBScript et puis enregistrer cet accord en tant que fichier .vbs sur votre disque dur.
    5. Quitter l'Assistant et double-cliquez sur le fichier .vbs pour l'exécuter.
  3. Après avoir exécuté le fichier .vbs, actualiser les accords partenaires de Accelerator for RosettaNet MMC interface. Notez qu'un accord pour une organisation à Entreprise b. Cependant, au lieu d'un accord entre organisation C et D organisation, il existe un accord entre une organisation et organisation d.
  4. Cliquez avec le bouton droit sur l'accord entre un organigramme et Organigramme D et puis afficher les canaux. Il présente l'état manquant . Dans le Gestionnaire de messagerie BizTalk, Notez qu'aucun ports ou les canaux ont été créées pour le second accord entre organisation C et d. organisation

Propriétés

Numéro d'article: 815139 - Dernière mise à jour: mercredi 12 mars 2003 - Version: 1.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft BizTalk Accelerator for RosettaNet 2.0 Enterprise Edition
Mots-clés : 
kbmt kbprb KB815139 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 815139
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com