The Remote Access Service Security DLL Is Incorrectly Used to Authenticate Non-Modem Remote Access Connections

Article translations Article translations
Article ID: 815182 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

When you create and install a custom Remote Access service security DLL on a Windows 2000 Server-based computer that is running the Routing and Remote Access service to authenticate remote users, the RAS security DLL may be incorrectly used to authenticate remote users who use a connection type other than a modem connection. For example, the Remote Access service security DLL is used to authenticate users who connect by using a Virtual Private Networking (VPN) connection. Because of this, VPN users may receive an "Error 619" error message when they try to access the server.

CAUSE

This problem occurs because Windows does not check the connection type before it calls the Remote Access service security DLL. Because of this, the Remote Access service security DLL is used for both modem and non-modem connections.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   -----------------------------------------------------
   20-Feb-2003  20:15  5.0.2195.6666  69,904  Mprddm.dll
Note Because of file dependencies, this update requires Windows 2000 Service Pack 3 (SP3).


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

As of March 2003, Windows 2000 provides Remote Access service security host support for asynchronous modem connections only. The following other types of connections are not supported:
  • Ethernet, which is not a modem connection.
  • VPN, which is not a modem connection.
  • ISDN, which is a synchronous connection.
For more information about Remote Access service security host support and the Remote Access service security DLL, view the Remote Access service Security Host Support topic in the Remote Access Service section of the Microsoft Platform SDK documentation. To view this documentation, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/aa446722.aspx

Properties

Article ID: 815182 - Last Review: October 26, 2013 - Revision: 3.7
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kbnetwork kberrmsg kbenv kbprb kbqfe kbwin2000presp4fix kbfix kbbug KB815182

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com