User Can Restart Windows 2000 Terminal Server Without Having Restart Rights

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Article ID: 815225 - View products that this article applies to.
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SYMPTOMS

A user is logged on to a Terminal Services session that is hosted by a computer that is running Windows 2000 Server. The user does not have administrative credentials or other rights that specify the ability to shut down or restart the server. However, the user is able to restart the server.

CAUSE

The problem occurs when the Msgina.dll file is exclusively locked by another Terminal Services session. This causes the winlogon process in the second session to prompt for a server restart because the session did not successfully load the Msgina.dll file.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date           Time   Version        Size     File name
---------------------------------------------------------
03-March-2003  08:49  5.0.2195.6672  167,936  Sp3res.dll
03-March-2003  09:14  5.0.2195.6675  181,008  Winlogon.exe


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

Properties

Article ID: 815225 - Last Review: February 27, 2014 - Revision: 1.7
APPLIES TO
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbsecurity kbwin2ksp4fix kbwin2000presp4fix kbfix kbbug KB815225

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