ID do artigo: 815266 - Última revisão: terça-feira, 24 de julho de 2007 - Revisão: 5.11

Erro "Seu privilégio de logon interativo tem sido desativado" ao tentar fazer logon em um servidor de terminal

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Sintomas

Quando você tenta fazer logon um servidor de terminal baseado no Microsoft Windows 2003, você receberá a seguinte mensagem de erro:
O privilégio de logon interativo foi desativado. Contate o administrador do sistema.

Causa

Esse problema pode ocorrer se você tentar usar a conta de usuário convidado para fazer logon após você adicionar a conta ao grupo interno de segurança usuários de área de trabalho remota. Você também pode receber esse erro se você tentar fazer logon usando qualquer conta de usuário que negado permissões de leitura para o Active Directory serviço de diretório.

Esse comportamento ocorre porque o domínio de conta de usuário convidado negado permissões de leitura às informações de conta de usuário no Active Directory. Quando uma conta é negada a permissão de leitura para o seu Active Directory ou as informações de conta local no banco de dados Gerenciador de contas de segurança do Windows (SAM), a solicitação de logon é malsucedida porque o sistema operacional não pode determinar se o usuário tem permissão para fazer logon no Windows.

Resolução

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.

Para sistemas de 32 bits

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Jul-2004  23:38  5.2.3790.193      540,672  Winlogon.exe     
   19-Jul-2004  06:32                        271  Branches.inf
   22-Jul-2004  05:12                      9,766  Kb815266.cat
   20-Jul-2004  03:21                        354  Updatebr.inf
   22-Jul-2004  03:31                      5,657  Update_rtmqfe.inf

Para sistemas de 64 bits

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Jul-2004  09:30  5.2.3790.193      638,464  Winlogon.exe     IA64
   18-Jul-2004  21:22                        271  Branches.inf
   22-Jul-2004  05:12                      9,766  Kb815266.cat
   22-Jul-2004  03:45                        354  Updatebr.inf
   22-Jul-2004  03:45                      5,677  Update_rtmqfe.inf

Como Contornar

Para contornar esse problema, edite o registro Windows no servidor de terminal para que ele faz com que o processo de Winlogon ignorar erros de leitura de dados de configuração de serviços de terminal e para que ele lê os dados DefaultUserConfig em vez disso. Para fazer isso, siga estas etapas.

Aviso : após você seguir essas etapas, um conta de usuário cuja ler permissões para o banco de dados SAM local ou para o Active Directory, você removeu intencionalmente para impedir o logon ao servidor de terminal, poderá fazer logon no servidor de terminal.
  1. Clique em Iniciar , clique em Executar , digite regedit na caixa Abrir e, em seguida, clique em OK .

    importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows
  2. Localize a seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
  3. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  4. Na caixa novo valor # 1 , digite IgnoreRegUserConfigErrors e, em seguida, pressione ENTER.
  5. Clique com o botão direito do mouse IgnoreRegUserConfigErrors e em seguida, clique em Modificar .
  6. Na caixa dados do valor , digite 1 (um), clique em decimal e, em seguida, clique em OK .
  7. Feche o Editor do Registro.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe KB815266 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 815266  (http://support.microsoft.com/kb/815266/en-us/ )