Komputer nie wychodzi poprawnie ze stanu hibernacji lub funkcja Wake-on-LAN nie wyprowadza go ze stanu wstrzymania

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 815304 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Gdy komputer z systemem Microsoft Windows XP wychodzi ze stanu hibernacji (S4) lub funkcja Wake-on-LAN próbuje wyprowadzić go ze stanu wstrzymania (S3), można zaobserwować jeden lub kilka spośród następujących symptomów:
  • Ekran nie jest wyświetlany poprawnie i mogą pojawić się zniekształcone znaki.
  • Ekran może być pusty.
  • Komputer przestaje odpowiadać.
Symptomy mogą się zmieniać w zależności od zainstalowanej w komputerze karty wideo.

Przyczyna

Ten problem może wystąpić w jednej z następujących sytuacji:
  • Został zainstalowany dodatek Service Pack 1 (SP1) dla systemu Windows XP.
  • Została zainstalowana poprawka opisana w następującym artykule z bazy wiedzy Microsoft Knowledge Base:
    306676 Komputer nie może wejść w tryb wstrzymania lub hibernacji, jeśli działa wygaszacz ekranu oparty na Direct3D
  • Komputer z systemem Windows XP z dodatkiem Service Pack 2 (SP2) ma włączoną funkcję Wake-on-LAN i komputer wychodzi ze stanu wstrzymania S3, na skutek nadejścia żądania sieciowego ping, takiego jak żądanie generowane przez połączenie Pulpitu zdalnego (RDP, Remote Desktop).

Rozwiązanie

Informacje o poprawce

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednak jest ona przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tę poprawkę należy stosować tylko w tych systemach, w których występuje opisany problem. Poprawka może być nadal w fazie testowania. Jeżeli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów Pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka.

Informacje dotyczące plików

Wersja anglojęzyczna tej poprawki ma atrybuty plików pokazane w poniższej tabeli (lub nowsze). Daty i godziny ostatniej modyfikacji plików podano zgodnie z czasem UTC (Coordinated Universal Time). Są one zamieniane na czas lokalny po wyświetleniu informacji o pliku. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, skorzystaj z karty Strefa czasowa narzędzia Data i godzina w Panelu sterowania.
Windows XP, wersje 64-bitowe
   Data       Godzina  Wersja            Rozmiar  Nazwa pliku       Platforma
   ----------------------------------------------------------------------
   14-sty-2005  16:44  5.1.2600.1619   1 485 312  User32.dll     IA-64
   14-sty-2005  05:01  5.1.2600.1619   5 630 080  Win32k.sys
   14-sty-2005  16:47  5.1.2600.1619     557 056  Wuser32.dll    x86
Windows XP, wersje 32-bitowe
   Data       Godzina  Wersja            Rozmiar  Nazwa pliku       Platforma
   --------------------------------------------------------------------
   114-sty-2005  16:47  5.1.2600.1619   574 464    User32.dll  x86 
   14-sty-2005   05:28  5.1.2600.1619   1 845 888  Win32k.sys  x86 
   14-sty-2005   05:50  5.1.2600.2597   1 836 032  Win32k.sys  x86 

Obejście problemu

Aby obejść ten problem, należy tymczasowo wyłączyć funkcję hibernacji (S4). Aby to zrobić, wykonaj następujące kroki:
  1. Kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania.
  2. Kliknij dwukrotnie polecenie Opcje zasilania.
  3. Kliknij kartę Hibernacja.
  4. Kliknij, aby wyczyścić pole wyboru Włącz hibernację, a następnie kliknij przycisk OK.

    Uwaga Opisana w tym artykule poprawka jest jedynym rozwiązaniem problemu dotyczącego funkcji Wake on LAN stosowanej z trybu S3. Nie istnieje inne obejście tego problemu.

Stan

Firma Microsoft potwierdziła, że jest to usterka występująca w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą”.

Właściwości

Numer ID artykułu: 815304 - Ostatnia weryfikacja: 11 września 2008 - Weryfikacja: 5.1
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Słowa kluczowe: 
kbautohotfix kbhotfixserver kbqfe kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB815304

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com