计算机不能从休眠状态下恢复或不能从待机状态下通过 LAN 唤醒 (Wake-on-LAN)

文章翻译 文章翻译
文章编号: 815304 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

当基于 Microsoft Windows XP 的计算机从休眠状态 (S4) 下恢复或尝试从待机状态 (S3) 下通过 LAN 唤醒时,您可能会遇到以下一个或多个症状:
  • 屏幕不能正确显示,并且可能出现乱码。
  • 屏幕空白。
  • 计算机停止响应。
具体症状可能会因计算机上安装的视频适配器而异。

原因

在以下某一情况下,可能会发生此问题:
  • 安装了 Windows XP Service Pack 1 (SP1)。
  • 安装了下面的 Microsoft 知识库文章中介绍的修补程序:
    306676 如果在运行基于 Direct3D 的屏幕保护程序,计算机将无法进入待机或休眠状态
  • 运行 Windows XP Service Pack 2 (SP2) 的计算机启用了“通过 LAN 唤醒”,由于网络 ping 请求(如远程桌面 (RDP) 连接生成的请求),计算机将从 S3(待机状态)电源状态下恢复。

解决方案

修补程序信息

Microsoft 目前提供了一个受支持的修补程序。但是,此修补程序仅用于修复本文所述的问题。请仅将此修补程序应用于出现这一特定问题的系统。此修补程序可能还会接受进一步的测试。因此,如果这个问题没有给您造成严重的影响,我们建议您等待包含此修补程序的下一个 Service Pack。

要解决此问题,请向 Microsoft 在线客户服务提交请求以获取该修补程序。要提交联机请求以获取该修补程序,请访问下面的 Microsoft 网站:
http://go.microsoft.com/?linkid=6294451
注意:如果发生其他问题或需要进行任何疑难解答,则您可能需要创建单独的服务请求。对于此特定修补程序无法解决的其他支持问题和事项,将照常收取支持费用。要创建单独的服务请求,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support

文件信息

此修补程序的英文版具有下表中列出的文件属性(或更新的文件属性)。这些文件的日期和时间按协调世界时 (UTC) 列出。当您查看文件信息时,相应的时间将转换为本地时间。要了解 UTC 与本地时间之间的时差,请使用“控制面板”中“日期和时间”工具中的“时区”选项卡。
Windows XP 64 位版本
日期         时间   版本            大小       文件名         平台
----------------------------------------------------------------------
14-Jan-2005  16:44  5.1.2600.1619   1,485,312  User32.dll     IA-64
14-Jan-2005  05:01  5.1.2600.1619   5,630,080  Win32k.sys
14-Jan-2005  16:47  5.1.2600.1619     557,056  Wuser32.dll    x86
Windows XP 32 位版本
日期          时间   版本           大小        文件名     平台
--------------------------------------------------------------------
114-Jan-2005  16:47  5.1.2600.1619   574,464    User32.dll  x86 
14-Jan-2005  05:28  5.1.2600.1619   1,845,888    Win32k.sys  x86 
14-Jan-2005   05:50  5.1.2600.2597   1,836,032  Win32k.sys  x86 

替代方法

要解决休眠 (S4) 问题,请临时关闭休眠功能。为此,请按照下列步骤操作:
  1. 单击“开始”,然后单击“控制面板”。
  2. 双击“电源选项”。
  3. 单击“休眠”选项卡。
  4. 单击以清除“启用休眠”复选框,然后单击“确定”。

    注意:除本文中所述的修补程序外,没有替代方法用来解决 S3 的“通过 LAN 唤醒”问题。

状态

Microsoft 已经确认这是在“这篇文章的信息适用于:”部分中列出的 Microsoft 产品中存在的问题。

属性

文章编号: 815304 - 最后修改: 2007年9月7日 - 修订: 5.0
这篇文章中的信息适用于:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
关键字:?
kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB815304
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com