クラスタ化されたディスクのドライブ文字が突然変更される

文書翻訳 文書翻訳
文書番号: 815616 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Windows 2000 ベースのサーバー クラスタで物理ディスク リソースが断続的にオフラインになることがあります。この現象が発生すると、次の情報がクラスタ ログ ファイル (Cluster.log) に記録されます。
00000718.0000093c::2002/12/30-06:45:15.657 Physical Disk: [PnP] DriveLetterChange: F => ?
00000718.0000093c::2002/12/30-06:45:15.657 Physical Disk <Disk F:>: Mountie[0]: 1, let=?, start=7E00, len=12CAA000.
00000718.0000093c::2002/12/30-06:45:15.657 Physical Disk <Disk F:>: PokeDiskResource: Volumes not ready, error 2
00000718.0000093c::2002/12/30-06:45:15.657 Physical Disk: PnP Event GUID_IO_VOLUME_NAME_CHANGE for ? (Partition1) received.
00000718.0000093c::2002/12/30-06:45:15.673 Physical Disk: [PnP] DriveLetterChange: ? => ?
00000718.0000093c::2002/12/30-06:45:15.673 Physical Disk: PnP Event GUID_IO_VOLUME_NAME_CHANGE for ? (Partition1) received.
00000718.0000093c::2002/12/30-06:45:15.704 Physical Disk <Disk F:>: Mountie[0]: 1, let=?, start=7E00, len=12CAA000.
00000718.0000093c::2002/12/30-06:45:15.704 Physical Disk <Disk F:>: PokeDiskResource: Volumes not ready, error 2
また、イベント ビューアのシステム ログに、次のような "遅延書き込みデータの紛失" イベントが 1 つ以上表示されることがあります。
日付 : date  ソース : Ftdisk
時刻 : time  分類 : なし
種類 : エラー  イベント ID :  50
ユーザー : N/A
コンピュータ : computername
説明 :
{遅延書き込みデータの紛失} ファイル \Device\HarddiskVolumeX のためのデータを一部保存できませんでした。
データを損失しました。このエラーは、コンピュータのハードウェアまたはネットワーク接続の障害によって発生した可能性があります。
このファイルをどこか別の所に保存してください。
データ :
0000: 00040000 005e0001 00000000 80040032
0010: 00000000 00000000 00000000 00000000
0020: 00000000 00000000 c000000e

原因

この問題は、予期しない PnP イベントによって Windows 2000 サーバー クラスタの物理ディスク リソースのドライブ文字が変更され、ディスクがオフラインになったために発生する場合があります。この問題が発生すると、プログラムはそのディスクにアクセスできなくなり、アクセスを回復するためには、何らかの修正動作が必要になる場合があります。この修正動作は、問題のあるグループに含まれているプログラムによって異なり、以下の動作の 1 つまたは複数が含まれる場合があります。
  • リソースまたはグループの再起動
  • Microsoft クラスタ サービスの再起動
  • コンピュータの再起動

解決方法

Service Pack の情報

この問題を解決するには、Microsoft Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows 2000 Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/?ws=support
: Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
 日付           時刻   バージョン       サイズ  ファイル名
 -------------------------------------------------------
 25-Jun-2002 11:33 5.0.2195.5912 34,384 Classpnp.sys

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Microsoft Windows 2000 Service Pack 4 で最初に修正されました。

詳細

予期しない PnP イベントは、PnP ドライバ内の同期の問題が原因で発生します。PnP ドライバは、問題のハード ディスク パーティションのサイズをセクタで計算し、その後、バイトで再計算します。パーティションをセクタで計算してからバイトで再計算するまでの間に、ハード ディスクのパーティション サイズの照会を受けると、パーティション サイズをセクタで返しますが、バイトとして解釈されます。これにより、オペレーティング システムはハード ディスクが取り外されたものと判断し、その結果、物理ディスク リソースが失われます。イベント ID 50 のデータ部分に記載されているエントリ c000000e は 0xC000000E STATUS_NO_SUCH_DEVICE に相当し、ハード ディスクが見つからないことを示しています。

この更新プログラムでは、パーティションの計算と再計算との間の時間をなくします。パーティションのサイズは常にバイトで返されます。

Windows 2000 Datacenter Server 用の修正プログラムの入手方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
265173 Datacenter Program と Windows 2000 Datacenter Server

プロパティ

文書番号: 815616 - 最終更新日: 2006年3月24日 - リビジョン: 2.6
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 3
キーワード:?
kbbug kbfix kbwin2000presp4fix kbqfe kbenv kboswin2000fix kbwin2ksp4fix kbhotfixserver KB815616
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com