Application Cannot Resolve Some Domain Names

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Article ID: 815768 - View products that this article applies to.
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Symptoms

An application, such as Microsoft Internet Explorer, cannot resolve domain names from some Domain Name System (DNS) servers. Because of this, you may not be able to access some Web sites. For example, you may receive the following error message in Internet Explorer when you try to access a Web site:
The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings...
Cannot find server or DNS Error

Cause

This problem may occur if the DNS server is queried for a non-"A" record, and the server replies with an authoritative response that returns NXDOMAIN or NAME_ERROR (Response Code, or RCODE, 3) even though an "A" (or Internet Protocol version 4, or IPv4, host) record for the queried name exists on that DNS server. NXDOMAIN or NAME_ERROR in the response indicates that there are "no records of any type for that name." Microsoft has found that some DNS server software does not support "AAAA" (Internet Protocol version 6 or IPv6) records and incorrectly responds with NXDOMAIN even though an "A" record exists for the site.

For example, this problem may occur when a Windows client computer that is running IPv6 tries to access a Web site. The Windows client will try to resolve the host name (for example, www.example.com) on behalf of applications that support both IPv6 and IPv4. To do this, the Windows client will query for both "AAAA" records and "A" records, unless the application specifies which protocol to use. If the DNS server replies with an authoritative response that returns NXDOMAIN or NAME_ERROR, Windows will return this response to applications, such as Internet Explorer. Because of this, the application will fail to resolve the host name and will be unable to access the site. Note that Windows clients will also cache this negative response. This prevents additional queries for this name from succeeding until the client cache is cleared.

Important In this example, if the DNS server that is used by the Windows IPv6 client caches negative responses, name resolution will also fail for other client computers when they use this same caching DNS server. This issue occurs regardless of the subsequent query type and regardless of whether the other client computers are running IPv6 or IPv4 only.

Resolution

To resolve this problem, contact the administrator of the site that you are having problems with.

The DNS administrator of the site should contact the manufacturer of their DNS product for help resolving this issue. This may require an upgrade to the DNS server product or a change in the configuration of the DNS server or servers.

More information

According to section 6.2.4 of RFC 1034 (see "References"), if there are "A" records that are hosted on the DNS server, the DNS server should not return a NXDOMAIN or NAME_ERROR response when the you query for "AAAA" records (or any non-"A" record). Instead, the DNS server should return NODATA or no error (RCODE 0) and an empty answer section if it does not recognize an "AAAA" name query.

References

For additional information about the IPv6 protocol for Microsoft Windows XP and Windows Server 2003, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/network/bb530961.aspx
For additional information about DNS, visit the following Web sites:

RFC 4047 Common Misbehavior Against DNS Queries for IPv6 Addresses
http://www.ietf.org/rfc/rfc4074.txt

RFC 1034 Domain Names - Concepts and Facilities
http://www.rfc-editor.org/rfc/rfc1034.txt

RFC 2308 Negative Caching of DNS Queries (DNS NCACHE)
http://www.rfc-editor.org/rfc/rfc2308.txt

RFC 1035 Domain Names - Implementation and Specification
http://www.rfc-editor.org/rfc/rfc1035.txt
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 815768 - Last Review: November 20, 2013 - Revision: 9.0
Applies to
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Windows Server 2008 R2 Service Pack 1
  • Windows Server 2012 R2 Datacenter
  • Windows Server 2012 Datacenter
Keywords: 
kbprb KB815768

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