Nonworking time updates from Microsoft Project Web Access do not save correctly in Microsoft Project 2002

Article translations Article translations
Article ID: 815836 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you (as a project manager) try to update changes to an Enterprise Resource in a project plan from Microsoft Project Web Access (PWA), and you do not have permissions in Microsoft Project Server to Edit Enterprise Resource Data, you might receive a message from Microsoft Project Web Access that the procedure is a success. However, the changes do not save in the project plan.

CAUSE

This problem may occur if the resource that you have to update is an Enterprise Resource. This procedure requires that the user who is performing the update have permissions in Microsoft Project Server to use the Edit Enterprise Resource Data feature or the confirmation message appears, but the changes do not save. Similarly, rate, calendar and resource property changes are also affected by this behavior.

RESOLUTION

Service Pack Information

This problem is corrected in Project 2002 Service Pack 1.

To resolve this problem, obtain the latest service pack for Project 2002. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
867829 How to obtain the latest Microsoft Project 2002 service pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size       File name
   ----------------------------------------------
   19-Feb-2003  06:20  8,958,976  Project10.msp
After the hotfix is installed, the following files will have the listed attributes or later:
   
     Date         Time   Version         Size        File name
   --------------------------------------------------------------
   22-May-2002  22:37  10.0.4109.0      7,445,320  Owc10.dll        
   18-Oct-2002  03:23  10.0.2002.1017     909,824  Pj10od10.dll     
   19-Feb-2003  00:24  10.0.2003.218      254,464  Pj10tm10.dll     
   28-Jan-2003  05:08  10.0.2003.127    4,108,800  Pjoledb.dll      
   28-Jan-2003  05:08  10.0.2003.127   10,101,248  Winproj.exe 

WORKAROUND

To work around this problem, depends on how the security settings are configured for the project managers. The project managers may not have permissions to modify the Enterprise Resources in the Enterprise Resource pool. If this scenario is true, then the nonworking time change must be sent to the designated Resource Manager who has permissions to check out the corresponding resource and make the appropriate changes to that particular resource's calendar.
  1. Open the Enterprise Resource Pool, and check out the assigned resource.
  2. Process the nonworking time updates from Project Web Access (PWA) and when you receive the prompt, select and update the Checked-out Enterprise Resources file.
  3. Save the Enterprise Resource Pool, and then close the Enterprise Resource Pool.
Note For individual project plans to reflect the update to the Enterprise Resource, you must check out, save and then republish each plan.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Project 2002 Service Pack 1.

MORE INFORMATION

The fix in this article only corrects the behavior described in the Symptoms section and provides a message that alerts the user that the user does not have the permissions that they must have for the update of nonworking time to occur.

Properties

Article ID: 815836 - Last Review: September 18, 2011 - Revision: 5.0
APPLIES TO
  • Microsoft Project 2002 Professional Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbsavefile kbpermissions kbbug kbproject2002sp1fix kbfix KB815836

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com