Остановка воспроизведения созданных оборудованием файлов ASF в проигрывателе Windows Media 9

Переводы статьи Переводы статьи
Код статьи: 816044 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

Через три или четыре минуты после начала воспроизведения некоторых файлов ASF, созданных оборудованием, может появиться следующее сообщение об ошибке.
0xC00D1199 — Проигрывателю Windows Media не удается воспроизвести файл. Файл поврежден или формат данного файла не поддерживается проигрывателем.
Это сообщение также можно получить, переводя ползунок за трех- или четырехминутную отметку.

Причина

При воспроизведении файлов приложения, основанные на формате Windows Media, проверяют допустимость пакета. Формат Windows Media обрабатывает с ошибкой те случаи, когда из-за достижения максимально возможного значения числовых данных значение времени интерпретируется неверно.

Решение

Данная проблема может быть решена с помощью исправления, выпущенного корпорацией Майкрософт. Оно должно применяться только в системах, где наблюдается описанная выше проблема. Данное исправление находится на стадии дополнительного тестирования. По этой причине корпорация Майкрософт рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего обновления Windows Media, в которое будет включено решение описанной проблемы.

Чтобы получить исправление, обратитесь в службы поддержки продуктов корпорации Майкрософт. Полный список телефонов службы поддержки, а также сведения об условиях обслуживания см. на веб-узле Майкрософт по адресу:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Примечание. В отдельных случаях, если специалистом службы технической поддержки Майкрософт будет определено, что решением проблемы является специально выпущенное исправление, оплата, предусмотренная за обращение в службы технической поддержки, может быть отменена. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются на стандартных условиях.
Загрузите следующий файл с веб-узла центра загрузки Майкрософт:
Свернуть это изображениеРазвернуть это изображение
Загрузка
Загрузить пакет wm816044. Дополнительные сведения о загрузке файлов с узла технической поддержки корпорации Майкрософт см. в следующей статье базы знаний:
119591 Как загрузить файлы поддержки Microsoft из Интернета
Корпорация Майкрософт проверила этот файл на отсутствие вирусов. Корпорация Майкрософт использует последние версии антивирусного программного обеспечения на момент публикации файла для его проверки. Файл хранится на сервере с повышенной степенью защиты, что предотвращает его несанкционированное изменение.
Данное исправление содержит версии файлов, перечисленные в приведенной ниже таблице, или более поздние. Дата и время указаны в формате универсального всемирного времени (по Гринвичу). При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, откройте вкладку Часовой пояс компонента «Дата и время» панели управления.
Дата         Время  Версия      Размер     Имя файла 
---------------------------------------------------- 
04-мар-2003  15:49  9.0.0.3001  2 058 888  mvcore.dll

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в начале данной статьи.

Свойства

Код статьи: 816044 - Последний отзыв: 6 декабря 2007 г. - Revision: 2.6
Информация в данной статье относится к следующим продуктам.
  • Windows Media 9 Series Software Development Kit
  • Windows Media Format 9 Series Software Development Kit
  • Microsoft Windows Media Player 9 Series
Ключевые слова: 
kbautohotfix kbdownload kbfix KB816044

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com