Puede experimentar problemas de rendimiento de memoria en un equipo basado en Windows 2000 que tiene varios procesadores Intel Pentium 4

Seleccione idioma Seleccione idioma
Id. de artículo: 816488 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Para obtener una versión de Microsoft Windows Server 2003 de este artículo, consulte 897335.
importante Este artículo contiene información acerca de cómo modificar el registro. Compruebe que ha hecho una copia de seguridad del Registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

En esta página

Síntomas

En un equipo basado en Microsoft Windows 2000 que tiene varios procesadores Intel Pentium 4, puede experimentar los síntomas siguientes:
  • Hora de inicio lento inesperadamente.
  • Problemas de rendimiento de memoria.
  • CPU tiene un pico del proceso del sistema que se producen inmediatamente después del inicio.

Causa

Este problema puede producirse si la página restableciendo a cero el subproceso está configurada para utilizar el conjunto de instrucciones de interfaz (XMMI) de administrador de memoria extendida.

Cuando un proceso asigna memoria virtual, el Administrador de memoria de Windows borrará las páginas de memoria virtual antes de que el Administrador de memoria permite que el proceso solicitante tener acceso a las páginas. Este paso asegura que un proceso no puede tener acceso a datos en la memoria virtual que anteriormente era propiedad por otro proceso.

La página restableciendo a cero el subproceso que es responsable de limpiar utiliza páginas de memoria está configurada con uno de dos conjuntos de instrucciones al principio del proceso de inicio. De forma predeterminada, la página restableciendo a cero el subproceso es configurada para no utilizar la instrucción XMMI establecer en sistemas multiprocesador Pentium 4. Esta restricción existe debido a problemas de hardware que producir una disminución del rendimiento en muchos sistemas multiprocesador Pentium 4. En determinadas condiciones, el conjunto de instrucciones XMMI incorrectamente está seleccionado. Este problema puede ser más común en equipos virtuales solo procesador que se ejecutan en hosts multiprocesador. Una máquina virtual incorrectamente puede seleccionar el bucle puesta a cero porque la máquina virtual se detecta un único procesador durante el inicio en un host multiprocesador.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para instalar este hotfix, debe estar ejecutando Windows 2000 Service Pack 3 o Service Pack 4 de Windows 2000. (SP4) Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix reemplaza el hotfix que originalmente includedwith SP4 de Windows 2000.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
     Date         Time    Version          Size        File name 
     --------------------------------------------------------------
     10-Feb-2004  19:47   5.0.2195.6897      30,160    Mountmgr.sys 
     05-Apr-2004  20:39   5.0.2195.6921   1,700,928    Ntkrnlmp.exe 
     05-Apr-2004  20:39   5.0.2195.6921   1,700,608    Ntkrnlpa.exe 
     05-Apr-2004  20:39   5.0.2195.6921   1,722,176    Ntkrpamp.exe 
     05-Apr-2004  20:39   5.0.2195.6921   1,677,824    Ntoskrnl.exe  

Más información

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Después de aplicar este hotfix, debe agregar y configurar la entrada de registro XMMIZeroingEnable para deshabilitar la funcionalidad restableciendo a cero el XMMI. Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar
  2. Busque la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\kernel
  3. En el panel izquierdo, haga clic con el botón secundario del mouse en núcleo , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  4. Tipo XMMIZeroingEnable como nombre de entrada y, a continuación, presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en XMMIZeroingEnable y a continuación, haga clic en Modificar .
  6. Para deshabilitar restableciendo a cero el XMMI, escriba 2 en el cuadro de datos de valor y, a continuación, haga clic en Aceptar .

    Nota Para volver a habilitar restableciendo a cero el XMMI, escriba 1 en los datos de valor y, a continuación, haga clic en Aceptar .
  7. Salga del Editor del Registro.
  8. Reinicie el equipo.
Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o confiabilidad de estos productos.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Propiedades

Id. de artículo: 816488 - Última revisión: viernes, 31 de enero de 2014 - Versión: 6.7
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Palabras clave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbwin2000sp5fix kbwin2000presp5fix kboswin2000fix kbfix kbbug KB816488 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 816488

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com