Update: Message Screener verursachen-Leck in Lsass.exe

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Problembeschreibung

Sie können Berichte in Internet Security and Acceleration (ISA) Server 2000 nicht ausführen, und die folgende Ereignismeldung im Ereignisprotokoll protokolliert:

Ereignistyp: Fehler
Ereignisquelle: Microsoft ISA-Bericht-Generator-Ereignis
Kategorie: keine
Ereignis-ID: 21026
Datum: 2002-10-13
Zeit: 00:50:00
Beschreibung: Der Aktion zum Erstellen des geplanten Berichts, "Weekly Report" mit den angegebenen Anmeldeinformationen ist fehlgeschlagen. Der Fehlercode im Datenbereich der Ereigniseigenschaften zeigt die Ursache.
Daten: 0000: 0D 00 00 00

Zum Abrufen von Win32-Fehler für den Statuscode 13 (0x0d) geben Sie im Feld Daten des Ereignisses die folgende Zeile an einer Eingabeaufforderung:

net Helpmsg 13

Dieser Befehl gibt die folgende Ausgabe zurück:
Die Daten sind unzulässig
Hinweis: Dieses Problem tritt auf, nur, wenn ISA Server und der ISA Server SMTP-Nachrichtenüberwachung (Fltrsnk1.dll) auf demselben Computer installiert und ausgeführt. Um zu überprüfen, dass die Nachrichtenüberwachung installiert ist, gehen Sie in den Abschnitt "Weitere Informationen" dieses Artikels.

Ursache

Dieses Problem, da der Nachrichtenüberwachung im Inetinfo-Prozess ausgeführt wird und ein Handle-Leck in der LSAOpenPolicy -Handle-Tabelle verursacht. Die Handletabelle LSAOpenPolicy wird von dem Lsass.exe-Prozess gehostet.

Nach ungefähr 8 bis 14 Tage ist die maximale Anzahl von verfügbaren Handles erreicht. Wenn dies eintritt, schlägt der Berichterstellung (Repgen.exe)-Vorgang fehl, wenn LSAOpenPolicy aufgerufen. Der Berichterstellung-Prozess fehlschlägt, da den gleichen Parameter als der Nachrichtenüberwachung verwendet werden, rufen Sie LSAOpenPolicy . Andere Prozesse oder Komponenten, die den gleichen Parameter wie der Nachrichtenüberwachung, verwenden LSAOpenPolicy aufrufen werden auch fehlschlagen.

Abhilfe

Um dieses Problem zu umgehen, beenden und starten Sie Inetinfo-Prozess neu. Die Handles, die der Inetinfo-Prozess reserviert sind sind jetzt verfügbar, um die Handletabelle in Lsass.exe.

Lösung

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.Die englische Version dieses Updates weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time () angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
Date         Time   Version        Size    File name
--------------------------------------------------
23-Mar-2003  18:32  3.0.1200.258   60,688  Fltrsnk1.dll

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Standardmäßig der Nachrichtenüberwachung ist nicht installiert während der ISA Server Setup. Gehen Sie folgendermaßen vor um überprüfen, ob während der Installation der Nachrichtenüberwachung installiert wurde,
  1. Klicken Sie auf Start , zeigen Sie auf Einstellungen und klicken Sie auf Systemsteuerung .
  2. Doppelklicken Sie auf Software .
  3. Klicken Sie auf Microsoft Internet Security and Acceleration Server , und klicken Sie dann auf Ändern .
  4. Klicken Sie auf Benutzerdefinierte Installation , und klicken Sie auf Add-in Dienste .

    Wenn die Message Screener das Kontrollkästchen aktiviert ist, wird installiert.
Um überprüfen, ob der Nachrichtenüberwachung im Inetinfo-Prozess ausgeführt wird, führen Sie den folgenden Befehl an einer Eingabeaufforderung:

Tlist-m fltrsnk1.dll

Die Ausgabe Listet die aktiven Prozesse. Wenn der Inetinfo-Prozess aufgeführt ist, wird der Nachrichtenüberwachung im Inetinfo-Prozess ausgeführt.

Die tlist.exe ist Teil von den. Um diese Tools zu installieren, besuchen Sie die folgende Website: http://www.microsoft.com/whdc/devtools/debugging/default.mspx

Eigenschaften

Artikel-ID: 816621 - Geändert am: Sonntag, 2. Februar 2014 - Version: 2.5
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Internet Security and Acceleration Server 2000 Standard Edition
  • Microsoft Internet Security and Acceleration Server 2000 Service Pack 1
Keywords: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbisaserv2000presp2fix kbbug kbfix KB816621 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 816621
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