CORRECÇÃO: Message Screener vazamento de identificador causa em Lsass.exe

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Sintomas

Não é possível executar relatórios no Internet Security and Acceleration (ISA) Server 2000 e a seguinte mensagem de identificação de evento é registrada no log de eventos:

Tipo de evento: erro
Origem do evento: Microsoft ISA relatório gerador de evento
Categoria: nenhum
IDENTIFICAÇÃO de evento: 21026
Data: 2002-10-13
Tempo: 00:50:00
Descrição: A ação para criar o relatório agendado, "Relatório semanal," com as credenciais especificadas, falha. O código de erro na área dados das propriedades de evento indica a causa.
Dados: 0000: 0D 00 00 00

Para obter o erro do Win32 para o código de status 13 (0x0d) no campo Data do evento, digite a seguinte linha em um prompt de comando:

net helpmsg 13

Este comando retorna a seguinte saída:
Os dados são inválidos
Observação Esse problema ocorre apenas se o ISA Server e o ISA Server SMTP Message Screener (Fltrsnk1.dll) estão instalados e sendo executados no mesmo computador. Para verificar se o message screener é instalado, execute as etapas na seção "Mais informações" deste artigo.

Causa

Esse problema ocorre porque o message screener está sendo executado no processo Inetinfo e está causando um vazamento de identificador na tabela de identificador LSAOpenPolicy . A tabela de identificadores LSAOpenPolicy é hospedada pelo processo Lsass.exe.

Após cerca de 8 a 14 dias, o número máximo de identificadores disponíveis é atingido. Depois disso, o processo de gerador de relatório (Repgen.exe) falha quando chama LSAOpenPolicy . O processo de gerador de relatório falha porque ele usa o mesmo parâmetro como o message screener para chamar LSAOpenPolicy . Outros processos ou componentes que usam o mesmo parâmetro como o message screener para chamar LSAOpenPolicy também falharem.

Como Contornar

Para contornar esse problema, desligue e reinicie o processo Inetinfo. As alças que são mantidas pelo processo do Inetinfo agora estão disponíveis para a tabela de identificador no Lsass.exe.

Resolução

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.A versão em inglês dessa correção apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
Date         Time   Version        Size    File name
--------------------------------------------------
23-Mar-2003  18:32  3.0.1200.258   60,688  Fltrsnk1.dll

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo.

Mais Informações

Por padrão, o message screener não é instalado durante ISA instalação Server. Para verificar se o message screener foi instalado durante a instalação, execute estas etapas:
  1. Clique em Iniciar , aponte para configurações e, em seguida, clique em Painel de controle .
  2. Clique duas vezes em Adicionar ou remover programas .
  3. Clique em Microsoft Internet Security and Acceleration Server e em seguida, clique em Alterar .
  4. Clique em Instalação personalizada e, em seguida, clique em Add-in Serviços .

    Se o Message Screener caixa de seleção estiver marcada, ele está instalado.
Para verificar se o message screener estiver sendo executado no processo Inetinfo, execute o seguinte comando em um prompt de comando:

tlist -m fltrsnk1.dll

A saída lista processos ativos. Se o processo Inetinfo estiver listado, o message screener está executando no processo Inetinfo.

O tlist.exe é parte do Microsoft Debugging Tools. Para instalar essas ferramentas, visite o seguinte site: http://www.microsoft.com/whdc/devtools/debugging/default.mspx

Propriedades

ID do artigo: 816621 - Última revisão: sábado, 26 de outubro de 2013 - Revisão: 2.5
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Security and Acceleration (ISA) Server 2000 Standard Edition
  • Microsoft Internet Security and Acceleration Server 2000 Service Pack 1
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbisaserv2000presp2fix kbbug kbfix KB816621 KbMtpt
Tradução automática
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