TCP/IP port printing may be slow in Windows 2000

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Article ID: 816627 - View products that this article applies to.
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SYMPTOMS

Printing to a TCP/IP printer port may be slow if you are using the LPR Byte Counting feature or if the advanced TCP/IP options are disabled on the printer. A network trace may show that for every three packets that are sent, there is a "Delayed Ack" before the print device sends an acknowledgement. If the "Delayed Ack" value is set to 0.2 seconds, a 10-MB print job may take approximately 10 minutes.

CAUSE

This problem occurs because the buffer size for reading spooled files is only 4 KB for the Windows print processor and for TCP/IP Port Monitor. This causes two packets with 1,460 KB of data followed by another packet with 1,176 KB of data with the TCP Push bit flag enabled.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Microsoft Windows 2000 Service Pack 3 (SP3) or a later version of Windows 2000 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date        Time  Version       Size    File name
   ----------------------------------------------------
   11-Jun-2003 19:03 5.0.2195.6749 252,176 Localspl.dll
   11-Jun-2003 19:03 5.0.2195.6741  80,656 Spoolss.dll
   11-Jun-2003 19:03 5.0.2195.6737  42,256 Tcpmon.dll
   11-Jun-2003 19:03 5.0.2195.6681  97,040 Win32spl.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The Windows print processor and the LPR Read buffers have been increased to 64 kilobytes (KB) to improve performance. This increase leads to fewer delays. If the print device correctly processes the Push bit on the last packet of the buffer, the delay does not occur.

For more information about TCP/IP behavior, search the Microsoft Web site for "Nagle algorithm" or for "RFC1122."

For more information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server product

Properties

Article ID: 816627 - Last Review: February 21, 2007 - Revision: 4.9
APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbfix kbbug KB816627

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