Article ID: 816744 - Last Review: December 25, 2006 - Revision: 1.3

Custom Connection Manager Dial-up Dialer Will Not Work After Custom VPN Dialer Is Used

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SYMPTOMS

When you use Connection Manager Administration Kit (CMAK) to create a custom dial-up Connection Manager dialer and a custom virtual private network (VPN) Connection Manager dialer, and you use both dialers on one computer, the dial-up Connection Manager will not work after the VPN Connection Manager dialer has been used.

CAUSE

This behavior may occur if you try to use the same logon credentials for both dialers. If you set the UseSameUserName flag in the .cms file to 1 to automate the connection of each dialer, the dial-up Connection Manager dialer does not work after you use the VPN Connection Manager dialer because different credentials are saved after the VPN connection has completed.

The VPN connection uses Extensible Authentication Protocol (EAP) credentials (SecureID), and the dial-up connection uses regular password-based credentials. As a result, the same information is not retained after a VPN connection.

The dial-up connection requires the domain information in the Log on to box on the logon screen, but the VPN connection does not use the domain information. Because the UseSameUserName flag is set to 1 in Connection Manager, the VPN credentials are saved in the connectoid after the VPN connection is made. As a result, the domain information is not available the next time a dial-up connection is made.

WORKAROUND

To work around this behavior, change the logon screen interface so that information that is entered in the user name field is entered in the format of domain\username. To change the interface, edit the Your_Dialer.cms file for each of your dialers. To edit the .cms file, follow these steps:
  1. Right-click My Computer, and then click Explore.
  2. Expand Local Disk (C:), expand Program Files, expand CMAK, expand Profiles, and then expand Your_Dialer_Name_Folder.
  3. Right-click the Your_Dialer_Name.cms file, and then click Edit.
  4. Find HideUserName=, and after the equals sign, delete the existing value, and then type 1 (that is, HideUserName=1).
  5. Find HideDomain=, and after the equals sign, delete the existing value, and then type 1 (that is, HideDomain=1).
  6. Find HidePassword=, and after the equals sign, delete the existing value, and then type 1 (that is, HidePassword=1).
  7. Find UseSameUserName=, and after the equals sign, delete the existing value, and then type 0 (that is, UseSameUserName=0).
  8. Click File, click Save, click File, and then click Exit.
  9. Repeat these steps for your dial-up dialer and for your VPN dialer.

APPLIES TO
  • Microsoft Windows XP Professional
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