Multiple memory leaks in Remote Registry Service

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Article ID: 816998 - View products that this article applies to.
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SYMPTOMS

When you run the Remote Registry Service, you may notice that a significant memory leak occurs over time.

CAUSE

When a program loads and unloads performance counter DLLs from memory, a significant memory leak may occur in the Remote Registry Service.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to obtain the latest Windows 2000 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   ---------------------------------------------------------
   10-Feb-2003  16:57  5.0.2195.6654     125,712  Icaapi.dll       
   08-Apr-2003  14:33  5.0.2195.6701     122,640  Iisrtl.dll       
   07-Oct-2002  22:29  5.0.2195.6609      93,456  Licmgr.exe       
   08-Apr-2003  03:09  5.0.2195.6701     330,512  Lserver.exe      
   10-Feb-2003  16:57  5.0.2195.6659      26,384  Mstlsapi.dll     
   08-Apr-2003  14:33  5.0.2195.6701      42,256  Perfctrs.dll     
   29-Mar-2003  19:30  5.0.2195.6697     100,248  Rdpwsx.dll       
   27-Mar-2003  20:40  5.0.2195.6696     142,608  Termsrv.exe      
   26-Mar-2003  21:26  5.0.2195.6672      23,312  Tls236.dll       
   08-Apr-2003  14:33  5.0.2195.6701      26,384  Utildll.dll      
   08-Apr-2003  14:33  5.0.2195.6701      39,184  Winsta.dll  
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173 The Datacenter program and Windows 2000 Datacenter Server product

Properties

Article ID: 816998 - Last Review: February 27, 2014 - Revision: 1.8
APPLIES TO
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Datacenter Server SP2
  • Microsoft Windows 2000 Service Pack 3
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbsysadmin kbwin2ksp4fix kbwin2000presp4fix kbfix kbbug KB816998

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