При загрузке компьютера не появляется экран входа в систему

Переводы статьи Переводы статьи
Код статьи: 817142 - Vizualiza?i produsele pentru care se aplic? acest articol.
Внимание!: Решение проблемы связано с внесением изменений в системный реестр. Перед внесением изменений рекомендуется создать архивную копию системного реестра и изучить процедуру его восстановления. Дополнительные сведения об архивировании, восстановлении и изменении реестра см. в следующей статье базы знаний Майкрософт:
256986 Описание реестра Microsoft Windows
Развернуть все | Свернуть все

В этой статье

Проблема

При запуске компьютера не отображается экран входа в систему Приветствие. При этом может появится одно из следующих сообщений об ошибке:
  • Недавно установленная программа отключила экран приветствия и быстрое переключение пользователей. Чтобы восстановить эти параметры, необходимо удалить данную программу.

    Следующее имя файла может помочь идентифицировать программу, выполнившую это изменение:

    C:\Windows\System32\Awgina.dll.
  • Ошибка пользовательского интерфейса:

    Невозможно загрузить DLL C:\Windows\System32\Awgina.dll пользовательского интерфейса входа. Обратитесь к системному администратору или восстановите исходную библиотеку DLL.
С этой проблемой можно столкнуться после включения в Windows XP быстрого переключения пользователей.

Причина

Описанная проблема может возникнуть после установки приложения Symantec pcAnywhere, когда фильтр механизма Graphical Identification and Authorization (GINA), Awgina.dll, поставляемый с pcAnywhere, блокирует вход в систему.

При установке приложение pcAnywhere заменяет используемый по умолчанию файл Windows GINA, Msgina.dll своим файлом Awgina.dll. Некоторые версии файла Awgina.dll приводят к появлению данной проблемы.

Решение

Для устранения проблемы в зависимости от ситуации воспользуйтесь одним из перечисленных ниже способов.

Способ 1. Отключение фильтра PcAnywhere GINA

Перезагрузите компьютер в безопасном режиме и отключите фильтр pcAnywhere GINA. Для этого выполните следующие действия.
  1. Перезагрузите компьютер в безопасном режиме.
    1. Перезагрузите компьютер.
    2. При появлении сообщения «Выберите операционную систему для запуска» нажмите клавишу F8.
    3. С помощью клавиш со стрелками выберите в Меню дополнительных вариантов загрузки Windows пункт Безопасный режим и нажмите клавишу ВВОД.
    4. Если на компьютере установлено несколько операционных систем, выберите из появившегося списка Microsoft Windows XP и нажмите клавишу ВВОД.
  2. Удалите параметр реестра
    GinaDLL
    . Для этого выполните следующие действия.Внимание! Неправильное использование редактора реестра может привести к возникновению серьезных неполадок, требующих переустановки операционной системы. Корпорация Майкрософт не несет ответственности за неправильное использование редактора реестра. При изменении реестра полагайтесь на свой опыт и знания.
    1. Нажмите кнопку Пуск и выберите пункт Выполнить.
    2. В поле Открыть введите команду regedit и нажмите кнопку ОК.
    3. Откройте следующий раздел реестра:
      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\WinLogon
    4. На правой панели щелкните правой кнопкой мыши параметр GinaDLL и выберите команду Удалить.
    5. Нажмите кнопку Да, чтобы подтвердить удаление.
    6. В меню Файл выберите команду Выход.
  3. Перезагрузите компьютер.

Способ 2. Удаление приложения pcAnywhere

Удалите приложение pcAnywhere. Дополнительные сведения о том, как удалить приложение pcAnywhere, см. в документации приложения или на веб-узле Symantec Corporation:
http://www.symantec.com/techsupp/

Дополнительная информация

Дополнительные сведения об этой проблеме в Windows Server 2000 см. в следующей статье базы знаний Майкрософт:
306948 Установка приложения pcAnywhere 9.0 в операционной системе Windows 2000 приводит к непрерывному циклу перезагрузки системы
Контактные данные независимых производителей предоставлены в данной статье с целью помочь пользователям в получении необходимой технической поддержки. Данная информация может быть изменена без предварительного уведомления. Корпорация Майкрософт не дает никаких явных или подразумеваемых гарантий относительно верности приведенных контактных данных независимых производителей. Упомянутые в данной статье сторонние продукты производятся компаниями, независимыми от корпорации Майкрософт. Корпорация Майкрософт не дает никаких явных или подразумеваемых гарантий относительно корректной работы или надежности таких продуктов.

Свойства

Код статьи: 817142 - Последний отзыв: 16 мая 2005 г. - Revision: 1.0
Информация в данной статье применима к:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Ключевые слова: 
kbprb KB817142

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com