Help and Support

Windows Update Web サイトへの接続時、メッセージ "ご利用いただき、ありがとうございます" が表示される

文書番号:817144
最終更新日:2007年12月5日
リビジョン:7.5
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 (http://support.microsoft.com/kb/256986/) Microsoft Windows レジストリの説明
目次

現象

Windows Update Web サイト (http://windowsupdate.microsoft.com (http://windowsupdate.microsoft.com)) に接続しようとすると、以下のようなメッセージを表示する Web ページに予想外にリダイレクトされることがあります。
Windows Update をご利用いただき、ありがとうございます。

Windows Update は、お使いのコンピュータを最大限に活用できるようにする Microsoft Windows のオンライン拡張機能です。...

先頭へ戻る

原因

この現象は、以下のいずれかの条件に該当する場合に発生することがあります。
? Windows 98、Windows 98 Second Edition、Windows Millennium Edition、Windows NT 4.0、Windows 2000、Windows XP、または Windows Server 2003 の製品版 (ベータ版以外) を実行していないか、Windows 2000 Datacenter Server を実行している。
? Microsoft Internet Explorer 5 以降の製品版を実行していない (Internet Explorer のベータ版を実行している場合、Internet Explorer を実行していない場合など)。
? サポート対象の Windows オペレーティング システムで Internet Explorer 5 以降の製品版が実行されていないと、Windows Update で誤って検出された。この現象は、ファイアウォールまたはプロキシ経由でインターネットにアクセスしているために、Windows Update Web サイトが Internet Explorer の適切な HTTP user-agent 要求ヘッダー ("HTTP_USER_AGENT") を受信できない場合に発生することがあります。Windows Update は navigator.userAgent プロパティが返すオペレーティング システム情報を使用して、サポート対象のオペレーティング システムが実行されているかどうかを判断します。ファイアウォールまたはプロキシ サーバーの中には、不適切または解釈が困難な user-agent 情報を送信するものがあります。

先頭へ戻る

解決方法

Windows Update を使用するには、Windows 98、Windows 98 Second Edition、Windows Millennium Edition、Windows NT 4.0、Windows 2000 (Datacenter Server を除く)、Windows XP、または Windows Server 2003 ベースのコンピュータで Internet Explorer 5 以降の製品版を実行している必要があります。この問題を解決するには、以下の中から適切な方法を使用します。

先頭へ戻る

方法 1 : Windows または Internet Explorer をアップグレードする

Windows 98、Windows 98 Second Edition、Windows Millennium Edition、Windows NT 4.0、Windows 2000 (Datacenter Server を除く)、Windows XP、または Windows Server 2003 の製品版を実行していない場合、Internet Explorer のベータ版を実行している場合、または Internet Explorer 5 より前のバージョンを実行している場合は、Windows と Internet Explorer を最新の製品版にアップグレードします。 使用している Internet Explorer のバージョンを確認する方法およびアップグレードする方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
164539 (http://support.microsoft.com/kb/164539/) インストールされている Internet Explorer のバージョンを確認する方法
: Windows Update では、現在 Windows 2000 Datacenter Server の更新プログラムをサポートしていません。サービス プロバイダに問い合わせて、Windows 2000 Datacenter Server の更新プログラムを入手してください。

先頭へ戻る

方法 2 : Internet Explorer 5 以降または Microsoft ダウンロード センターを使用する

マイクロソフト以外のブラウザを使用している場合は、そのブラウザの代わりに Internet Explorer 5 以降を使用して Windows Update サイトにアクセスするか、マイクロソフト以外のブラウザを使用して、以下の Microsoft ダウンロード センターから更新プログラムをダウンロードします。
http://www.microsoft.com/downloads/search.aspx?displaylang=ja (http://www.microsoft.com/downloads/search.aspx?displaylang=ja)

先頭へ戻る

方法 3 : Windows Update が Internet Explorer の User-Agent 要求ヘッダーを受信できるようにファイアウォールまたはプロキシを構成する

使用しているファイアウォールまたはプロキシを構成して、Internet Explorer から送信される HTTP user-agent 要求ヘッダーを Windows Update が受信できるようにします。この方法については、ネットワーク管理者またはシステム管理者に問い合わせるか、プロキシやファイアウォールに付属するマニュアルを参照してください。 ファイアウォールまたはプロキシの製造元への問い合わせ方法を参照するには、以下のうち該当する「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
65416 (http://support.microsoft.com/kb/65416/) ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (A 〜 K)

60781 (http://support.microsoft.com/kb/60781/) ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (L 〜 P)

60782 (http://support.microsoft.com/kb/60782/) ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (Q 〜 Z)

先頭へ戻る

方法 4 : レジストリを変更する

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。

以下のレジストリ キーをバックアップしてから削除します。
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent\Post Platform
レジストリ キーをバックアップしてから削除するには、次の手順を実行します。
1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
2. [名前] ボックスで regedit と入力し、[OK] をクリックします。
3. 次のレジストリ キーを見つけてクリックします。
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent\Post Platform
4. [ファイル] メニューの [エクスポート] (または [レジストリ] メニューの [レジストリ ファイルの書き出し]) をクリックします。
5. [ファイル名] ボックスに Post Platform と入力し、[保存] をクリックします。
6. [編集] メニューの [削除] をクリックします。
7. 削除を確認するメッセージが表示されたら [はい] をクリックします。
8. レジストリ エディタを終了します。
9. この方法で問題が解決しない場合は、手順 5. で保存した Post Platform.reg ファイルをダブルクリックして、このキーをレジストリにインポートして (読み込んで) 戻します。

先頭へ戻る

詳細

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

先頭へ戻る


この資料は以下の製品について記述したものです。
?Microsoft Windows Update?を以下の環境でお使いの場合
??Microsoft Windows 95
??Microsoft Windows 98 Standard Edition
??Microsoft Windows 98 Second Edition
??Microsoft Windows Millennium Edition
??Microsoft Windows XP Professional
??Microsoft Windows 2000 Standard Edition
??Microsoft Windows NT 4.0
??Microsoft Windows Server 2003, Standard Edition (32-bit x86)

先頭へ戻る

キーワード:?
kbbug kbprb KB817144

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Related Support Centers

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.