Roaming Profiles Are Not Unloaded on a Computer That Is Running Terminal Services

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Article ID: 817171 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
For an Internet Explorer 5.5 version of this article, see 294268.
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SYMPTOMS

After you install Internet Explorer version 6 or version 6 Service Pack 1 (SP1) on a Windows 2000-based computer that is running Terminal Services, if the "Important URLs & Favorites and Links" Windows 2000 Group Policy is enabled, Index.dat files may not be deleted on the server when a user logs off from a Windows 2000 Terminal Services client. This problem may occur even though the "Delete cached roaming profiles" group policy is enabled. This problem does not occur in Microsoft Internet Explorer versions 5.0 and 5.01 or if the "Important URLs & Favorites and Links" Windows 2000 Group Policy is not enabled.

CAUSE

Cached profile folders are created but not completely deleted because three Index.dat files cannot be deleted in three different subfolders. Therefore, every time a user logs on and off, new folders are created on the computer that is running Terminal Services in the user_name, user_name.000, user_name.001 format. A new folder is created for each user. These folders quickly fill the hard disk of the computer that is running Terminal Services.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   -----------------------------------------------------------
   07-Apr-2003  23:08  6.0.2800.1186   1,026,048  Browseui.dll
   07-Apr-2003  23:10  16.0.2800.1186    294,912  Iedkcs32.dll
				
Note The hotfix installer name for this issue is Q817171.EXE.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Properties

Article ID: 817171 - Last Review: February 27, 2014 - Revision: 2.9
APPLIES TO
  • Microsoft Internet Explorer 6.0, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows 2000
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbie600sp2fix kbie600presp2fix kbfix kbbug KB817171

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