Article ID: 817194 - Last Review: July 17, 2006 - Revision: 3.5

"Event ID: 7000" Error Message When ASCTRM Service Does Not Start

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SYMPTOMS

On a computer that is running Windows NT 4.0, Windows 2000, or Windows XP, when you install or remove RealNetworks RealPlayer 8, or when you install or remove a program that installs RealPlayer 8 (for example, Netscape Navigator), the following event ID message is logged in the event log:

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7000
Date: DD.MM.YYYY
Time: HH:MM:SS
User: N/A
Computer: computer_name
Description: The ASCTRM service failed to start due to the following error:
The specified driver is invalid.

For more information, visit Help and Support Services at
http://search.support.microsoft.com/search/?adv=1 (http://search.support.microsoft.com/search/?adv=1) .

CAUSE

This problem occurs if you try to install or remove RealPlayer 8, but the process fails. If the %systemroot%\System32\Drivers\Asctrm.sys driver file is removed, but the corresponding registry keys are not removed, the system tries to start the driver and does not find it. You then experience the problem that is described in the "Symptoms" section of this article.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
To resolve the problem, do one of the following:
  • Reinstall RealPlayer 8 (and then remove it if you want to).
  • Manually remove the registry key that associated with Asctrm.sys. To do so:
    1. Click Start, and then click Run.
    2. In the Run dialog box, type regedit, and then click OK.
    3. Locate, and then click the following key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASCTRM
    4. On the File menu, click Export.
    5. In the File name box, type ASCTRM Backup, and then click Save.
    6. On the Edit menu, click Delete, and then click Yes to confirm the deletion.
    7. On the File menu, click Exit, and then restart the computer.

MORE INFORMATION

For information about your hardware manufacturer, visit the following Web site:
http://support.microsoft.com/gp/vendors/en-us (http://support.microsoft.com/gp/vendors/en-us)
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

REFERENCES

For additional information about Event ID: 7000, click the following article number to view the article in the Microsoft Knowledge Base:
314357  (http://support.microsoft.com/kb/314357/EN-US/ ) "Event ID: 7000" or "Event ID: 7013" Error Message When You Attempt to Start a Service
For additional information about how to edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/EN-US/ ) HOW TO: Back Up, Edit, and Restore the Registry in Windows XP

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT 4.0
Keywords: 
kbregistry kbevent kbprb kberrmsg KB817194
 

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