You May Not See All Counters in a CSV-Formatted Performance Log

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Article ID: 817416 - View products that this article applies to.
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SYMPTOMS

When you collect the Performance Monitor log in a comma-separated value (CSV) file on a Windows 2000-based computer, you may notice that not all the counters are visible. For example, the Pages/sec counter or the Available Bytes counter under the Memory counter performance object may not be visible. This applies to all the counter performance objects that do not require instances, including the Memory object and the TCP object, for example.

CAUSE

This issue occurs when you save the performance log file in the CSV file format.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time     Version         Size      File name
---------------------------------------------------------
24-Apr-2003  22:22   5.0.2195.6741    151,824   Pdh.dll

WORKAROUND

To work around this issue, save your log files in the Windows Binary Performance Log (BLG) file format.

Note In Performance Monitor, the BLG option appears as just Binary File.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New Naming Schema for Microsoft Windows Hotfix Packages

Properties

Article ID: 817416 - Last Review: October 26, 2013 - Revision: 2.5
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB817416

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