ID Artikel: 817442 - Kajian Terakhir: 04 Oktober 2011 - Revisi: 2.0

0-Byte file dapat kembali ketika kompresi diaktifkan pada server yang menjalankan IIS

Tips SistemThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Perbesar semua | Perkecil semua

GEJALA

Ketika kompresi diaktifkan pada server berjalan Internet Information Services (IIS), dan permintaan HTTP dilayani dari IIS kompresi direktori, file 0-byte mungkin dikembalikan daripada berkas yang diharapkan.

Catatan Anda mungkin hanya melihat gejala ini jika statis HTTP kompresi diaktifkan.

PENYEBAB

Perangkat lunak antivirus yang berjalan di IIS server pemindaian IIS kompresi direktori.

PEMECAHAN MASALAH

Mengecualikan IIS kompresi direktori dari perangkat lunak antivirus memindai daftar. Langkah-langkah untuk melakukan hal ini dapat bervariasi berdasarkan perangkat lunak antivirus yang Anda gunakan. Microsoft menyarankan Anda untuk menghubungi pabrik perangkat lunak antivirus untuk informasi tentang cara untuk mengecualikan direktori dari pemindaian.

INFORMASI LEBIH LANJUT

Standar kompresi direktori di IIS 6.0 %systemroot%\IIS sementara file-file terkompresi. Direktori ini mungkin berubah ke lokasi lain. Dalam IIS 7.0, lokasi default cache file terkompress adalah % SystemDrive %\inetpub\temp\IIS sementara file-file terkompresi.

Untuk memverifikasi kompresi direktori:
  1. Klik Mulai, arahkan ke Program, Arahkan ke Alat administratif, lalu klik Manajer informasi Internet Services (IIS).
  2. Dalam IIS Manager, klik kanan Situs web folder, dan kemudian klik Properti.
  3. Klik Layanan tab.
  4. Di bawah HTTP kompresi, pastikan Kompres file statis dipilih, dan kemudian cari path ke direktori sementara.

Berlaku bagi:
  • Microsoft Internet Information Services 6.0
  • Microsoft Internet Information Services 7.0
Kata kunci: 
kbmt KB817442 KbMtid
Penerjemahan MesinPenerjemahan Mesin
PENTING: Artikel ini diterjemahkan menggunakan perangkat lunak mesin penerjemah Microsoft dan bukan oleh seorang penerjemah. Microsoft menawarkan artikel yang diterjemahkan oleh seorang penerjemah maupun artikel yang diterjemahkan menggunakan mesin sehingga Anda akan memiliki akses ke seluruh artikel baru yang diterbitkan di Pangkalan Pengetahuan (Knowledge Base) dalam bahasa yang Anda gunakan. Namun, artikel yang diterjemahkan menggunakan mesin tidak selalu sempurna. Artikel tersebut mungkin memiliki kesalahan kosa kata, sintaksis, atau tata bahasa, hampir sama seperti orang asing yang berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab terhadap akurasi, kesalahan atau kerusakan yang disebabkan karena kesalahan penerjemahan konten atau penggunaannya oleh para pelanggan. Microsoft juga sering memperbarui perangkat lunak mesin penerjemah.
Klik disini untuk melihat versi Inggris dari artikel ini:817442  (http://support.microsoft.com/kb/817442/en-us/ )