Los discos IDE ATA y ATAPI usan el modo PIO después de producen varios tiempo de espera o errores de CRC

Seleccione idioma Seleccione idioma
Id. de artículo: 817472 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Después de suspender y reanudar el equipo varias veces, puede reducirse el rendimiento del disco duro. Si utiliza el Administrador de dispositivos para ver las propiedades de la canal IDE al que la unidad está conectada, la ficha Configuración avanzada puede mostrar que el modo de transferencia actual de la unidad es "Modo PIO".

Causa

Después de que el controlador del puerto IDE/ATAPI de Windows (Atapi.sys) recibe un total acumulado de tiempo de espera de seis o comprobación de redundancia cíclica comprobar errores (CRC), el controlador reduce la velocidad de las comunicaciones (el modo de transferencia) desde el modo de acceso directo a memoria (DMA) más alto para reducir los modos DMA en los pasos. Si el controlador continúa recibiendo errores de CRC o de tiempo de espera, el controlador finalmente reduce el modo de transferencia para el más lento (modo PIO).

Solución

Windows Server 2003

Información de la revisión

Hay una característica compatible que modifica el comportamiento predeterminado del producto de Microsoft. Sin embargo, esta característica está diseñada para modificar sólo el comportamiento descrito en este artículo. Esta característica sólo se aplican a los sistemas que la requieran. Esta característica podría ser sometida a comprobaciones adicionales. Por lo tanto, si el sistema no se ve muy afectado por la falta de esta característica, le recomendamos que espere a la próxima actualización de software que contiene esta función.

Si la función está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio de atención al cliente y soporte técnico para obtener la función.

Nota Si se producen problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las cuestiones y problemas que no guarden relación con esta característica específica. Para obtener una lista completa de los números de teléfono de soporte técnico y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la función está disponible. Si no ve su idioma, es porque la característica no está disponible para ese idioma.
Requisitos previos
Requerida ningún service pack.
Requisito de reinicio
Debe reiniciar el equipo después de aplicar esta revisión.
Información de sustitución de la revisión
Este hotfix no sustituye a ninguna otra revisión.
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Cuando vea la información de archivo, se convierte en hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora en el Panel de Control.
Nota Después de aplicar esta revisión, debe modificar el registro como se describe en la sección "Más información" de este artículo para cambiar este comportamiento. Si no se modifica el registro, el hotfix no cambia el comportamiento.

Windows XP

Información del Service pack

Para resolver este problema, obtenga el service pack más reciente para Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389 Cómo obtener el service pack más reciente para Windows XP

Información de la revisión

Hay una característica compatible que modifica el comportamiento predeterminado del producto de Microsoft. Sin embargo, esta característica está diseñada para modificar sólo el comportamiento descrito en este artículo. Esta característica sólo se aplican a los sistemas que la requieran. Esta característica podría ser sometida a comprobaciones adicionales. Por lo tanto, si el sistema no se ve muy afectado por la falta de esta característica, le recomendamos que espere a la próxima actualización de software que contiene esta función.

Si la función está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio de atención al cliente y soporte técnico para obtener la función.

Nota Si se producen problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las cuestiones y problemas que no guarden relación con esta característica específica. Para obtener una lista completa de los números de teléfono de soporte técnico y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la función está disponible. Si no ve su idioma, es porque la característica no está disponible para ese idioma.
Requisitos previos
Service Pack 1 de Windows XP
Requisito de reinicio
Debe reiniciar el equipo después de aplicar esta revisión.
Información de sustitución de la revisión
Esta revisión sustituye a las revisiones 331958 y 331895.
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Cuando vea la información de archivo, se convierte en hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora en el Panel de Control.
Nota Después de aplicar esta revisión, debe modificar el registro como se describe en la sección "Más información" de este artículo para cambiar este comportamiento. Si no se modifica el registro, el hotfix no cambia el comportamiento.

Windows 2000:

Hay un hotfix soportado disponible de Microsoft. Sin embargo, esta revisión se diseñó únicamente para corregir el problema descrito en este artículo. Aplicar esta revisión sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de la revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, enviar una solicitud de servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de soporte técnico y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Windows 2000 Service Pack 2
Requisito de reinicio
Debe reiniciar el equipo después de aplicar esta revisión.
Información de sustitución de la revisión
Esta revisión sustituye a las revisiones 813908, 323153, 314695, 305176, 305098, 304912, 304572, y 298505.
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Cuando vea la información de archivo, se convierte en hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora en el Panel de Control.
Nota Después de aplicar esta revisión, debe modificar el registro como se describe en la sección "Más información" de este artículo para cambiar este comportamiento. Si no se modifica el registro, el hotfix no cambia el comportamiento.

Solución

Para volver a habilitar el modo de transferencia típico, o más rápido, de un dispositivo afectado:
  1. Haga doble clic en Herramientas administrativasy, a continuación, haga clic en Administración de equipos.
  2. Haga clic en Herramientas del sistemay, a continuación, haga clic en Administrador de dispositivos.
  3. Expanda el nodo Controladores IDE ATA/ATAPI .
  4. Haga doble clic en el controlador para el que desea restaurar el modo de transferencia típico DMA.
  5. Haga clic en la ficha controlador .
  6. Haga clic en desinstalar.
  7. Cuando el proceso finalice, reinicie el equipo. Cuando Windows se reinicia, se vuelven a numerar la controladora de disco duro y el modo de transferencia se restablece al valor predeterminado para cada dispositivo que esté conectado a la controladora.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Windows XP

Este problema se corrigió primero en Microsoft Windows XP Service Pack 2.

Más información

La revisión que se describe en este artículo realiza los cambios siguientes:
  • En Windows 2000 a veces se emiten solicitudes de sólo lectura a discos ATA con un valor de tiempo de espera de 4 segundos. Esto ocurre cuando el equipo se reactive. Esto puede provocar un tiempo de espera del disco porque las unidades suelen tardar más de 4 segundos en Girar. Este valor de tiempo de espera se cambió a 10 segundos.

    En Windows XP y Windows Server 2003, este valor de tiempo de espera siempre es 10 segundos.
  • Una directiva alternativa, menos dura se implementa para reducir el modo de transferencia (de los modos DMA más lentos, rápido y, finalmente, al modo PIO) en errores de CRC y tiempo de espera. El comportamiento actual es que el controlador del puerto IDE/ATAPI (Atapi.sys) reduce el modo de transferencia después de algún tiempo de espera o errores de CRC 6. Cuando esta corrección implementa la nueva directiva, Atapi.sys reduce el modo de transferencia después de 6 consecutivo tiempo de espera o errores de CRC. Esta nueva directiva sólo se implementa si está presente el valor del registro que se describe más adelante en este artículo.
Para implementar el comportamiento alternativo (reducir el modo de transferencia después de seis consecutivo tiempo de espera o errores de CRC en lugar de después de seis tiempo de espera o errores de CRC), debe modificar el registro como se describe a continuación después de aplicar el hotfix.

Para que modifique el registro para, ir a la "Corríjanlo por mí. Si prefiere modificar el registro manualmente, ir a la "Déjeme corregirlo yo mismo.

Corríjanlo por mí



Para solucionar este problema automáticamente, haga clic en el botón o vínculo de Corregirlo. En el cuadro de diálogo Descarga de archivos , haga clic en Ejecutar y, a continuación, siga los pasos de la corrección se asistente.

Implementar el comportamiento alternativo
Microsoft Fix it 50644



Notas
  • Este asistente puede estar sólo en inglés. Sin embargo, la corrección automática también funciona para otras versiones de idioma de Windows.
  • Si no está en el equipo que tiene el problema, guarde la solución, solución en una unidad flash o en un CD y, a continuación, se ejecuta en el equipo que tiene el problema.

A continuación, vaya a la "¿Esto ha solucionado el problema?.



Déjeme corregirlo yo mismo

Importante: Esta sección, el método o la tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, copia de seguridad del registro antes de modificarlo. Luego puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo hacer copia de seguridad y restaurar el registro en Windows


Siga estos pasos y, a continuación, salga del Editor del registro:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo Regedity, a continuación, haga clic en Aceptar.
  2. Busque y, a continuación, haga clic en la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001
  3. En el menú Edición , seleccione nuevoy, a continuación, haga clic en Valor DWORD.
  4. Tipo ResetErrorCountersOnSuccess, y, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar.
  6. Tipo 1y, a continuación, haga clic en Aceptar.
Siga estos pasos y, a continuación, salga del Editor del registro:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo Regedity, a continuación, haga clic en Aceptar.
  2. Busque y, a continuación, haga clic en la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002
  3. En el menú Edición , seleccione nuevoy, a continuación, haga clic en Valor DWORD.
  4. Tipo ResetErrorCountersOnSuccess, y, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar.
  6. Tipo 1y, a continuación, haga clic en Aceptar.
Nota Las subclaves numeradas que aparecen anteriormente corresponden a los canales IDE principal y secundario en un equipo que contiene una única controladora IDE. Si el equipo contiene dos controladoras IDE, las subclaves numeradas para los canales IDE principales y secundarios para cada uno de los dos controladores pueden ser:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0003


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0004


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0005
Para comprobar que ha encontrado la subclave correcta, compruebe que el
DriverDesc
valor de la subclave contiene el valor de cadena "Primary IDE Channel" o el valor de cadena "Secondary IDE Channel".

Propiedades

Id. de artículo: 817472 - Última revisión: jueves, 6 de febrero de 2014 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows XP Tablet PC Edition
Palabras clave: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbwin2000presp5fix kbbug kbfix kbqfe kbwinserv2003presp1fix kbfixme kbmsifixme kbmt KB817472 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 817472

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com