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文書番号: 817472 - 最終更新日: 2007年12月3日 - リビジョン: 8.2

複数回のタイムアウトまたは CRC エラーの発生後 IDE ATA および ATAPI ディスクで PIO モードが使用される

重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、システムの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986? (http://support.microsoft.com/kb/256986/ ) Microsoft Windows レジストリの説明

目次

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現象

コンピュータの中断と再開を数回繰り返すと、ハード ディスクのパフォーマンスが低下することがあります。デバイス マネージャを使用して、ドライブが接続されている IDE チャンネルのプロパティを表示すると、[詳細設定] タブに、ドライブの現在の転送モードが "PIO モード" であることが示されます。

原因

タイムアウトまたは巡回冗長検査 (CRC) エラーが合計 6 回発生すると、Windows IDE/ATAPI ポート ドライバ (Atapi.sys) は、通信速度 (転送モード) を、最速の DMA (Direct Memory Access) モードから段階的に低速の DMA モードに下げます。引き続きタイムアウトまたは CRC エラーが発生する場合、ドライバは最終的に転送モードを最も低速のモード (PIO モード) まで下げます。

解決方法

Windows Server 2003

修正プログラムの情報

マイクロソフトでは、この製品のデフォルトの動作を変更する、サポートされた機能を用意していますが、この機能はこの資料に記載された動作のみを修正することを目的としており、この機能を必要とするコンピュータに対してのみ適用することを推奨します。この機能は、今後さらにテストを行う場合があります。したがって、この機能の不足により深刻な影響を受けていない場合は、この機能が含まれる次の Windows Server 2003 がリリースされるまで待つことを推奨します。

この機能を入手するには、Microsoft Product Support Services にお問い合わせください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)
必要条件
必要な Service Pack はありません。
再起動の必要性
この修正プログラムの適用後、コンピュータを再起動する必要があります。
修正プログラムの置き換えに関する情報
この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。
ファイル情報
修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付            時刻    バージョン      サイズ    ファイル名   プラットフォーム
   ------------------------------------------------------------------
   28-Apr-2003  18:09  5.2.3790.10   91,136  Atapi.sys  i386
   28-Apr-2003  18:09  5.2.3790.10  288,256  Atapi.sys  IA64

: この修正プログラムの適用後、この資料の「詳細」に記載されているようにレジストリを変更して、この動作を変更する必要があります。レジストリを変更しないと、修正プログラムによって動作が変更されません。

Windows XP

Service Pack の情報

この問題を解決するには、Windows XP の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322389? (http://support.microsoft.com/kb/322389/ ) 最新の Windows XP Service Pack を入手する方法

修正プログラムの情報

マイクロソフトでは、この製品のデフォルトの動作を変更する、サポートされた機能を用意していますが、この機能はこの資料に記載された動作のみを修正することを目的としており、この機能を必要とするコンピュータに対してのみ適用することを推奨します。この機能は、今後さらにテストを行う場合があります。したがって、この機能の不足により深刻な影響を受けていない場合は、この機能が含まれる次の Windows XP Service Pack がリリースされるまで待つことを推奨します。

この機能を入手するには、Microsoft Product Support Services にお問い合わせください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)
必要条件
Windows XP Service Pack 1
再起動の必要性
この修正プログラムの適用後、コンピュータを再起動する必要があります。
修正プログラムの置き換えに関する情報
この修正プログラムにより、修正プログラム 331958? (http://support.microsoft.com/kb/331958/ ) および 331895? (http://support.microsoft.com/kb/331895/ ) が置き換えられます。
ファイル情報
修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付            時刻    バージョン       サイズ     ファイル名   プラットフォーム
   --------------------------------------------------------------------
   23-Apr-2003  16:29  5.1.2600.1211   87,296  Atapi.sys  i386
   23-Apr-2003  16:29  5.1.2600.1211  306,432  Atapi.sys  IA64

: この修正プログラムの適用後、この資料の「詳細」に記載されているようにレジストリを変更して、この動作を変更する必要があります。レジストリを変更しないと、修正プログラムによって動作が変更されません。

Windows 2000

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)
: Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。
必要条件
Windows 2000 Service Pack 2
再起動の必要性
この修正プログラムの適用後、コンピュータを再起動する必要があります。
修正プログラムの置き換えに関する情報
この修正プログラムにより、修正プログラム 813908? (http://support.microsoft.com/kb/813908/ ) 323153? (http://support.microsoft.com/kb/323153/ ) 314695? (http://support.microsoft.com/kb/314695/ ) 305176? (http://support.microsoft.com/kb/305176/ ) 305098? (http://support.microsoft.com/kb/305098/ ) 304912? (http://support.microsoft.com/kb/304912/ ) 304572? (http://support.microsoft.com/kb/304572/ ) および 298505? (http://support.microsoft.com/kb/298505/ ) が置き換えられます。
ファイル情報
修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付            時刻    バージョン       サイズ    ファイル名
   ----------------------------------------------------
   28-Apr-2003  17:38  5.0.2195.6741  86,896  Atapi.sys

: この修正プログラムの適用後、この資料の「詳細」に記載されているようにレジストリを変更して、この動作を変更する必要があります。レジストリを変更しないと、修正プログラムによって動作が変更されません。

回避策

デバイスの標準または高速の転送モードを有効にするには、以下の手順を実行します。
  1. [管理ツール] をダブルクリックし、[コンピュータの管理] をクリックします。
  2. [システム ツール] をクリックし、[デバイス マネージャ] をクリックします。
  3. [IDE ATA/ATAPI コントローラ] を展開します。
  4. 標準 DMA 転送モードを復元するコントローラをダブルクリックします。
  5. [ドライバ] タブをクリックします。
  6. [削除] をクリックします。
  7. 処理の完了後、コンピュータを再起動します。Windows の再起動時に、ハード ディスク コントローラが再列挙され、コントローラに接続されている各デバイスの転送モードが、デフォルト値に再設定されます。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

Windows XP

この問題は、Microsoft Windows XP Service Pack 2 で最初に修正されました。

詳細

この資料に記載されている修正プログラムによる変更点は以下のとおりです。
  • Windows 2000 のみ、タイムアウト値が 4 秒に設定された、ATA ディスクへの読み取り要求が発行されることがあります。この現象は、コンピュータがスタンバイから再開するときに発生します。ドライブの再開には通常 4 秒以上かかるため、これが原因で、ディスクのタイムアウトが発生する可能性があります。このタイムアウト値が 10 秒に変更されます。

    Windows XP および Windows Server 2003 ではこのタイムアウト値は常に 10 秒です。
  • タイムアウトおよび CRC エラーの発生時に、(高速の DMA モードから低速の DMA モード、最終的には PIO モードへ) 転送モードを下げる動作が従来よりも発生しにくいポリシーが実装されます。従来の動作では、合計 6 回のタイムアウトまたは CRC エラー発生後、IDE/ATAPI ポート ドライバ (Atapi.sys) により、転送モードが下げられていました。この修正プログラムで新しいポリシーを実装すると、タイムアウトまたは CRC エラーが連続して 6 回発生した場合にのみ、Atapi.sys により転送モードが下げられます。新しいポリシーは、この資料で後述するレジストリ値が存在する場合にのみ実装されます。
代替の動作 (合計 6 回のタイムアウトまたは CRC エラー発生後ではなく、6 回の連続したタイムアウトまたは CRC エラー発生後に、転送モードを下げます) を実装するには、修正プログラムの適用後、以下の手順に従ってレジストリを変更する必要があります。

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

次の手順を実行した後、レジストリ エディタを終了します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。regedit と入力し、[OK] をクリックします。
  2. 次のレジストリ キーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001
  3. [編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。
  4. ResetErrorCountersOnSuccess と入力し、Enter キーを押します。
  5. [編集] メニューの [修正] (または [変更]) をクリックします。
  6. 1 と入力し、[OK] をクリックします。
次の手順を実行した後、レジストリ エディタを終了します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。regedit と入力し、[OK] をクリックします。
  2. 次のレジストリ キーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002
  3. [編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。
  4. ResetErrorCountersOnSuccess と入力し、Enter キーを押します。
  5. [編集] メニューの [修正] (または [変更]) をクリックします。
  6. 1 と入力し、[OK] をクリックします。
: 上記の番号付きのサブキーは、IDE コントローラを 1 台搭載したコンピュータのプライマリ IDE チャネルとセカンダリ IDE チャネルに対応します。コンピュータに IDE コントローラが 2 台搭載されている場合、2 台のコントローラそれぞれのプライマリ IDE チャネルとセカンダリ IDE チャネルの番号付きサブキーは、次のようになります。
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0003

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0004

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0005
見つけたサブキーが適切なサブキーであるかどうかを確認するには、そのサブキーの DriverDesc 値に文字列値 "プライマリ IDE チャネル" または文字列値 "セカンダリ IDE チャネル" が設定されていることを確認します。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 817472? (http://support.microsoft.com/kb/817472/EN-US/ ) (最終更新日 2004-11-05) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows XP Tablet PC Edition
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