Os discos IDE ATA e ATAPI usam o modo PIO após ocorrerem diversos erros de tempo limite ou CRC

Traduções deste artigo Traduções deste artigo
ID do artigo: 817472 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Após suspender e retomar seu computador diversas vezes, o desempenho do disco rígido pode ser reduzido. Se usar o Gerenciador de Dispositivos para exibir as propriedades do canal IDE ao qual a unidade está conectada, a guia Configurações Avançadas pode mostrar que o modo de transferência atual para a unidade é "Modo PIO".

Causa

Após o driver de porta IDE/ATAPI do Windows (Atapi.sys) receber um total cumulativo de 6 erros de tempo limite ou CRC, o driver reduz a velocidade de comunicação (o modo de transferência) do modo DMA (Acesso direto à memória) mais alto aos modos DMA mais baixos em etapas. Se o driver continuar a receber erros de tempo limite ou CRC, o driver eventualmente reduz o modo de transferência para o modo mais lento (modo PIO).

Resolução

Windows Server 2003

Informações sobre o hotfix

Um recurso de suporte que modifica o comportamento padrão do produto está agora disponível pela Microsoft. No entanto, este recurso destina-se somente a modificar o comportamento descrito neste artigo. Aplique este recurso apenas aos sistemas que necessitem especificamente dele. Testes adicionais podem ser realizados nesse recurso. Por isso, se o sistema não for muito afetado devido à ausência deste recurso, é aconselhável aguardar a próxima atualização de software que contenha este recurso.

Se o recurso estiver disponível para download, existirá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não é exibida, contate o Serviço de Atendimento ao Cliente da Microsoft para obter o recurso.

Observação Caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não sejam específicos deste recurso. Para obter uma lista completa dos números de telefone do Atendimento ao Cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
ObservaçãoO formulário "Download de hotfix disponível" exibe os idiomas para os quais o recurso está disponível. Caso seu idioma não seja exibido, o recurso não está disponível para esse idioma.
Pré-requisitos
Não é necessário nenhum service pack.
Requisitos de reinicialização
É necessário reiniciar seu computador após aplicar este hotfix.
Informações sobre a substituição do hotfix
Este hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários desses arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
   Data         Hora   Versão      Tamanho    Nome do arquivo    Plataforma
   -------------------------------------------------------------
   28-Abr-2003  18:09  5.2.3790.10   91.136  Atapi.sys  i386
   28-Abr-2003  18:09  5.2.3790.10  288.256  Atapi.sys  IA64

Observação Após aplicar esse hotfix, é necessário modificar o Registro como descrito na seção "Mais Informações" neste artigo para alterar esse comportamento. Caso o Registro não seja modificado, o hotfix não altera o comportamento.

Windows XP

Informação do Service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows XP. Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
322389 Como obter o service pack mais recente do Windows XP

Informações sobre o hotfix

Um recurso de suporte que modifica o comportamento padrão do produto está agora disponível pela Microsoft. No entanto, este recurso destina-se somente a modificar o comportamento descrito neste artigo. Aplique este recurso apenas aos sistemas que necessitem especificamente dele. Testes adicionais podem ser realizados nesse recurso. Por isso, se o sistema não for muito afetado devido à ausência deste recurso, é aconselhável aguardar a próxima atualização de software que contenha este recurso.

Se o recurso estiver disponível para download, existirá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não é exibida, contate o Serviço de Atendimento ao Cliente da Microsoft para obter o recurso.

Observação Caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não sejam específicos deste recurso. Para obter uma lista completa dos números de telefone do Atendimento ao Cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
ObservaçãoO formulário "Download de hotfix disponível" exibe os idiomas para os quais o recurso está disponível. Caso seu idioma não seja exibido, o recurso não está disponível para esse idioma.
Pré-requisitos
Windows XP Service Pack 1
Requisito de Reinicialização
É necessário reiniciar o computador após aplicar esse hotfix.
Informação de substituição do Hotfix
Esse hotfix substitui outros hotfixes 331958 e 331895.
Informação sobre o arquivo
A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários desses arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
   Data         Hora   Versão      Tamanho    Nome do arquivo    Plataforma
   ---------------------------------------------------------------
   23-Abr-2003  16:29  5.1.2600.1211   87.296  Atapi.sys  i386
   23-Abr-2003  16:29  5.1.2600.1211  306.432  Atapi.sys  IA64

Observação Após aplicar esse hotfix, é necessário modificar o Registro como descrito na seção "Mais Informações" neste artigo para alterar esse comportamento. Caso o Registro não seja modificado, o hotfix não altera o comportamento.

Windows 2000

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix estiver disponível para download, existirá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não é exibida, envie uma solicitação ao Serviço de Atendimento ao Cliente da Microsoft para obter o hotfix.

Observação Caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento ao Cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso seu idioma não seja exibido, um hotfix não está disponível para esse idioma.
Pré-requisitos
Windows 2000 Service Pack 2
Requisito de Reinicialização
É necessário reiniciar o computador após aplicar esse hotfix.
Informação de substituição do Hotfix
Esse hotfix substitui outros hotfixes 813908, 323153, 314695, 305176, 305098, 304912, 304572 e 298505.
Informação sobre o arquivo
A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários desses arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
   Data         Hora    Versão      Tamanho  Nome do arquivo
   ----------------------------------------------------
   28-Abr-2003  17:38  5.0.2195.6741  86.896  Atapi.sys

Observação Após aplicar esse hotfix, é necessário modificar o Registro como descrito na seção "Mais Informações" neste artigo para alterar esse comportamento. Caso o Registro não seja modificado, o hotfix não altera o comportamento.

Como Contornar

Para reativar o modo de transferência normal, ou mais rápido, para um dispositivo afetado:
  1. Clique duas vezes em Ferramentas administrativas e clique em Gerenciamento do computador.
  2. Clique em Ferramentas do sistema e em Gerenciador de dispositivos.
  3. Expanda o nó Controladores IDE ATA/ATAPI.
  4. Clique duas vezes no controlador para o qual deseja restaurar o modo de transferência DMA normal.
  5. Clique na guia Driver.
  6. Clique em Desinstalar.
  7. Quando o processo for concluído, reinicie o computador. Quando o Windows reinicia, o controlador do disco rígido é re-enumerado e o modo de transferência é redefinido para o valor padrão para cada dispositivo conectado ao controlador.

Situação

A Microsoft confirmou que este é um problema que ocorre nos produtos Microsoft que estão listados na seção "Aplica-se a".

Windows XP

Este problema foi corrigido pela primeira vez no Windows XP Service Pack 2 (SP2).

Mais Informações

O hotfix descrito neste artigo faz as seguintes alterações:
  • No Windows 2000 somente, as solicitações de leitura de discos ATA são algumas vezes enviadas com um valor de tempo limite de 4 segundos. Isso ocorre quando seu computador é retomado do modo de espera. Isso pode fazer com que o tempo limite do disco seja atingido porque as unidades normalmente levam mais de 4 segundos para girar. Esse valor de tempo limite foi alterado para 10 segundos.

    No Windows XP e no Windows Server 2003, esse valor de tempo limite é sempre 10 segundos.
  • Uma diretiva alternativa e menos agressiva é implementada para reduzir o modo de transferência (de modos MDA mais rápidos para modos MDA mais lentos, e eventualmente para o modo PIO) em erros de tempo limite e de CRC. Esse comportamento é que o driver de porta IDE/ATAPI (Atapi.sys) reduz o modo de transferência após 6 erros cumulativos de tempo limite e CRC. Quando a nova diretiva é implementada por essa correção, o Atapi.sys reduz o modo de transferência somente após 6 erros de tempo limite e CRC consecutivos. Essa nova diretiva é implementada somente se o valor do Registro descrito posteriormente neste artigo está presente.
Para implementar esse comportamento alternativo (reduzindo o modo de transferência após seis erros de tempo limite e CRC consecutivos em vez de fazer isso após seis erros de tempo limite e CRC cumulativos), é necessário modificar o Registro conforme descrito abaixo após aplicar o hotfix.

Importante Esta seção, método ou tarefa contém etapas que instruem sobre como modificar o Registro. No entanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Por isso, certifique-se de seguir essas etapas cuidadosamente. Para obter mais proteção, faça um backup do Registro antes de modificá-lo. Dessa forma, você poderá restaurar o Registro se ocorrer um problema. Para obter informações adicionais sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
322756 Como fazer backup e restaurar o Registro no Windows


Execute as seguintes etapas e encerre o Editor do Registro.
  1. Clique em Iniciar, Executar, digite regedit e clique em OK.
  2. Localize e clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0001
  3. No menu Editar, aponte para Novo e clique em Valor DWORD.
  4. Digite ResetErrorCountersOnSuccess e pressione ENTER.
  5. No menu Editar, clique em Modificar.
  6. Digite 1 e clique em OK.
Execute as seguintes etapas e encerre o Editor do Registro.
  1. Clique em Iniciar, Executar, digite regedit e clique em OK.
  2. Localize e clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002
  3. No menu Editar, aponte para Novo e clique em Valor DWORD.
  4. Digite ResetErrorCountersOnSuccess e pressione ENTER.
  5. No menu Editar, clique em Modificar.
  6. Digite 1 e clique em OK.
Observação As subchaves numeradas listadas anteriormente correspondem aos canais IDE primário e secundário em um computador contendo um único controlador IDE. Se seu computador contém dois controladores IDE, as subchaves numeradas para os canais IDE primário e secundário para cada um dos dois controladores podem ser:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0003


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0004


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0005
Para verificar se você encontrou a subchave correta, verifique se o valor
DriverDesc
para a subchave contém o valor de cadeia de caracteres "Canal IDE Primário" ou o valor de cadeia de caracteres "Canal IDE Secundário".

Propriedades

ID do artigo: 817472 - Última revisão: quinta-feira, 19 de junho de 2008 - Revisão: 8.3
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows XP Tablet PC Edition
Palavras-chave: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbwin2000presp5fix kbbug kbfix kbqfe kbwinserv2003presp1fix KB817472

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com