Le message d'erreur « Une opération a été tentée sur autre chose qu'un socket » s'affiche lorsque vous essayez de vous connecter au réseau

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Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 Description du Registre de Microsoft Windows
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Sommaire

Symptômes

Lorsque vous tentez de connecter votre ordinateur à un réseau, le message d'erreur suivant peut s'afficher :
une opération a été tentée sur autre chose qu'un socket.
Ce symptôme se produit sur un ordinateur qui obtient une adresse IP d'un serveur DHCP (Dynamic Host Configuration Protocol). Si vous affectez une adresse IP statique à votre ordinateur, ce message d'erreur ne s'affiche pas.

Cause

Ce problème peut se produire si vous possédez un produit tiers qui utilise des sockets Windows et les commandes ipconfig, release et renew. Les sous-clés du Registre des sockets Windows peuvent être endommagées.

Résolution

Avertissement Toute utilisation incorrecte de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Méthode 1

Il est recommandé d'utiliser la Méthode 1 si l'une ou l'autre des conditions suivantes est vrai :
  • Vous ne disposez que d'un seul ordinateur.
  • Vous n'avez pas accès à un ordinateur semblable au premier ordinateur où vous avez rencontré les symptômes qui sont décrits dans la section « Symptômes ». Un ordinateur semblable au premier ordinateur est un autre ordinateur qui a la même version d'un système d'exploitation et une configuration matérielle similaire.
Utilisez l'Éditeur du Registre pour exporter et supprimer les sous-clés de Registre Winsock et Winsock2, puis supprimez et réinstallez TCP/IP sur Microsoft Windows 2000 ou Microsoft Windows XP. Pour cela, procédez comme suit :

Exportez et supprimez les sous-clés de Registre endommagées

  1. Insérez une disquette dans le lecteur de disquette de l'ordinateur dont vous exportez les entrées de Registre.
  2. Cliquez sur Démarrer, sur Exécuter, tapez regedit, puis cliquez sur OK.
  3. Recherchez la sous-clé de Registre suivante et cliquez dessus :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock
  4. Dans le menu Fichier, cliquez sur Exporter.
  5. Dans la zone Enregistrer dans, cliquez sur Disquette 3,5½ (A:), tapez un nom pour le fichier dans la zone Nom de fichier, puis cliquez sur Enregistrer.
  6. Cliquez avec le bouton droit sur Winsock, puis cliquez sur Supprimer. Lorsque vous êtes invité à confirmer la suppression, cliquez sur Oui.
  7. Répétez les étapes 3 à 6 pour les sous-clés suivantes :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2
    Remarque Chaque fichier .reg que vous enregistrez doit avoir un nom différent.
  8. Cliquez avec le bouton droit sur Winsock2, cliquez sur Supprimer, puis sur Oui.
  9. Quittez l'Éditeur du Registre.

Ordinateur Windows 2000

Supprimez TCP/IP sur un ordinateur Windows 2000
  1. Ouvrez une session Windows en tant qu'administrateur.
  2. Dans le Panneau de configuration, double-cliquez sur Connexions réseau, cliquez avec le bouton droit sur Connexion au réseau local, puis cliquez sur Propriétés.
  3. Sous Les composants sélectionnés sont utilisés par cette connexion, cliquez sur Protocole Internet (TCP/IP), puis sur Désinstaller.
  4. Suivez les instructions qui s'affichent à l'écran pour supprimer le protocole TCP/IP.
  5. Redémarrez votre ordinateur, mais cliquez sur Non si vous êtes invités à laisser Windows activer un protocole.
Installez TCP/IP sur un ordinateur Windows 2000
  1. Ouvrez une session Windows en tant qu'administrateur.
  2. Dans le Panneau de configuration, double-cliquez sur Connexions réseau, cliquez avec le bouton droit sur Connexion au réseau local, puis cliquez sur Propriétés.
  3. Cliquez sur Installer.
  4. Dans la boîte de dialogue Sélection du type de composant réseau, cliquez sur Protocole, puis sur Ajouter.
  5. Sous Protocole réseau, cliquez sur Protocole Internet (TCP/IP), puis sur OK.
  6. Une fois le protocole installé, cliquez sur Fermer.
  7. Redémarrez votre ordinateur.

Ordinateur Windows XP

Réinstallez TCP/IP sur un ordinateur Windows XP
Dans Windows XP, la pile TCP/IP est un composant principal du système d'exploitation. Par conséquent, vous ne pouvez pas supprimer TCP/IP dans Windows XP.
  1. Installez TCP/IP sur lui-même. Pour cela, procédez comme suit :
    1. Dans le Panneau de configuration, double-cliquez sur Connexions réseau, cliquez avec le bouton droit sur Connexion au réseau local, puis cliquez sur Propriétés.
    2. Cliquez sur Installer.
    3. Cliquez sur Protocole, puis sur Ajouter.
    4. Cliquez sur Disque fourni.
    5. Dans la zone Copier les fichiers constructeur à partir de, tapez Lettre_lecteur_système:\windows\inf, puis cliquez sur OK.
    6. Dans la liste des protocoles disponibles, cliquez sur Protocole Internet (TCP/IP) puis sur OK.
  2. Redémarrez votre ordinateur.

Méthode 2

Si vous corrigez ce problème sur plusieurs ordinateurs et que vous avez accès à un ordinateur en service équipé de la même version de système d'exploitation et d'une configuration matérielle semblable, il est recommandé d'utiliser la Méthode 2.

Pour résoudre ce problème, supprimez les entrées du Registre endommagées, puis remplacez-les par les informations de clé de Registre que vous avez exportées à partir d'un ordinateur équipé d'une installation active de TCP/IP. Pour cela, procédez comme suit :

Supprimez les entrées endommagées du Registre

Sur l'ordinateur dont les entrées du Registre sont endommagées, procédez comme suit :
  1. Cliquez sur Démarrer, sur Exécuter, tapez regedit, puis cliquez sur OK.
  2. Dans l'Éditeur du Registre, recherchez la sous-clé de Registre suivante et cliquez dessus :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
    .
  3. Cliquez avec le bouton droit sur Winsock, puis cliquez sur Supprimer. Lorsque vous êtes invité à confirmer la suppression, cliquez sur Oui.
  4. Cliquez avec le bouton droit sur Winsock2, puis cliquez sur Supprimer. Lorsque vous êtes invité à confirmer la suppression, cliquez sur Oui.

Exportez les entrées du Registre sur une disquette

Sur l'ordinateur qui possède une installation active de TCP/IP, procédez comme suit.

Remarque L'ordinateur à partir duquel vous importez les entrées du Registre doit utiliser la même version de Windows et être semblable ou identique à l'ordinateur dont les symptômes sont décrits dans la section « Symptômes ».
  1. Insérez une disquette dans le lecteur de disquette de l'ordinateur dont vous exportez les entrées de Registre.
  2. Cliquez sur Démarrer, sur Exécuter, tapez regedit, puis cliquez sur OK.
  3. Dans l'Éditeur du Registre, recherchez la sous-clé de Registre suivante et cliquez dessus, puis cliquez sur Winsock :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
  4. Cliquez sur Fichier, puis sur Exporter.
  5. Dans la zone Enregistrer dans, cliquez sur Disquette 3½ (A:), tapez un nom de fichier dans la zone Nom du fichier, puis cliquez sur Enregistrer.
  6. Cliquez sur Winsock2, sur Fichier, puis sur Exporter.
  7. Dans la zone Enregistrer dans, cliquez sur Disquette 3½ (A:), tapez un nom de fichier dans la zone Nom du fichier, puis cliquez sur Enregistrer.

    Remarque Chaque fichier .reg que vous enregistrez doit avoir un nom différent.
  8. Quittez l'Éditeur du Registre.

Importez les entrées du Registre à partir de la disquette

Sur l'ordinateur dont les entrées du Registre sont endommagées, procédez comme suit :
  1. Insérez la disquette qui contient les fichiers .reg dans le lecteur de disquette de l'ordinateur dont les symptômes sont décrits dans la section « Symptômes ».
  2. Démarrez l'Explorateur Windows, cliquez sur Poste de travail, puis double-cliquez sur Disquette 3½ (A:).
  3. Double-cliquez sur chaque fichier .reg que vous avez créé et enregistré sur la disquette dans la section « Exportez les clés de Registre sur une disquette ».
  4. Cliquez sur Oui lorsque vous êtes invité à ajouter des informations au Registre.
  5. Cliquez sur OK lorsque vous recevez le message vous indiquant que les informations ont été ajoutées au Registre avec succès.
  6. Quittez l'Éditeur du Registre.

Plus d'informations

Ces méthodes restaurent les fonctionnalités de base des sous-clés Winsock et Winsock2. Vous devrez peut-être réinstaller certains logiciel proxy ou pare-feux tiers.

Propriétés

Numéro d'article: 817571 - Dernière mise à jour: vendredi 23 décembre 2005 - Version: 6.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professionnel
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professionel
  • Microsoft Windows 2000 Server
Mots-clés : 
kbacwsurvey kberrmsg kbprb KB817571
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