Artigo: 817571 - Última revisão: segunda-feira, 27 de Novembro de 2006 - Revisão: 7.1

Recebe uma mensagem de erro "Foi tentada uma operação em algum item que não é um socket" quando tenta ligar a uma rede

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante: este artigo contém informações sobre como modificar o registo. Certifique-se de que cria uma cópia de segurança do registo antes de o modificar. Certifique-se de que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows

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Sintomas

Quando tenta ligar o computador a uma rede, poderá receber a seguinte mensagem de erro:
Foi tentada uma operação em algum item que não é um socket.
Este sintoma ocorre num computador que obtém um endereço IP de um servidor de protocolo de configuração dinâmica de anfitrião (DHCP, Dynamic Host Configuration Protocol). Se atribuir um endereço IP estático ao computador, não receberá esta mensagem.

Causa

Este problema pode ocorrer se tiver um produto de outros fabricantes instalado que utilize os sockets do Windows e também os comandos ipconfig, release e renew. As subchaves de registo dos sockets do Windows podem estar danificadas.

Resolução

Aviso: poderão ocorrer problemas graves se modificar o registo de forma incorrecta utilizando o Editor de registo (Registry Editor) ou qualquer outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que estes problemas possam ser resolvidos. Todo e qualquer risco decorrente da modificação do registo é da responsabilidade do utilizador.Para resolver este problema, utilize um dos métodos seguintes.

Método 1

A Microsoft recomenda a utilização do Método 1 se se verificar qualquer uma das seguintes condições:
  • Tem apenas um computador.
  • Não tem acesso a um computador semelhante ao primeiro computador onde ocorreram os sintomas descritos na secção "Sintomas". O computador semelhante ao primeiro é outro computador que tenha a mesma versão do sistema operativo e uma configuração de hardware semelhante.
Utilize o Editor de registo (Registry Editor) para exportar e eliminar as subchaves de registo Winsock e Winsock2 e remova e reinstale o TCP/IP no Microsoft Windows 2000 ou Microsoft Windows XP. Para tal, siga estes passos.

Exportar e eliminar as subchaves de registo danificadas

  1. Insira uma disquete na unidade de disquetes do computador cujas entradas de registo está a exportar.
  2. Clique em Iniciar (Start), clique em Executar (Run), escreva regedit e clique em OK.
  3. Localize e clique na seguinte subchave de registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock
  4. No menu Ficheiro (File), clique em Exportar (Export).
  5. Na caixa Guardar em (Save in), clique em Disquete de 3½ (A:) [3½ Floppy (A:)], escreva um nome para o ficheiro na caixa Nome do ficheiro (File name) e clique em Guardar (Save).
  6. Clique com o botão direito do rato em Winsock e clique em Eliminar (Delete). Quando lhe for pedido para confirmar a eliminação, clique em Sim (Yes).
  7. Repita os passos 3 a 6 para a seguinte subchave:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2
    Nota: cada ficheiro .reg que guardar deve ter um nome diferente.
  8. Clique com o botão direito do rato em Winsock2, clique em Eliminar (Delete) e clique em Sim (Yes).
  9. Saia do Editor de registo (Registry Editor).

Computador com o Windows 2000

Remover o TCP/IP num computador com o Windows 2000
  1. Inicie sessão no Windows como administrador.
  2. No Painel de controlo (Control Panel), faça duplo clique em Ligações de acesso telefónico e de rede (Network Connections), clique com o botão direito do rato em Ligação de área local (Local Area Connection) e clique em Propriedades (Properties).
  3. Em Os componentes assinalados são utilizados por esta ligação (This component uses the following items), clique em TCP/IP (Protocolo Internet) [Internet Protocol (TCP/IP)] e clique em Desinstalar (Uninstall).
  4. Siga as instruções apresentadas no ecrã para remover o TCP/IP.
  5. Reinicie o computador, mas clique em Não (No) se lhe for pedido para permitir ao Windows activar o protocolo.
Instalar o TCP/IP num computador com o Windows 2000
  1. Inicie sessão no Windows como administrador.
  2. No Painel de controlo (Control Panel), faça duplo clique em Ligações de acesso telefónico e de rede (Network Connections), clique com o botão direito do rato em Ligação de área local (Local Area Connection) e clique em Propriedades (Properties).
  3. Clique em Instalar (Install).
  4. Na caixa de diálogo Seleccionar tipo de componente de rede (Select Network Component Type), clique em Protocolo (Protocol) e clique em Adicionar (Add).
  5. Em Protocolo de rede (Network Protocol), clique em Protocolo Internet (TCP/IP) [Internet Protocol (TCP/IP)] e clique em OK.
  6. Quando o protocolo estiver instalado, clique em Fechar (Close).
  7. Reinicie o computador.

Computador com o Windows XP

Reinstalar o TCP/IP num computador com o Windows XP
No Windows XP, a pilha do TCP/IP é um componente principal do sistema operativo. Assim, não pode remover o TCP/IP do Windows XP.
  1. Instale o TCP/IP sobre o existente. Para tal, siga estes passos:
    1. No Painel de controlo faça duplo clique em Ligações de rede, clique com o botão direito do rato em Ligação de área local e clique em Propriedades.
    2. Clique em Instalar.
    3. Clique em Protocolo e clique em Adicionar.
    4. Clique em Disco.
    5. Na caixa Copiar ficheiros do fabricante de, escreva Letra_Unidade_Sistema:\windows\inf e clique em OK.
    6. Na lista de protocolos disponíveis, clique em TCP/IP (Protocolo Internet) [Internet Protocol (TCP/IP)] e clique em OK.
  2. Reinicie o computador.

Método 2

Se estiver a corrigir este problema em vários computadores e tiver acesso a um computador em funcionamento com a mesma versão de sistema operativo e uma configuração de hardware semelhante, a Microsoft recomenda o Método 2.

Para resolver este problema, elimine as entradas de registo danificadas e substitua-as pelas informações da chave de registo exportadas a partir de um computador com uma instalação do TCP/IP em funcionamento. Para tal, siga estes passos.

Eliminar as entradas de registo danificadas

No computador que tem as entradas de registo danificadas, siga estes passos:
  1. Clique em Iniciar (Start), clique em Executar (Run), escreva regedit e clique em OK.
  2. No Editor de registo (Registry Editor), localize e clique na seguinte subchave de registo:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
  3. Clique com o botão direito do rato em Winsock e clique em Eliminar (Delete). Quando lhe for pedido para confirmar a eliminação, clique em Sim (Yes).
  4. Clique com o botão direito do rato em Winsock2 e clique em Eliminar (Delete). Quando lhe for pedido para confirmar a eliminação, clique em Sim (Yes).

Exportar as entradas de registo para uma disquete

No computador que tem uma instalação de TCP/IP em funcionamento, siga estes passos.

Nota: o computador do qual está a importar as entradas de registo deve utilizar a mesma versão do Windows e ser semelhante a ou um duplicado do computador onde estão a ocorrer os problemas descritos na secção "Sintomas".
  1. Insira uma disquete na unidade de disquetes do computador cujas entradas de registo está a exportar.
  2. Clique em Iniciar (Start), clique em Executar (Run), escreva regedit e clique em OK.
  3. No Editor de registo (Registry Editor), localize e clique na seguinte subchave de registo e clique em Winsock:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
  4. Clique em Ficheiro (File) e clique em Exportar (Export).
  5. Na caixa Guardar em (Save in), clique em Disquete de 3½ (A:) [3½ Floppy (A:)], escreva um nome para o ficheiro na caixa Nome do ficheiro (File name) e clique em Guardar (Save).
  6. Clique em Winsock2, clique em Ficheiro (File) e clique em Exportar (Export).
  7. Na caixa Guardar em (Save in), clique em Disquete de 3½ (A:) [3½ Floppy (A:)], escreva um nome para o ficheiro na caixa Nome do ficheiro (File name) e clique em Guardar (Save).

    Nota: todos os ficheiros .reg que guardar devem ter um nome diferente.
  8. Saia do Editor de registo (Registry Editor).

Importar as entradas de registo da disquete

No computador com as entradas de registo danificadas, siga estes passos:
  1. Insira a disquete que contém os ficheiros .reg na unidade de disquetes do computador onde estão a ocorrer os sintomas descritos na secção "Sintomas".
  2. Inicie o Explorador do Windows (Windows Explorer), clique em O meu computador (My Computer) e faça duplo clique em Disquete de 3½ (A:) [3½ Floppy(A:)].
  3. Faça duplo clique em todos os ficheiros .reg criados na secção "Exportar as entradas de registo para uma disquete" e guardados na disquete.
  4. Clique em Sim (Yes) quando lhe for pedido para adicionar informações ao registo.
  5. Clique em OK quando receber a mensagem relativa à introdução com êxito das informações no registo.
  6. Saia do Editor de registo (Registry Editor).
  7. Reinicie o computador.

Mais Informação

Estes métodos restauram as funcionalidades básicas das subchaves Winsock e Winsock2. Pode ser necessário reinstalar algum software de proxy ou firewalls de outros fabricantes.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Palavras-chave: 
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