ID do artigo: 817571 - Última revisão: segunda-feira, 29 de janeiro de 2007 - Revisão: 8.0

Uma mensagem de erro "Foi tentada uma operação em algum item que não é um soquete" é exibida ao tentar se conectar a uma rede

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e certifique-se de que saiba como restaurá-lo caso ocorra algum problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do Registro do Microsoft Windows

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Sintomas

Ao tentar conectar o computador a uma rede, a seguinte mensagem de erro pode ser exibida:
Foi tentada uma operação em algum item que não é um soquete.
Esse sintoma ocorre em um computador que obtém um endereço IP de um servidor DHCP (Protocolo de configuração dinâmica de hosts). Se atribuir um endereço IP estático para o computador, essa mensagem não será exibida.

Causa

Esse problema pode ocorrer se tiver um produto de terceiros que use soquetes do Windows instalado e também use os comandos ipconfig, release e renew. As subchaves do Registro dos soquetes do Windows podem estar corrompidas.

Resolução

Aviso O uso incorreto do Editor do Registro, ou outro método, pode causar sérios problemas, que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. A modificação do Registro é de sua responsabilidade.Para resolver este problema, execute um dos métodos a seguir.

Método 1

Recomendamos o uso do Método 1 se uma das seguintes condições for verdadeira:
  • Você tem apenas um computador.
  • Você não tem acesso a um computador semelhante ao primeiro computador no qual enfrentou os sintomas descritos na seção "Sintomas". Um computador semelhante ao primeiro é outro computador que tem a mesma versão do sistema operacional e uma configuração de hardware semelhante.
Use o Editor do Registro para exportar e excluir as subchaves do Registro Winsock e Winsock2 e remova e reinstale o TCP/IP no Microsoft Windows 2000 ou no Microsoft Windows XP. Para fazer isso, execute as seguintes etapas.

Exporte e exclua as subchaves do Registro corrompidas

  1. Insira um disquete na unidade de disquete do computador do qual está exportando as entradas do Registro.
  2. Clique em Iniciar, em Executar, digite regedit e clique em OK.
  3. Localize e clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock
  4. Execute uma das seguintes etapas, dependendo do sistema operacional:
    • No Windows XP, no menu Arquivo, clique em Exportar.
    • No Windows 2000, no menu Registro, clique em Exportar.
  5. Na caixa Salvar em, clique em Disquete de 3½ (A:), digite um nome para o arquivo na caixa Nome do arquivo e clique em Salvar.
  6. Clique com o botão direito do mouse em Winsock e clique em Excluir. Ao ser solicitado confirmar a exclusão, clique em Sim.
  7. Repita as etapas 3 a 6 para a seguinte subchave:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2
    Observação Cada arquivo .reg salvo deve ter um nome diferente.
  8. Clique com o botão direito do mouse em Winsock2, clique em Excluir e em Sim.
  9. Encerre o Editor do Registro.

Computador com o Windows 2000

Remova o TCP/IP em um computador com o Windows 2000
  1. Faça o logon no Windows como administrador.
  2. No painel de controle, clique duas vezes em Conexões de rede, clique com o botão direito do mouse em Conexão local e clique em Propriedades.
  3. Em Os componentes marcados serão usados por esta conexão, clique em Protocolo Internet (TCP/IP) e em Desinstalar.
  4. Execute as instruções mostradas na tela para remover o TCP/IP.
  5. Reinicie o computador, mas clique em Não se for solicitado a permitir que o Windows ative um protocolo.
Instale o TCP/IP em um computador com o Windows 2000
  1. Faça o logon no Windows como administrador.
  2. No painel de controle, clique duas vezes em Conexões de rede, clique com o botão direito do mouse em Conexão local e clique em Propriedades.
  3. Clique em Instalar.
  4. Na caixa de diálogo Selecionar tipo de componente de rede, clique em Protocolo e em Adicionar.
  5. Em Protocolo de rede, clique em Protocolo Internet (TCP/IP) e em OK.
  6. Quando o protocolo estiver instalado, clique em Fechar.
  7. Reinicie o computador.

Computador com o Windows XP

Reinstale o TCP/IP em um computador com o Windows XP
No Windows XP, a pilha de TCP/IP é um componente base do sistema operacional. Por isso, não é possível remover o TCP/IP no Windows XP.
  1. Instale o TCP/IP sobre ele mesmo. Para fazer isto, execute as seguintes etapas:
    1. No painel de controle, clique duas vezes em Conexões de rede, clique com o botão direito do mouse em Conexão local e clique em Propriedades.
    2. Clique em Instalar.
    3. Clique em Protocolo e em Adicionar.
    4. Clique em Com disco.
    5. Na caixa Copiar os arquivos do fabricante de, digite Letra_da_unidade_do_sistema:\windows\inf e clique em OK.
    6. Na lista de protocolos disponíveis, clique em Protocolo TCP/IP e em OK.
  2. Reinicie o computador.

Método 2

Se estiver corrigindo esse problema em diversos computadores e tiver acesso a um computador com a mesma versão do sistema operacional e uma configuração de hardware semelhante, recomendamos o método 2.

Para resolver esse problema, exclua as entradas do Registro corrompidas e substitua essas entradas pelas informações da chave do Registro exportadas de um computador que tem uma instalação funcional do TCP/IP. Para fazer isso, execute as seguintes etapas.

Exclua as entradas do Registro corrompidas

No computador que tem as entradas do Registro corrompidas, execute as seguintes etapas:
  1. Clique em Iniciar, em Executar, digite regedit e clique em OK.
  2. No Editor do Registro, localize e clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
    .
  3. Clique com o botão direito do mouse em Winsock e clique em Excluir. Ao ser solicitado confirmar a exclusão, clique em Sim.
  4. Clique com o botão direito do mouse em Winsock e clique em Excluir. Ao ser solicitado confirmar a exclusão, clique em Sim.

Exporte as entradas do Registro para um disquete

No computador que tiver uma instalação funcional do TCP/IP, execute as seguintes etapas.

Observação O computador do qual está importando as entradas do Registro deve usar a mesma versão do Windows e ser semelhante ou uma réplica do computador que está enfrentando os sintomas descritos na seção "Sintomas".
  1. Insira um disquete na unidade de disquete do computador do qual está exportando as entradas do Registro.
  2. Clique em Iniciar, em Executar, digite regedit e clique em OK.
  3. No Editor do Registro, localize e clique na seguinte subchave do Registro e clique em Winsock:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
  4. Clique em Arquivo e em Exportar.
  5. Na caixa Salvar em, clique em Disquete de 3½ (A:), digite um nome para o arquivo na caixa Nome do arquivo e clique em Salvar.
  6. Clique em Winsock2, em Arquivo e em Exportar.
  7. Na caixa Salvar em, clique em Disquete de 3½ (A:), digite um nome para o arquivo na caixa Nome do arquivo e clique em Salvar.

    Observação Cada arquivo .reg que salvar deve ter um nome diferente.
  8. Encerre o Editor do Registro.

Importe as entradas do Registro do disquete

No computador que tem as entradas do Registro corrompidas, execute as seguintes etapas:
  1. Insira o disquete que contenha os arquivos .reg na unidade disquete do computador com os sintomas descritos na seção "Sintomas".
  2. Inicie o Windows Explorer, clique em Meu computador e clique duas vezes em Disquete de 3½ (A:).
  3. Clique duas vezes em cada arquivo .reg que criou e salvou no disquete na seção "Exporte as entradas do Registro para um disquete".
  4. Clique em Sim ao ser solicitado para adicionar as informações ao Registro.
  5. Clique em OK ao receber a mensagem afirmando as informações foram inseridas com êxito no Registro.
  6. Encerre o Editor do Registro.
  7. Reinicie o computador afetado.

Mais Informações

Esses métodos restauram a funcionalidade básica às subchaves Winsock e Winsock2. Pode ser necessário reinstalar alguns softwares proxy ou firewalls de outras empresas.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Palavras-chave: 
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